Titanium Backup - Freezing Apps


  1. sleky

    sleky Active Member

    Just rooted (YEAH!) - Basic reason: remove/freeze bloatware

    I do have a pro version of the TB. And I'm trying to go thru and freeze all the bloatware, but when I hit the "freeze" button. It says "Freezing "FM Radio 1.00"..." and just sits there. I tried it with the Amazon MP3 as well, but gave up waiting after 10 minutes and rebooted. When it came up, it showed that the Amazon MP3 is frozen. Figured that it worked, but its stuck again. Am I doing something wrong? Do I really need to reboot after each freeze? =[

    TIA!

    Advertisement
  2. exBBuser

    exBBuser Well-Known Member

    If you are not planning on using all that bloatware why freezing?Wouldn't it be better to uninstall?

    Idk I'm just saying here u might future plans with them apps.
  3. sleky

    sleky Active Member

    I am going to uninstall. But I'd rather freeze them to ensure that it doesn't cause any sort of hiccup. I want to stay as "stock" as I can. But - that bloatware HAS to go. ;D
  4. ceabbott2

    ceabbott2 Well-Known Member

    I also heard something similar. Some have had trouble upgrading stock rooted ROMS because they removed some of the bloatware. If I remember they mentioned placing the files somewhere on the sd card in a file.
  5. Mr. Ed

    Mr. Ed Well-Known Member

    i tried backing up the bloatware with titanium and then uninstalling ....titanium went through all of the motions but when trying to reinstall there is nothing in the back ups :(

    not really a big deal because we can get these apps over at xda but worth mentioning...the consensus I have read was to freeze them rather than uninstall so that you simply unfreeze later.
  6. bobthebob

    bobthebob Active Member

    I am having an incredibly difficult time finding any instructions on **HOW** to freeze apps using TB.
    I have looked at the Wiki, gone to the dev's site, tried to access the Wiki forum without success - apparently even tho I registered and have paid for my copy I do not have 'sufficient access' - and all I can find is info on backing up your apps, which I have done without problem.

    this is not a very well documented feature - which is odd considering how it is one of the biggest reasons people seem to want to purchase this app over any of the other backup apps.

    so - link anyone? instructions?
    I'd rather not just go blundering around and possibly make a big pile of doo out of some system file etc.
  7. sleky

    sleky Active Member

    Bob - I hope this sheds a little light on your frustrations. If you need more.... I can try. ^^ (*Click on the image for a larger screen shot*)

    Overview: This is what it looks like when you first open it. It'll tell you if there are any errors, what version you're using and what not. The first thing, after both rooting and installing is hitting that Problems ? button and walking through the steps to download whatever it needs to function properly.

    [​IMG]

    Frozen App: In this shot, you can see in the app list what is frozen because the line is highlighted blue. (Unsure what the Green/Red/White names mean however)

    [​IMG]

    Defrost: This app, Amazon is frozen. It won't run, won't update, won't work period. If you hit that Defrost ! button, then it will "unlock" the app for you to use.

    [​IMG]

    Unfrozen App: This app, Adobe Flash Player 10.1 10.1.95.2 is unfrozen. Had I wanted to freeze it, I'd hit that Freeze ! button.

    [​IMG]
    magicman08, tgi007 and LfcFan1977 like this.
  8. Dragon-Lord

    Dragon-Lord New Member

  9. tgi007

    tgi007 Member

    I've been getting the same symptom. Was previously running a rooted 1.47.651.1 (using whitslack's "no adb" method (tinyurl.com/2v2p5sv)), and suffered through multiple reboots after each freeze (back in July).

    I was kinda expecting that this had been fixed, but ran into the same problem (but with a worse symptom) tonight, now that I've updated to 3.29.651.5 (benefiting from myn's efforts (tinyurl.com/2943hlb)).

    What I tried was TB's new "Integrate update into ROM" feature, but it ended up hanging indefinitely (waited 25 minutes before giving up and rebooting). Since it never finished the procedure, I now had a phone with NO Gmail on it at all!

    My guess is that this new "integrate into ROM" feature depends on "freezing" the app first, and that is presumably what caused the "hang".

    After uninstalling (and rebooting) and reinstalling (and rebooting) the Gmail update, TB showed that Gmail was frozen (red text on blue background). Thawed it (another "hang"). Rebooted. I finally had to boot to the Recovery (ClockworkMod) and wipe the cache, because launching Gmail produced bizarre displays with much of the window "adornment" missing.

    Grrrrrrrrrrrrr.

    Anyone know what's causing this "hang" when freezing (or thawing)?

    HTC EVO/PC36100
    3.29.651.5 CL252548 Rooted DeOdex'd
    Kernel 2.6.32-ge2fb08e htc-kernel@and18-2 #11
    Radio 2.15.00.09.01
    WiMAX 26023_R01
    PRI 1.77_003
    Hardware 0002
  10. fozzie

    fozzie New Member

    You might want to check you've got USB Debugging enabled. It does seem to make a difference.
  11. Droidster

    Droidster Well-Known Member

    I rooted a few days ago and although TI says I have the amazon program frozen, it did not remove it from the app drawer as stated?? All other froze programs (except nova) do not appear in the app drawer.
    did I do something wrong, or is amazon such a beast it will not allow to be froze....
    .... forgot to mention... even after TI showing it is froze.... amazon restarts itself when I look under applications running
  12. dmolavi

    dmolavi New Member

    I noticed this today as well. I uninstalled the update to the app and tried re-freezing, but it still started up and showed up in the app drawer. i don't want to uninstall it, but since it can be had from the market (in the event of an OTA), i might just go ahead and do it.
  13. Matlock

    Matlock Well-Known Member

    I'll look into that Amazon bugger. When I ran the STOCK HTC SENSE ROM prior to flashing any Custom ROMs, the Amazon app froze with no problems.
  14. tgi007

    tgi007 Member

    Did you try rebooting, since the app drawer probably caches the icons (for performance)?
  15. tgi007

    tgi007 Member

    Well, that's weird. I just tried freezing Amazon, Amazon Kindle, and Amazon MP3 with Titanium Backup, and all three reported as being frozen successfully.

    Rebooted, just to make sure HTC Sense's cached icons were cleared out.

    Now when I look, there's still an icon for Amazon MP3, but not the other two. Unsurprisingly, when I tap that icon, it attempts to launch something but fails with a "Sorry! The application Amazon MP3 (process com.amazon.mp3) has stopped unexpectedly" message.

    Checking the running processes lists from Advanced Task Manager and OSMonitor I do not find anything Amazon-ish running.

    It would appear that whatever the "freezing" algorithm is, it doesn't fully prevent an app from still sitting around.

    Curiouser.

    --tgi

    HTC Supersonic | Sprint EVO 4G | Hardware 002
    teshxx's Rooted Froyo 2.2 3.70.651.1 | Kernel 2.6.32.17 #15
    Radio 2.15.00.11.19 | PRI 1.77_003 | WiMAX 27167_R01 | PRL 60674 | HBoot ENG 0.76.2000

  16. Barats

    Barats Well-Known Member

    The last time this happened to me, my phone was running extremely slow because I was running a 1.9 PRI meant for 3.7 software when I was running 3.3. So my cpu usage was 100% and my phone lagged like crazy. Check to see your cpu usage. If it's really high and your phone is slow, this will take forever. Just like a pc that is using all it's system resources. It can forever to do a command in a program.

    And like someone said, if you are never ever going to use it, just delete it.
  17. SaleenFiend

    SaleenFiend Well-Known Member

    If you create a NAND back up prior to removing/freezing Apps. Wouldn't the Nand Backup restore everything necessary? Thus, allowing the user to decide between freezing/removing?

    Also, when I first froze Amazon MP3 it was still displaying in my App Drawer.
  18. dmolavi

    dmolavi New Member

    I got the mp3 app to freeze by doing this:
    Get a terminal emulator app.
    at the console:

    su
    mount -o rw /system

    then freeze the app. reboot, and it should be gone.

    some have reported success with
    mount -o rw,remount /system

    but my EVO doesn't like the "remount" option, so I achieve that by rebooting the phone.
  19. MDtoka

    MDtoka Active Member

    So I know freezing apps stops them from running and updating and whatnot, but is it supposed to really help with memory by doing so? I froze some big ones like amazon mp3 and the sprint apps but didn't really notice any difference in memory
  20. evomattnc

    evomattnc Well-Known Member

    Good point dmolavi, I never noticed titanium not removing apps until i didnt reinstall root explorer after a flash which mounted /system as rw. Ti wont do anything until i make sure i remount as rw. remount works for me though.
  21. kandinga

    kandinga Member

    Does anyone know somewhere I can get a list of processes I can safely freeze using TB? Most of the stuff in there has names that don't really identify what it is and I don't want to freeze something I need and mess things up. Thanks in advance!
  22. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    if you got to the http://androidforums.com/evo-4g-all...ooting-dummies-guide-gingerbread-edition.html. there is a section called life after root that has a link to some of the files that are safe to remove. it is a little old so some of the newer stuff is not on there.

    also you can use titanium backup to just freeze stuff before deleting them. that way you will no if your phone will be stable after freezing them. if your phone does not freak out then you can delete them.

    also another thing you can do is flash a rom that has the bloatware removed. there are plenty of stock 4.53 gingerbread roms that have bloatware removed and some are even optimized to run faster as well. if you go here: http://androidforums.com/evo-4g-all-things-root/284413-roms-kernels-download-page.html. and go to the gingerbread 4.53 sectioni would try swag or sns roms.

    another cool rom to try is mikg2.56. it has sense 2.1 and sense 3.0 built in. it has bloatware removed and it is super fast. try it out.
  23. kandinga

    kandinga Member

    Thanks for the info on the processes. As for the roms, unfortunately I did not realize this thread was for the EVO 4G till after I posted the question and couldn't figure out how to remove the post. I have the CLIQ 2 and as far as I can tell there aren't any non-stock roms out there to flash. I've been following some threads by Tattedman but can't seem to find out if he finished his ECC Rom. Hopefully the link will be somewhat helpful even though I don't have the Evo.
  24. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    ahhhh no worries. you then the info i gave will not help you, unfortunately.

    none the less you can still use tb to freeze any unwanted apps and see if your phone is stable and if so then you can delete them.
  25. kandinga

    kandinga Member


    Thanks! Some of the processes looked similiar to what I've got so it'll definitely be helpful. Don't think I'll delete anything just because im a scaredy cat. Freezing will work for me.

Share This Page