1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Titanium Backup "parse error"


  1. sublimnl

    sublimnl Well-Known Member

    I just flashed Pete's latest ESE53 BB and cannot restore any of my apps and data with Titanium Backup. I get the error "there is a problem parsing the data". I have already tried to chmod 755 /system/xbin/busybox and still no go.

    Does anyone have any ideas before I go back to my BB 0.7.8 nandroid backup?

    Thanks!

    Advertisement
    :
  2. sublimnl

    sublimnl Well-Known Member

    I fixed this by going into the Titanium Backup options and disabling compression entirely. What sucks is that I had to buy the donate version in order to verify my backups so that I could do some reasonable testing without nandroiding back and forth.

    Anyway, hopefully this will help someone else down the line.
  3. Fadelight

    Fadelight Well-Known Member

    I don't know about the particular ROM you are using, but Chevy was having the same problems with his ROMs, and it turns out it was all because busybox wasn't correctly chmod'd.

    Before you wipe or anything, try this...


    Code:
    adb shell chmod 755 /system/xbin/busybox
    After that, try Titanium again.
  4. sublimnl

    sublimnl Well-Known Member

    ;) all good, per my 2nd post its working now. :)
  5. JasonRK

    JasonRK Well-Known Member

    I'm having the same problem, but when I try chmod I get an error "Unable to chmod /system/xbin/busybox: Read-only file system." I'm guessing this is an ID-10T error but I can't figure out what I'm doing wrong. Any help?
    -J{
  6. JasonRK

    JasonRK Well-Known Member

    I figured out that I needed to mount /system first, and I verified busybox is working with "whoami" command in a terminal emulator. I'm still getting the Parse error. Any ideas?
  7. Fadelight

    Fadelight Well-Known Member


    Wait... what? Were you in recovery when you did it? That would've been the entire problem right there.


    Code:
    Mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system

    You missed that entire step. ;) The system has to be remounted as read/write before anything can be changed.

    Some of the new roms have scripts, so before you type that whole bit out, you could try to simply type either "rwsystem" or "sysrw".
  8. JasonRK

    JasonRK Well-Known Member

    Fadelight, oddly enough I had to look on another forum to find the "Mount -o... /system" step. Live & learn.

    As to your first question, when you're asking if I was in recovery, you mean from the recovery screen (power on while holding X)? If that is the case, no, I was using Connectbot. If you mean something else, and my answer doesn't make sense, I may be less knowledgeable about the process than I thought.
  9. Fadelight

    Fadelight Well-Known Member


    Connectbot? I'm lost on that one, too. I assume it is something similar to just using ADB?
  10. destrekor

    destrekor Member

    I'm getting the same problem.

    So there is an issue with making a backup in a 2.0.1 ROM and attempting to recover it in a 2.1 ROM?
    Because that's exactly what I did. I hate wiping everything and losing all my settings and data not stored on the memory card. Haven't had to do it yet with Android since it's far more versatile than Windows Mobile, but... would really like to avoid it.

    Any possible fixes for this yet? I've changed permissions and whatnot, but... can't get it to go.
  11. JasonRK

    JasonRK Well-Known Member

    You know what, I don't think I mentioned that before in the thread, but that is exactly what I was trying to do. I went from stock root => BB 0.8.

    Honestly, I've given up on the Titanium restore. Another poster pointed out that it's a good chance to clean out the apps you don't want anymore and layout your screens more to your liking, and I'm finding it to be true. I'm already 90% back after about an hour of work.
  12. destrekor

    destrekor Member

    A bump, plus a little more fleshed out query.

    I tried moving from Bugless Beast (android 2.0.1 version) to one of the recent Simply Stunning ESE53 2.1 builds (rom version 2.0.1, android 2.1), and nothing could be restored from the backups from Titanium Backup. Some "package parse" error.

    So I reverted back to my nandroid backup for my BB install, and hell... couldn't even restore a backup I made there! Heard there are issues with the one compression format, and I saw my copy of Titanium Backup defaulted to gzip (not the one in question, supposed to be the most compatible actually). I switched to no compression and still couldn't restore even in the same ROM.

    Is it a kernel issue? Should I just install a different kernel? Tried "fixing" with TB, which supposedly installs a known-good version of BusyBox, and still no-go for restores.

    Been really, really looking at making the switch the Koush's recovery and flashing the Droid Cyanogen, but really, really do not want to go through basically starting over completely.

    I did that enough with every ROM flash for my Omnia. Just a pain in the ass when you have a lot of apps with custom settings or data attached to them.

    Well there isn't much for cleaning out on my end. Any apps I don't want I recently removed, and as far as laying out screens to my liking... well, that keeps changing so not worried about that. Been using different home screens like mad, been using a well-themed copy of Home++ I extracted from a ROM (a very stable version of Home++ too I might add), and started playing around with the HelixLauncher and really like it. So making the move to the Cyanogen Mod I actually look forward to, since apparently it has a very stable and responsive Launcher2 plus the app dock.

    I just don't want to have to re-do countless app customizations again.
    With my Omnia, it was a pain but I also didn't have a large number of apps.

    Maybe it will be a good idea to just start over again, every now and then it's a good thing, but like I do with Windows... if I can avoid completely formatting, I like to. I usually wait until there are no more options. :)
Loading...

Share This Page