1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

[TMobile] Root/Unlock (Added Video) D50010b Firmware


Last Updated:

  1. androidguy1991

    androidguy1991 Well-Known Member This Topic's Starter

    Joined:
    May 13, 2012
    Messages:
    72
    Likes Received:
    59
    Hello everyone,

    I thought I share how I rooted this device.
    I found a thread on xda and I was able to root successfully without any issues. As far as Unlocking, I have not tried that out? If you have success at unlocking please post your outcome so others will know if it works or not.

    Here is a video I made:

    Hope the video helps for some people.


    MotoChopper.zip


    Don't thank me thank roketteere over at xda for finding a root method.
    Reference: [Root/Unlock] LG Optimus F6 T-Mobile - xda-developers
     

    Advertisement
  2. umar805

    umar805 Member

    Joined:
    Feb 12, 2012
    Messages:
    8
    Likes Received:
    1
    i tried the motochopper and it fails at the adding of the su binary . it adds the superuser apk but the su binary is a no no . any help would be appreciated
     
  3. androidguy1991

    androidguy1991 Well-Known Member This Topic's Starter

    Joined:
    May 13, 2012
    Messages:
    72
    Likes Received:
    59
    You might need the drivers. Install LG Mobile Support Tool Make sure your phone is not plugged in. Click on install USB drivers on the right of it. Click the drop down and select T-Mobile and then find LGD500BK. There should be two of them. Just install the first one. Then plug in your phone and you should be able to root without any problems.
     
  4. Apoplectic1

    Apoplectic1 Well-Known Member

    Joined:
    Sep 7, 2011
    Messages:
    85
    Likes Received:
    9
    I don't suppose this would work for metro F6's would it?
     
  5. androidguy1991

    androidguy1991 Well-Known Member This Topic's Starter

    Joined:
    May 13, 2012
    Messages:
    72
    Likes Received:
    59
    I'm guessing the metro version will not work with this? People with metro said this will not work?
     
  6. marconesme

    marconesme New Member

    Joined:
    Oct 26, 2013
    Messages:
    3
    Likes Received:
    1
    I've got drivers installed via LGMobile Support Tool. I have USB Debugging on, unknown sources checked. USB connected to LG Software. When I run run.bat it:
    tells me to push any key, I do
    says waiting for device....
    daemon not running. starting it now on port 5037
    daemon started successfully

    ... then nothing

    is that is? I was expecting something more. Nothing seems to be changed with the phone.

    Any ideas?
     
  7. marconesme

    marconesme New Member

    Joined:
    Oct 26, 2013
    Messages:
    3
    Likes Received:
    1
    EDIT:
    Restarted everything and tried again. Opened LG User Support Tool, plugged phone in and waited. Device driver was not successfully installed...Details:
    USB Composite Device...Ready to use
    LGE AndroidNet USB Modem...Failed
    LGE AndroidNet USB Serial Port (COM3)...Failed
    LG-D500...Ready to use
    AndroidNet Sooner Single ADB Interface...Failed.
     
  8. androidguy1991

    androidguy1991 Well-Known Member This Topic's Starter

    Joined:
    May 13, 2012
    Messages:
    72
    Likes Received:
    59
    Try a factory reset before you try to flash the kdz.
     
  9. JoeyBiff

    JoeyBiff New Member

    Joined:
    Dec 2, 2013
    Messages:
    1
    Likes Received:
    0
    Just a quick note for anyone who's having trouble -- try Linux. I just assumed that it was a Windows only tool, and failed with both XP and 7 -- but then noticed the .sh files and tried it with Ubuntu and it worked perfectly.
     
  10. androidguy1991

    androidguy1991 Well-Known Member This Topic's Starter

    Joined:
    May 13, 2012
    Messages:
    72
    Likes Received:
    59
    I believe its for Windows, Mac, and Linux.

     
    infowarz likes this.
  11. bricbloc

    bricbloc New Member

    Joined:
    Aug 23, 2013
    Messages:
    1
    Likes Received:
    0
    Ubuntu is Linux
     
  12. infowarz

    infowarz Well-Known Member

    Joined:
    Oct 25, 2013
    Messages:
    52
    Likes Received:
    12
    Hey thanks.....
    but do you have a link to as step by step for that?
     
  13. krugercharlese

    krugercharlese Member

    Joined:
    May 9, 2014
    Messages:
    12
    Likes Received:
    3
    Any reason why the" Saferoot" method isn't here somewhere? Simple, quick, one-click...
     
  14. leorookie

    leorookie Well-Known Member

    Joined:
    Aug 27, 2013
    Messages:
    51
    Likes Received:
    17
    I have a Tmobile LG f6. I rooted it via Towelroot no problem . it's one click way...at least it worked for me no problem. Took literally 20 sec.
     
    Vulcan219 likes this.
  15. Vulcan219

    Vulcan219 Member

    Joined:
    Feb 19, 2012
    Messages:
    21
    Likes Received:
    3
    leorookie, I also used the Towelroot when I rooted my Tmobile LG f6 with no issues whatsoever. And as you said, it did it quick as hell too.
     

Share This Page

Loading...