To Everyone Who IS/WAS Having GPS ProblemsTips


  1. KappaG9

    KappaG9 Well-Known Member

    Those who have not been able to install the JH7 update OTA, here is a flash-able version of it that is the same as OTA. Flash with Clockwork.

    I897UCJH7 - OTA System, Kernel, Modem - Clockwork Flashable - Rooted - xda-developers

    Some claim this has fixed GPS others claim it has not. Make your own conclusions.

    This is what is wrong with Galaxy S GPS. Post by MR.GPS

    http://androidforums.com/captivate-...demystifying-gps-issues-samsung-galaxy-s.html

    Here is a reference page and in depth guide to GPS settings and what could work!

    GPS Settings: Performance Options (improvement) - xda-developers

    and another one

    T-Mobile Samsung Vibrant (Galaxy S) GPS fix

    Another suggested fix that seems to be helping a number of people!

    http://androidforums.com/samsung-ca...l-gps-fix-being-pushed-out-3.html#post1278062

    Original Settings

    SUPL/CP Settings
    Server spirent-lcs.com
    Port 7275
    SUPL Secure On

    Application Settings
    Operation Mode Standalone
    Hot Start
    Accuracy 50
    Use SkyHook Off

    Advertisement
    tehbishop, ys2010, mnicb and 6 others like this.
  2. Donaldkbart

    Donaldkbart Active Member

    has anyone tried this yet I'm at work and interested to know
  3. Donaldkbart

    Donaldkbart Active Member

    has anyone tried this yet I'm at work and interested to know
  4. krystak04

    krystak04 Member

    did nothing for me
  5. jbradt

    jbradt Member

    Wow... it seemed to work great for me. Yesterday when I was playing with Maps, Navigation, & trying to geo-tag photos it took minutes to lock and be somewhat functional. Maps showed me being about 1/2 mile away. Navigation seemed to be pretty close, but again, took forever to lock. Then when taking photos, the "Show on map" option put me about 1/2 mile away from where I was.

    I compared the "normal" settings in your first post to the ones on my phone, which had the original GPS settings. I found the only two things I had to do were turn Skyhook to ON and switch configuration from Custom to Auto. I rebooted for good measure, went outside, and ZING. Was locked in seconds and incredibly accurate.
  6. KappaG9

    KappaG9 Well-Known Member

    Glad it worked for you as well! I was about ready to return it and get a new one that had working gps
  7. rofflez

    rofflez Member

    is skyhook an easy setting to change, or do I need root/special app? (don't have my phone yet, but am concerned about this)

    thanks
  8. krystak04

    krystak04 Member

    whoops, looks like i forgot the reboot...mine works now..GJ kappa

    you can turn skyhook on by typing in

    *#*#1472365#*#* and its in application settings at the bottom no root needed
    Loco Leeep, naxir and Blackforge like this.
  9. KappaG9

    KappaG9 Well-Known Member

    Dial *#*#1472365#*#* and it will take you to the GPS menu and under application settings you scroll down to skyhook and switch it to ON. No need for root.
    Blackforge likes this.
  10. circazero

    circazero Well-Known Member

    this actually worked!

    i noticed when i dialed *#*#1472365#*#* my signal went from 2 bars to 4 bars!
    but once i reboot the phone it goes back to 2 bars, which is weird because with my iphone it would get 4-5 bars edge or 3g. :(

    does anyone know of any setting to change or something to do to boost signal?

    thanks!
  11. Blackforge

    Blackforge Well-Known Member

    Do not compare the number of bars on your iPhone if it wasn't running 4.0.1. You were seeing more bars than you should have been. The Captivate and my iPhone 3GS are within the same area as far as signal goes post-4.0.1 firmware on the iPhone. Actually the Captivate usually gets an extra bar.
  12. olieebur

    olieebur Active Member

    Remember iOS lied to us before for a long time and then they recently patched the signal is iOS 4.0.1. My brother has an iPhone 4 and now it shows true signal which is about lower than usual.
  13. KappaG9

    KappaG9 Well-Known Member

    Well this doesn't boost your 3G/Edge signal. It just lets you mess around with GPS settings.
  14. Donatron

    Donatron Well-Known Member

    I didn't have much problems with the GPS for the first two days. It definitely took a little while longer to lock than the Aria (which was within seconds), but it always locked. But today, while I had to visit several places, my GPS just didn't want to lock at all. And when it finally did, it was inaccurate, and would drop the connection shortly after.

    I just set those two settings mentioned, and I'll give it a shot when I drive home from work. I'll let you guys know my results.
  15. ghostfox1

    ghostfox1 Well-Known Member

    Didn't do anything for me.
  16. mjgunn

    mjgunn Active Member

    For those of us concerned about battery life, does enabling skyhook suck up any extra juice? Of course I leave my gps off unless I'm using it so I'd guess even if it does it wouldn't matter except for when I have it on right?
  17. Jreitnauer7

    Jreitnauer7 Well-Known Member

    i tried this and unfortunately this did not work for me. i've tried so many different things. i'm thjnking of taking the phone back to att this weekend. Im so frustrated with this issue.
  18. falcon26

    falcon26 Well-Known Member

    Where are you guys making this changes to files? I have no idea where to look on the phone. Also what does calling this number do?
  19. GordonE

    GordonE Member

    You don't need to change any files and dialing *#*#1472365#*#* doesn't call a number, it's just a way to get access to a configuration screen that you can't get to otherwise. After you enter that sequence, click on the "Application Settings" button that you'll see.
  20. LCDeuce

    LCDeuce Member

    Um.... Can you post what the normal settings were?
  21. Terry S

    Terry S Well-Known Member

    Can someone post these instructions for someone who has never used gps or a smartphone... so I mean in detail. Also, when you say using GPS are you referring to the Nav button on the phone? Or the Map button? or Either? Thanks
  22. amazingtaters

    amazingtaters Member

    Nothing seems to be working on the GPS front for me. GPS worked great for the first two days or so, but now I can't get the phone to get a GPS lock for anything. I've tried changing settings as described above, as well as putting them back to defaults. I run the GPS test available from the config screen, and get the same result with both settings variants: 5 to six satellites shown as being connected, but after several minutes of being connected nothing happens, the phone still has no idea about latitude, longitude, etc. This is a major pain in the @**

    **EDIT**

    I did some digging, and went over to the folks at xda forums who directed me to the Samsung Vibrant community there. I used the method described in this thread (http://forum.xda-developers.com/showthread.php?t=728611) and my GPS now works and is quick as all get out. Accuracy isn't perfect, but could be worse.
  23. Chromag

    Chromag Well-Known Member

    I'm having the same problem. The GPS worked great the first day but it's progressively gotten worse. Now if I open up Maps the satellite icon at the top just blinks and blinks and blinks and never locks. This happens indoors and out.
  24. Mugzee18

    Mugzee18 Member

    Same with me. I did as mentioned above and enabled Skyhook but didnt seem to work, even after a reboot. Getting reallllly frustrated!
  25. Donatron

    Donatron Well-Known Member

    I tried the fix, and it seems to help get a lock faster (within 1 minute), but it doesn't help at all with accuracy or the ability to maintain the lock.

    With my Tilt, Fuze, and Aria, the GPS was always very accurate and never lost its lock once it got it.
Loading...

Share This Page