To Everyone Who IS/WAS Having GPS ProblemsTips


  1. Chromag

    Chromag Well-Known Member

    I just tried it and I'm not sure it worked. When I went to google maps it did jump to my position but the GPS icon at the top was steadily "bouncing" or whatever you want to call it. I went to the Lbs GPS test and it showed it seeing 6 satellites but never locked and didn't show any long/lat info.
  2. Fixintu

    Fixintu Member

    OK, went back and turned off Skyhook. Not sure what effect that might have had but after retesting I got a lock in under 30 seconds and accuracy is at a consistent 16.4 feet. What kind of accuracy are you all seeing? Please post.
  3. amazingtaters

    amazingtaters Member



    What I've done is change my settings back to default but with the supl settings set to auto. It takes about 90 seconds for me to get a lock and accuracy hovers around the 10 meter mark. With skyhook on I get zero locked satellites.
  4. Donatron

    Donatron Well-Known Member

    Every thread on every forum seems to have a different combination of settings, all with mixed results. I'm wondering if any of the settings are really making any difference at all, or if everything is just coincidence (ex: was able to lock instantly after changing settings, but that's only because you had a previous lock a minute ago, which allows you lock on faster).

    edit: Someone also suggested somewhere that maybe these settings may only affect the GPS test application within the console, and that they aren't permanent settings that affect the way other applications (e.g. Google Maps) work.
  5. Fixintu

    Fixintu Member

    Ahh, the famous Placebo App! LOL, guess we need an uber geek to do some verifiable testing on these solutions, find what WORKS and report back. Samsung? Hello? Tap Tap,...is this thing on?
  6. KappaG9

    KappaG9 Well-Known Member

    Yeah I definitely agree that different settings work for people differently. If the GPS still doesn't work then I would say return it because I was about to do the same thing, but make sure the GPS is working at the store as soon as they swap your SIM!! lol
  7. giper54

    giper54 Well-Known Member

    sonicanatidae, athosghost and KappaG9 like this.
  8. KappaG9

    KappaG9 Well-Known Member

    Nice page! I'll add it to the first post for future references and such
  9. athosghost

    athosghost New Member

    Using this with sky hook on enabled me to get a lock indoors where as before I was getting no lock any where around my house. :D whoohoo!
  10. NOSintake

    NOSintake Well-Known Member

    Can anyone confirm if skyhook uses data? I think it does, but I won't have the phone until maybe this weekend, but I have new 2gb limit :(
  11. KappaG9

    KappaG9 Well-Known Member

    I'll post that fix on the front page as well.

    I'm not sure if Skyhook uses data, i'll get back to you on that one
  12. gflare

    gflare Well-Known Member

    I think you are over-estimating the data-usage of this...


    The only thing that will ever get you near a 2GB limit is downloading files, podcasts, streaming media, downloading game apps, downloading hundreds of full theme packages / ROMs / etc, using google maps & street view everyday for 1hr or more every single day, re-downloading all your dropbox or evernote files about 50+ times (why would you ever do that when it syncs well), etc...

    That's all I could come up with off the top of my head...

    And you can check data by dialing *DATA# and hitting 'call.'
  13. KappaG9

    KappaG9 Well-Known Member

    It does use data but i'm not sure how much
  14. meadrealty

    meadrealty Member

    tried all suggestions on Forum and no go.
    Att said do a 'Hard Reboot" but were unable to tell me how to do this.
    When I try Google maps shows I am about 15 miles away from my actual location
    and 'searching for GPS" continues till it times out {am doing this outside}
    am in Maine and thus far from satellites
    maybe as I've seen AT&T are only allowing phone to log onto a few satellites to save battery.
    Back to AT&T tomorrow doubt they will solve problem so I guess it's back to i-phone
    urg !!:confused:
  15. RingMe

    RingMe Active Member

    Sorry dude, but that cracks me up! :D
  16. emuneee

    emuneee Well-Known Member

    This actually fixed my issues!
  17. KappaG9

    KappaG9 Well-Known Member

    Good! glad it helped!
  18. mi04se1

    mi04se1 Well-Known Member

    Got my phone today and installed google nav. I couldnt even get a lock on any app that required location in my house. I went into the menu for the settings. All I changed was skyhook to on and rebooted. I tried google nav and maps and it locked on within 10 seconds in my house.
  19. KappaG9

    KappaG9 Well-Known Member

    Good. Its seems that very few devices work right out of the box. Almost always some one changes something and it starts working. So weird. An article did say that the captivate and vibrant come with broken gps but its fixable through firmware update
  20. Donatron

    Donatron Well-Known Member

    I'm really starting to believe that all these "fixes" are placebo effects. I did a hard reset this morning, so everything was reverted back to factory settings. On the way to work, the GPS was acting up as usual. But during my lunch break, and on my way home, the GPS was damn near perfect. Locked on within seconds, was extremely accurate, and never lost its lock. I made no changes to the settings at all. So improved performance was really luck of the draw (It'll probably act up again later). But had I made any changes before my lunch, I would've thought "wow, these changes really worked!!!"

    If any of you can say that after you made your changes, that the has GPS never acted up again (but give it at least a few days), I'll believe that those settings really made a difference. But at this point, I'm thinking it's just a placebo effect.
  21. Jofaba

    Jofaba Well-Known Member

    Going to wait for an official fix myself. Only real problem I've had since I haven't used it for directions yet was the clock/weather widget I'm using. When I go to maps in my apartment it locks on just fine. I turn the phone and the arrow moves smoothly and what appears to be accurately in comparison to the direction of the main road just outside my window.
  22. PaulMcCartney

    PaulMcCartney Well-Known Member

    Stuck.
  23. KappaG9

    KappaG9 Well-Known Member

    Changing the settings can change the way the phone attempts to receive gps signal so messing around with them may actually help. They arn't there to just look at...so i dunno if i would go as far as saying its rubish
  24. ruppert

    ruppert Active Member

    I think changing these setting can help, but as has been pointed out in the xda forums this is just trying to make up for what appears to be bad gps firmware. Using gps testing utilities you can see that the phone is only locking on to at most 4 or 5 satellites, where other phones will lock on to twice that many. The settings may help it lock faster, but to really fix this problem there needs to be a firmware update to allow the gps to lock on to all of the satellites it's seeing. This isn't just a captivate problem either. It's a problem on the vibrant and the international galaxy s phone as well. We need samsung to do something about this. I would suggest contacting samsung anyway you can to make them aware of the problem.
  25. ghostfox1

    ghostfox1 Well-Known Member

    So I got mine working a lot better, using the google.com setting, MS assistance, and hot start.
Loading...

Share This Page