To Everyone Who IS/WAS Having GPS ProblemsTips


Last Updated:

  1. gflare

    gflare Well-Known Member

    Yeah, if you don't mind, getting both phones as close to vanilla as possible would be the ideal scenario.

    Root and such should not make a difference in the GPS results, but after hearing all these reactions to 'placebos,' you'd avoid a mess of random discussion (not by me, haha) by getting as close to stock as possible.

    Advertisement
  2. mongstradamus

    mongstradamus Well-Known Member

    I will do that i am interested to see the results , once i do restore will just install gps test program and try , let me see if i can find odin on this laptop..
  3. dOGHAIR

    dOGHAIR Member

    Two words: Factory reset.
    :)
  4. mongstradamus

    mongstradamus Well-Known Member

    It was rooted so wanted to make sure i got every single piece of software that was on the phone when i got it so can do an direct 1 to 1 comparison.

    So the new phone and old phone sitting next to each other the new phone got 10 satellites in view only connecting 6 , but the old phone didnt connect to any and could only see 2 satellites. So i am thinking the newer phone is somehow getting stronger gps signal.

    Btw i tried using google maps and new one would connect in about three seconds old one would not ,
  5. SamsungVibrant

    SamsungVibrant Well-Known Member


    There is also an option for "factory format"

    factory reset seems to just clean off data, while format totally wipes the phone and reinstalls the firmware.

    I've done factory reset, trust me it doesn't do anything to fix the gps problem.
  6. mongstradamus

    mongstradamus Well-Known Member

    it seems so random now my old captivate is getting an pretty quick gps lock , quick for me that is about 8 seconds
  7. crydee

    crydee New Member

    I opened up the GPS Settings
    Changed from default to these:
    Application settings/Operation Mode/MS Based
    SUPL/CP Settings/Server/supl.google.com
    SUPL/CP Settings/Port/7276

    Enabled SkyHook.

    GPS worked fast and like a charm accurate within 5 meters. Took 1 minute to do.

    I had GPS working about 30% of the time and accurate within 30 meters when it did work before these changes.
  8. jmreed97

    jmreed97 Well-Known Member

    Go for a drive with mytracks and post your track... Lets see how accurate it actually is. Sometimes it says 5 meters but is actually off by much more.
  9. crydee

    crydee New Member

    I will try it tomorrow. I didn't go off what it said it was accurate by. But based on the blue dot it can tell the difference between when I'm in my apartment or parking lot.
  10. ozziedog

    ozziedog Member

    I tried the suggested settings and still didn't get the gps to work right. I drove from Dallas, Texas to Houston, Texas and the gps was not able to find my location. It kept searching for satellite. Now on the other hand if I was stopped it had no trouble finding my location. I changed the settings back to original ones for the trip back to Dallas did not show any improvement. Hope Samsung or AT&T comes out with a fix for it.
  11. c2k

    c2k Well-Known Member

    so I realized that when it told me I had an accuracy of 70m, on occasion it would show the wrong location on google maps (maybe like 1/4 mile off, a in I could see where I was supposed to be). So my guess is that was due to using wireless networks because gps test wouldn't connect to any satellites. I played with my settings and tried again. Within 30 seconds I was connected to 7 satellites with an accuracy of 16.4 ft. I also looked on google maps and it was about 20 ft off from exactly where I was standing
  12. mongstradamus

    mongstradamus Well-Known Member

    GPS seems to be pretty random for me, sometimes it works and other times not so much. Today while i was driving got solid lock within 2 seconds and never got searching for gps signal in the google nav app. So it looked like it was working out ok , but sometimes in other places i will get no lock at all

    When i ran gps test i would get between 4/8 to 7/8 lock on satellite depending where i was , so i am all around confused
  13. Vee

    Vee Well-Known Member

    I've tried everything in this thread and no matter what I can't get mine to work.
  14. nikolai

    nikolai Member

    Maybe it's just me, but when I uncheck "Use wireless networks", back out and then go back into Location and security, the box is always checked again. I don't know if this a consequence of that problem, but none of my GPS configuration changes stick either. Upon reboot, they are always the same as the default.
  15. c2k

    c2k Well-Known Member

    I don't have that problem nor have I heard of it... Odd.factory reset lol?

    I've also noticed that my gps stol has fits, it will work great, then not at all. Using gps test, it often connects to 5 to 8 satellites, then drops them, then picks up more, then drops...etc
  16. BobPaul

    BobPaul Well-Known Member

    Do you still contend that your phone is not broken?
  17. nikolai

    nikolai Member

    I did a factory reset and that problem went away, but the GPS still won't lock on. It takes a couple minutes to aquire a satellite and then it won't pick up more than 1 or 2. Of course Maps still can't tell me my location....
  18. c2k

    c2k Well-Known Member

    Well, Im just making an assumption here, and mind you its a HUGE assumption, considering the fact that thousands of other peoples phones are experiencing odd gps behavior, Im ASSUMING that mine is having those same software issues.

    But youre probably right, out of the thousands of phones with gps problems, mine is in that 1% thats actually a hardware issue.
  19. Loren

    Loren Well-Known Member

    I just took a 220 mile trip today to an area I was unfamiliar with and the GPS function performed perfectly. It did take about 5 minutes to initially lock on to the satellites but after that each destination was dead on (within 5 meters).

    From what I saw today Samsung just needs to fix the lock on to make lock on faster.
  20. bhulku123

    bhulku123 Member

    was on my deck just fem for minutes ago and i was checking this forum and when my phone was laying flat on the deck, the GPS Test had hard time locking the signal but as soon as i held vertical in my hand the sats started to show green (bars) and i got lock in maybe 5 secs. and the accuracy first was 98ft, then changed to 32ft and then 16ft. And the i opened google earth and it was showing the point right behind my house and on the deck.

    I want to have other users check this out and report it the vertical phone position makes any difference.
  21. no driver

    no driver Active Member

    Ok, so since some folks think that the GPS only works at all because of using cell towers I decided to test it out on the way home with my phone in airplane mode and the GPS turned back on.

    I switched to airplane mode + GPS while I was still in my office and started up Navigator while walking to my car because that's usually enough time for it to figure out where I am. It usually starts with a huge blue ring around my position but by the time I am done putting on my seatbelt etc it has a pretty good fix on my position. Today it wouldn't lock. So I ran GPS Test, something I haven't done much of, and it showed some satellites (6-8 IIRC) but none in use.

    Then I got a message from Navigator that it couldn't route me because it didn't have data. Duh. So I turned airplane mode off to let it load up a route home. While it was doing that, the GPS figured out where I was, so I went back into GPS test and now it was locking on more than half of the satellites. Navigator showed where I was without a blue ring. I can't say whether it was the cell towers assisting the GPS (though I tend to think it was) or if the GPS finally had enough time to start locking, but in any case it knew where I was.

    I still wanted to see if it could tell where I was on the drive home without cell towers, so I turned on airplane mode + GPS again. Navigator still knew the initial route that it had picked for me and was showing my location without a blue ring, and GPS test still showed a good amount of satellites with locks. I started driving and Navigator turned the route from blue to grey and put up a message that said something about how it couldn't get new route data but I should follow the map it had already laid out for me. GPS stayed on my position the whole way home, even though I didn't follow the Navigator route (never do, it sends me down some busy streets that I usually avoid in the afternoon). Since it had loaded up a map for my trip I was able to see my location updated the entire way and it was right on my spot. It did put a blue ring around me when I drove under a bridge, which I hadn't ever noticed before I read someone complaining about GPS losing you in that situation, but it picked me up again within a few seconds of emerging on the other side.

    It seems to me that using the XDA tweaks helps the phone use cell towers to find you initially, but once the GPS kicks in it is working through satellites and not cell towers or wifi networks that some company has tried to map.

    So far I've just been messing with it while driving around my home town, but in about a week I'm traveling to a city I haven't been to since before I could drive, so I'll have an opportunity to test the GPS when I really need it. Based on today's trip I think I'll be ok.
  22. askpcguy

    askpcguy Well-Known Member

    For the record I only provide this as a general guide, not to be considered a fix for these GPS problems. Neither I, nor the forums are to be held responsible for any damage you cause while following this guide.

    First, make a new contact named GPS Settings or something similar to help enter the GPS setting menu more easily. Enter this number *#*#1472365#*#* as a mobile number. Next enter the phone dial pad and type *#* and you will see the contact you entered popup, tap that to enter the GPS settings menu, which is called LbsTestMode.

    I'll now list my settings and the steps I use to acquire a GPS signal.

    The LbsTestMode screen has 5 buttons, labeled (from top to bottom) Get Position Test, Application Settings, SUPL/CP Settings, Test Application and Delete GPS Data.

    *About Delete GPS Data, I will use this if it's been over 8 hours since my Captivate last had a GPS fix. More on this later.

    Application Settings (which I imagine only apply to the LbsTestMode app.)
  23. BobPaul

    BobPaul Well-Known Member

  24. askpcguy

    askpcguy Well-Known Member

    Glad to see that my efforts are not welcome. This is why I hardly register for forums in the first place.
  25. BobPaul

    BobPaul Well-Known Member

    Did you even bother to read the VERY FIRST post in this thread?

    Did you notice that your "work around" is posted all over the internet already?

    Look, I appreciate you wanting to help out but at least be productive. Most of us herein are looking and waiting for the "solution" to this problem and are well aware of this work around.

Share This Page