To Make Browser Identify as Desktop...Tips

Last Updated:

  1. Jake43

    Jake43 Well-Known Member

    To make the default browser identify as a Desktop browser do the following:

    Type 'about:debug' into the address bar of the browser and click go. Nothing will happen. But open up settings and you will have a lot more options. Go down to the bottom, and it will read UAString. Open that and you will have the option between Desktop, iPhone, and Android.

    I don't believe people had found an answer to this question in the Threads I had read. if so, mods, please just delete this. Thanks.

  2. binary visions

    binary visions Well-Known Member

    Nice tip.

    Some of the third party browsers offer this as a quickly switchable option. Dolphin, Skyfire and xScope all let you quickly toggle to another user agent, which might be more convenient for some people than heading into the settings and modifying it.

    xScope remembers the setting for up to 10 domains, which is great for sites that you either always want the desktop version, or the occasional site that will respond with a mobile version to an "iPhone" user agent, but not to "Android."
    dan55 and Hrethgir like this.
  3. &roid

    &roid Well-Known Member

    Thanks......this makes facebook easier
  4. Kevmueller

    Kevmueller Well-Known Member

    Great tip!!!!
    I just tried ESPN which always wanted to open in mobile view and it opens to the ESPN web page. This was the only reason I spent the money and bought the xScope browser. The default browser is perfect now!
  5. eraursls1984

    eraursls1984 Well-Known Member

    I like the Dolphin HD browser best but I haven't found a setting to get some of the websites that open in mobile view to open in desktop view
  6. BigJim94

    BigJim94 Well-Known Member

    I had Dolphin HD and it has and add on so you can switch to desktop mode but I just put skyfire on and I gotta say I really like it. The address bar has an icon on it that you can switch from android to desktop.... I just cant seem to figure out how to move my bookmarks around so I can organize them better.... So I may go back to Dolphin HD...
  7. santangelo

    santangelo Active Member

    I turned off all animations and wow, my phone is much more slick. Thanks for the tip!
  8. ECFfighter7232

    ECFfighter7232 Well-Known Member

    hard menu button > More > Settings > User Agent > desktop


    Edit: this is for Dolphin HD btw
  9. TheXFactor

    TheXFactor Well-Known Member

    What are all those other options under the settings, debug menu for?
  10. landacre

    landacre New Member

    i typed about:debug and typed 'about:debug', but the settings options are the same (they haven't changed). Did I do something wrong?
  11. ac6ea

    ac6ea Member

    can you tell me if this still works after the update, why i ask, i have a website. that wants to make me load the mobile app. after i did the update it wants to put me back in the mobile app again. so i try the process again and i get no affect. just curious. thanks you all. have fun and enjoy the update. steve
  12. Jake43

    Jake43 Well-Known Member

    Hmm. That should work.

    It works for me. I was on the leaked 2.2 and now the OTA 2.2 and both have worked. loads as the desktop version for me.
  13. ac6ea

    ac6ea Member

    Ok, well i will try again and then let you all know. thanks steve
  14. ac6ea

    ac6ea Member

    well i dont know where to go from here, it still works on my other droid that i havent did the up date on, but after the ota its not working now. any one know why. thanks steve
  15. OLYVRC

    OLYVRC New Member

    I had same problem. A fresh reboot did the trick. :)
  16. GU4G

    GU4G New Member

    This is a great tip!!!
    I use Mobiscope for my network cam application. Originally used the mobile version on a WinMo phone, but with my Droid X I was not able to see the full screen with the default browser. Mobiscope recommended using Skyfire. Did that, but I found myself switching between the two browsers since I think I prefer the default browser. Now I don't have to switch!
  17. Coolguy71261

    Coolguy71261 Well-Known Member

    i have remote connection set up and view as desktop in skyfire hello espn3
  18. cynkrzy

    cynkrzy Active Member

    Jake43 -
    This has got to be one of the Best Tips I've found in the 2 short weeks I've had this Phone, Thanks!
  19. Lars

    Lars Well-Known Member

    I get a cazy JS bar on the screen taking up valuable real estate. Anyone know how to get rid of that?
  20. cynkrzy

    cynkrzy Active Member

    so I did this and it worked, but then it didn't.. went back to facebook and get the crappy Mobile site & when I switch it to "Full Site" with the Browser link at the bottom of the page, still won't load the recent posts.... any idea's. I went to setting and the UAString setting wasn't visible, so did About : Debug again, checked the setting and it was correct ?
  21. cynkrzy

    cynkrzy Active Member

    After you do the About : Debug, in the settings menu there is an option to disable the Java Debugging
  22. Lars

    Lars Well-Known Member

    Anyone else find that debug mode doesn't survive a reboot? I tried to create a shortcut to it and also make it my home page but you have to type it in manually. When not in debug mode it ignored the uastring setting.
  23. JohnCena83

    JohnCena83 Member

    So nice tips. Thank you for informative information.
  24. sezaro21

    sezaro21 Well-Known Member

    It's a nice tip but has to be done everytime after you exit the browser. The change in the setting doesn't stickk so this seems like a big waste. Is there anyway to make this setting stay?
  25. mahers

    mahers Well-Known Member

    If you use Dolphin HD, get the add on Desktop Toggles and all you gotta do is hit it to switch from Android Mode to Desktop mode...and last choice sticks until you change it.

Share This Page