[TOOL][APK ROOT]SparkyRoot apk root method v1.3

Last Updated:

  1. JAy3001

    JAy3001 Well-Known Member

    Thought i'd re-post this here as it is incredibly handy.

    This is for people that want Root on their Primes but do not want to mess around with the Bootloader.

    Many thanks to SparkyRoot for posting this exploit method and rhcp0112345 for the original exploit, any support requests should go to the original post here:
    [TOOL][APK ROOT]SparkyRoot apk root method - xda-developers

    Attached Files:

    ocnbrze and ylexot like this.
  2. ylexot

    ylexot Well-Known Member

    I'll make this a sticky when I get to a computer. At some point though, I'd like to make a FAQ for this section with links to root methods, bootloader unlock, and ROMs.

    Sent from my DROIDX using Tapatalk
  3. JAy3001

    JAy3001 Well-Known Member

    Sounds like an excellent idea ylexot. I for one would love an FAQ for rooting, when you pop over to XDA you are presented with a mass of confusing (sometimes conflicting) posts regarding rooting and it is not always clear that they need to mess with the bootloader to work.
  4. JAy3001

    JAy3001 Well-Known Member

    Added the new v1.3 update details and file:

    UPDATE: 3/18/2012 - v1.3 – enhancement/fix Fixed issue where if you have never opened the app backup tool before the rooting would fail due to not accepting the terms of service Added an unroot option (the current method requires superuser installed so that it can grant this app permission to unroot)
  5. JAy3001

    JAy3001 Well-Known Member

    This currently does not work with the .21 update.
  6. ylexot

    ylexot Well-Known Member

    Good thing I used Root Keeper.

    Sent from my Transformer Prime TF201 using Tapatalk
  7. hurmat

    hurmat New Member

    hey guys! i ve been directed here to ask some of my problms regarding the rooting of my prime. i am not an android experience user so quite frankly i had no idea that for rooting apps like superuser and busy box are needed. the problem that i had was whenever i tried to root it with either vipermod or sparkroot it always gave the error of extracting the file su from the system/binand neither was the busy box found and in sparky root it says exploitable file not found. atlast i grew with the idea of supersuder app and busybox (which never opens due to the error of root needed) but still i am getting the same error of extraction in ... please anyone help me out with this cuz its getting over my head since almost a month...

Share This Page