Touch Screen gone madSupport


Last Updated:

  1. dannybrazil

    dannybrazil Member

    Hello fellows,

    I have bought the MS1 and for the FIRST month of use ALL GOOD.

    Then, suddenly, the center part of the screen, when VERTICAL, isn't working.

    For example:
    When try to place a call:
    SEND button OK
    numbers 0-8-5-2 - NO

    When I call and I want to END call, the END button doesn't act.

    I guessed it was smt with the screen it self, so I was rooting it and upgraded the whole OS, and it was working again for a WEEK. suddenly the phone HAS GONE MAD, started to work by itself, calling people and starting apps BY-IT-SELF!!!

    Did another reboot etc. and again the screen center doesn't work.

    My question is:

    If it is the screen why after rebooting the first time it was working for a week or so?

    Is there any SCREEN driver or some sort of a bug update for this ?

    Thanks.

    Advertisement
  2. dannybrazil

    dannybrazil Member

    If this is the screen pic attched

    [​IMG]


    So the RED AREA that doesn't work.

    Tried it all...changed from 2.1 to 2.2 to 2.3

    cell works perfectly besides this irritating problem of BAD screen touch.
  3. dannybrazil

    dannybrazil Member

    I have installed 2 CALCULATOR apps..and weirdly...
    All the number buttons work 100%!!

    What the hell is going on here?

    Tried to install, over 5 different app dialers...NOTHING works
  4. monsterduc1000

    monsterduc1000 Well-Known Member

    I don't know if this is the same issue, but sometimes when I am scrolling something or trying to move an app it it very jittery. What I have figured out is to tilt the phone into landscape mode so as the screen changes orientation then tilt back to the upright position and all is fine. I don't know what is causing this but this little technique fixes the issue for me.
  5. Mateus

    Mateus Active Member

    Are you overclocking?

Share This Page