touch screen stops working.Support


  1. Padgett114

    Padgett114 New Member

    Once in awhile my touchscreen stops responding until I hit the power button to turn off the screen and when I turn the screen back on everything is is fine. I have mainly noticed it in google maps and games. I have all the current updates and just started doing this about 3 weeks ago. I tried a full reset and it did seem to help. Any sugestions?

    Advertisement
  2. Ziphless

    Ziphless Well-Known Member

    My phone has been doing the same thing, and just in the past few weeks. I thought it was from my dolphin browser add ons, so I got rid of the add ons. Recently downloaded a task killer and it got worse, got rid of that also, now my battery doesn't charge to 100%. Little galaxy s glitches...got to love them!
  3. matt88si

    matt88si Well-Known Member

    I was having the same issue, although I wasn't as lucky as the two of you. My phone would randomly disable the use of the touchscreen AND the haptic buttons at the bottom. However, the application on the screen would continue to run (animations continue to move, audio still playing, etc.).

    So, after this happened 3 or 4 times, I called USCC told them the problem. Did all their steps and such to try and errect the problem, but to no avail. So, they sent me a new Mesmerize. As all new devices would, it is more responsive, faster, and smoother than the last Mesmerize I had. Something about freshly activated phones makes me get chills all over.

    Havent had the problem yet with the new phone.

    Fingers still crossed... So are toes.
  4. dixie_boysles

    dixie_boysles Well-Known Member

    mine does this too. the Google Maps app is one of the main culprits that cause it. cannot wait to get an Electrify
  5. matt88si

    matt88si Well-Known Member

    I actually just had a different issue happen to me last night with my phone.

    Occassionally, my phone will randomly light up the screen without any kind notification being activated. No email, text, phone call, etc. This is something that I believe is a Samsung phone problem as this happened in Eclair, Froyo, and now Gingerbread. I've even replaced my phone via USCC's phone replacement program and still the problem persists.

    Anywho, I was sitting at my computer when I saw my phone light up. Of course I look at it to see if there was a message, but there wasn't. So I clicked the lock button on the side and set it back down. Not even 5 seconds later, the screen lit back up, but something weird happened. All of a sudden, the SD card was 'unexpectedly removed' and the signal on my phone was lost. My WiFi turned off and there was a circle with a line through it where the signal strength icon would be.

    I tried waking my phone and unlocking it, but to no avail as the phone was nearly paralyzed. Nothing seemed to work to unlock it and even holding down the power button to turn the phone off seemed to be inactive. So, before attempting to remove the battery, I held the Volume Up and Power buttons until the phone showed the Samsung logo. The phone reset and all was well again.

    Not sure what caused this issue, but if it happens again I'm calling for another replacement phone.
  6. trilogin

    trilogin New Member

    I recently activated a new mesmerize and I have noticed that when I plug it in on the charger in my house the touch screen stops working but if I use the car charger it does not seem to affect the touch screen at all. Is thos phone designed to work like this or is this something that I should contact US Cellular about?
  7. LaTuFu

    LaTuFu Well-Known Member Contributor

    Are you using the charger that was included with the phone, or a different charger? It shouldn't work that way. The touchscreen works whether it is plugged in to power or not.
  8. scott_

    scott_ Well-Known Member

    Trilogin, I had the same issue if I was using a cheap generic charger. Would charge, but I couldn't use the phone. The screen was disabled.

    The charger shipped with the phone is good, and lets the phone work when plugged in.
    I also have my charger from my old Razr2 that lets my phone work as normal when plugged in.
  9. matt88si

    matt88si Well-Known Member

    It seems that these phones require their specific Samsung-brand charger to charge and operate normally under charging conditions. I've had a sever issue like this when I used my friend's MyTouch charger on my Mesmerize. The screen did not disable itself, but began to read my gestures abnormally. For instance, if I were to swipe across the screen in a straight line, the actual line generated by the touchscreen would be completely off track (jolting up and down and acting glitchy).

    After removing the charger it began to work normally again. I have experienced some of the same recurring issues when using my fiancee's LG charger, too.
  10. trilogin

    trilogin New Member

    I see. I do not have any idea why, but now my phone screen works tegardless of it's power source. Unfortunayely for me, however, I can no longer make it switch from portrait to landscape mode.
  11. scott_

    scott_ Well-Known Member

    There is an option setting for that, but it does not work for your home screen. Its portrait only.
  12. matt88si

    matt88si Well-Known Member

    Check to make sure the Auto-Rotation is enabled from the drop-down status bar. If it is, then it should work - unless, of course, you're using a custom UI.

    edit: The above sounded odd to me after I re-read everything.

    If Auto-Rotation is enabled, but you're using the stock UI for the Mesmerize, then the home screen with not rotate into Landscape mode. However, if you're using a custom UI (such as GoLauncher, ADW.Launcher, etc.) some of them have an option to enable Landscape mode for the homescreen.

    Other than that, only a few Android phones have the capability to go in to Lanscape mode using the stock UI. That is more of a Tablet feature.
  13. BooBoo says do a factory reset.
  14. T68

    T68 New Member

    Thanks for posting this suggestion cause you saved me from resetting my phone to factory settings. I was almost blaming an APP I downloaded a few days ago.

    I happen to use a charger I purchased a few days ago, just about the same time I downloaded the app. The charger i used was not the one that came with the phone. It was a cheap made charger made in China, $10. For trying to save a few $$$ I almost lost all my data. I called the phone company and that was they were ready to do. WALA! I changed the charger to another one I had at home and now the phone is UNLOCKED and I can know make calls and use the touch screen.

    Thank you :D. Now I'm going to return this back the cheap charger to the merchant and get something else. So anyone that has this problem where your Samsung Galaxy Endulge stops working when charged, PLEASE use the original charger, simple as that! before resetting phone.
  15. T68

    T68 New Member

    *** Use another charger and the phone will unlock the touchscreen.

    Who knew!

    Not ever the phone provider knew this.

    They wanted to reset my phone.

    Sorry for the mass message. ;) I was not able to delete this one. :D
  16. theillway

    theillway New Member

    I though my phone's quirkiness was just because of my special talent for mucking things up, but apparently not!

    I have a lot of the same issues. During some apps (mostly games), my screen will stop responding. The game will keep going, but the touchscreen stops responding. Like Padgett114 said, if I hit the power button to turn the screen off and on again, things start working like normal.

    I also have a problem where sometimes, randomly, my screen won't turn off when I hit the power button. Instead, it takes a screenshot. I can snap it out of this by first hitting the back button, which makes the power button respond like normal.

    Also, lately the auto-rotate has been wrong about which way is up, and it's decided to not even try with Google Maps (it keeps north at the top, rather than doing the behind-the-shoulder view).

    EDIT: Galaxy S running Android version 2.3.4. My wife has the same phone, running on the settings the phone shipped with (she hasn't even updated any software), and hasn't ever had any of these problems.

Share This Page