Touchscreen / digitizer area not workingSupport

Last Updated:

  1. metadsign

    metadsign New Member

    Hi all first, as I am new here and discover the (great) forums ! :)

    So I had a problem and after several tries, decided I would ask here in case someone someone had some knowledge / idea of it...

    So two weeks a go a friend borrowed my tab 15 minutes to play games on it - when suddenly the tab shut off. Then I tried to reboot it, but it would'nt ! I had really no idea why ; only clue I had is I updated to ICS in late August when the update appeared.

    After some time spent looking for a solution, I decided to buy a new battery and replace it, which I did. Then yay, the tab takes the charge, so I charge it entirely with the new battery.

    Once done I finally boot up again... Yay, all seems to be working, all's here, as before... but I soon discover an entire area of the touchscreen won't work !
    It's located in the middle of the screen, like a large vertical band ; and the whole touchscreen works except here. Touch inputs won't react at all, small or long touches.

    Just in case, thinking I may have badly reconnected the touhscreen connection, I go and check in the tab a second time, but no, nothing more, it's well connected.

    Now I don't know what to think at all, I used my friend Google but did not find really similar problems...

    So just in case I could find a solution here, any idea ? :)

    Just to get an idea, the problem looks like this when I use a drawing program :



Share This Page