touchscreen not responding! help?? :( razr maxxSupport


Last Updated:

  1. fylicity

    fylicity New Member This Topic's Starter

    Joined:
    Apr 30, 2012
    Messages:
    2
    Likes Received:
    0
    ive had my razr maxx just three months now and it stopped working out of no where! i went to turn the screen on and it wont let me unlock it. the touchscreen is not working.

    every now and then it will go half way to unlock my phone but then stopes and goes back. could it be because cricket flashed my phone wrong?

    is this the digitizer that is broke? maybe a wire came loose in my phone?

    when people call i can see it and hear it, but my phone wont let me hit answer. HOW DO I FIX MY DROID??? :(
     

    Advertisement
  2. MSUgEEk

    MSUgEEk Well-Known Member

    Joined:
    Apr 22, 2010
    Messages:
    3,696
    Likes Received:
    1,418
    Happened frequently on my Original Droid. Only way I had to fix it was pull the battery...can't do that on the Maxx though, right? Try holding the power button till it goes off and then turn it back on.
     
  3. fylicity

    fylicity New Member This Topic's Starter

    Joined:
    Apr 30, 2012
    Messages:
    2
    Likes Received:
    0

    ive already tried taking out the battery and puting it back in. it was hard to take it out too! but it didnt work
     
  4. arparaspolo

    arparaspolo Well-Known Member

    Joined:
    Oct 11, 2010
    Messages:
    410
    Likes Received:
    74
    If you have the MAXX and you took your battery out, I am pretty sure you just voided your warranty. How did you take the battery out? You can simulate a battery pull by holding volume down and the power button for about 10 or 15 seconds(whenever the phone shuts off) then power back up as normal.
     
    Mesada and El Presidente like this.
  5. MSUgEEk

    MSUgEEk Well-Known Member

    Joined:
    Apr 22, 2010
    Messages:
    3,696
    Likes Received:
    1,418
    I'm afraid your phone is messed up if that's the case. Back to the factory for repairs.
     
  6. STEye

    STEye Active Member

    Joined:
    Mar 26, 2010
    Messages:
    34
    Likes Received:
    1
    I had problems unlocking the phone when it was hooked up to the charger. After unplugging it, it seemed to gain back the control.
     
  7. literck

    literck New Member

    Joined:
    May 6, 2012
    Messages:
    1
    Likes Received:
    0
    I found that when my phone gets overheated the touch screen stops working. cooling it with a fan usually brought it back to functionality.
     
  8. monty95

    monty95 New Member

    Joined:
    May 16, 2012
    Messages:
    1
    Likes Received:
    0
    OK...just had the same issue. I called Verizon and asked what to do since you cannot pull the battery. You hold down the Power button AND the Volume Down button at the same time and this restarts the phone (had to hold it down for 5-10 sec). Worked like a charm! All better (I hope) :D
     
  9. jcarver1969

    jcarver1969 New Member

    Joined:
    Jul 23, 2012
    Messages:
    1
    Likes Received:
    0
    Same problem for me and this (power button + down volume) worked great.

     

Share This Page

Loading...