Transform "USB Device Not Recognized". Can't connect to PCSupport


Last Updated:

  1. RazzMaTazz

    RazzMaTazz Well-Known Member

    When I first got my Transform and plugged it into my Gateway Windows 7 Home Premium (64-bit) desktop PC through the USB cable, it worked fine and I a was able to mount the SD card. (The USB driver was installed on the Windows 7 PC, the Transform displayed a "USB" symbol in the notification area, I was able to mount the device and transfer files to & from the micro SD card.) Ever since then, I have haven't been able to get the Transform to connect properly to the desktop PC. The PC makes a "kerplunk" USB-connected sound, and the Transform makes a connected sound (with the battery charging symbol). But the PC either displays a "USB Device Not Recognized" balloon or it displays nothing at all (with no drive icon), and the Transform doesn't display the USB symbol in the notification area. I have tried pulling the battery on the phone, restarting the PC, and trying different USB ports on the PC, but nothing works. It is worth noting that if I pull the micro USB card and insert it directly into the PC, the PC has no problem mounting the card.

    The exact same thing happened with my HP Windows 7 Home Premium (64-bit) laptop PC. It worked fine the first time, but not since.

    When I connect the Transform to one of my Windows XP Pro (32-bit) laptops (a Dell), it mounts properly. But when I connect it to another one of my Windows XP Pro (32-bit) laptops (a Toshiba), it acts like it mounts properly, but then when I open the "D" drive, there is nothing inside of it!. No amount of pulling the battery or restarting the laptop changes this behavior.

    And here's another weird thing... On the Dell Windows XP Pro (32-bit) that actually mounts the Transform properly, it will only mount properly if I use the USB cable that came with the Transform. It will not mount at all if I use the USB cable that came with my Optimus S. (However, the Optimus S will connect to any of my Win7 or WinXP PCs with both the Transform's USB cable or the Optimus's USB cable, anytime, no problem!) I have tried this many times, and it's always the same result. This makes absolutely no sense to me since the USB cabling spec is a standard and the Optimus has no problem with either cable.

    And here's another weird thing... If I try to connect the Transform to a Win7 PC, then it will not properly connect to my Dell WinXP laptop unless I first shut down the Transform. Or if I try to connect the Transform to the Dell laptop using the Optimus's cable, then it will not connect using the Transform's cable unless I restart the Transform.

    There are lots of people on various websites complaining about USB connection problems, but I have found no clear solution.

    Samsung should be ashamed of themselves for their lack of quality assurance testing before they shipped this phone.

    This crap is just mind-boggling.

    Anybody have any idea what the problem is or how to fix it?

    Advertisement
  2. [TheAndroid]

    [TheAndroid] Well-Known Member

    All computers have different settings when dealing with item drivers not certified by Windows. I had a hard time with this before as well, installed my Samsung drivers and also went into my control panels to see that the Samsung drivers were installed correctly. Guess what? They weren't and Windows asked me to browse my computer and find the appropriate drivers, I did it and my Transform began playing nice with my Windows XP. Make sure you check your settings! I wish I could help more with Win7 config. but I'm not taking my class for that until next year. I have more coding based things to do yet.
  3. fenderman

    fenderman Active Member

    Also try a different usb cable! Have had this issue with my transform new cable worked fine!!! Worth a shot! The usb cable that came with the phone didnt work! And the funny thing is that i used my Samsung Behold 2 usb cable which didnt work with the Behold 2, yet worked with my transform lol
  4. SupaphlY

    SupaphlY New Member

    One thing you might want to look for is "USB Debugging"... Make sure that is disabled. Located under: Settings -> Applications -> Development -> USB Debugging.... If that is checked then that was your problem, hope that helped.
    JohnHellis and Mista77 like this.
  5. Mista77

    Mista77 Member

    ^^^^ That worked for me
  6. RazzMaTazz

    RazzMaTazz Well-Known Member

    I already had USB Debugging off so that's not a solution for me.
  7. Cooper271

    Cooper271 Well-Known Member

    Try enabling USB debugging. If this doesn't work, download and set up PDA net.
  8. RazzMaTazz

    RazzMaTazz Well-Known Member

    I was able to solve the problem by swapping my Transform for an LG Optimus S. The Optimus connects to every PC, every time. Eff Samsung.
  9. speeder760

    speeder760 Well-Known Member

    Doesn't really solve the problem.
  10. twistedsense

    twistedsense Well-Known Member

    The problem i've had was that I couldnt have more than one device plugged in to my USB ports if they are close together. As if I have my USB printer plugged into front port A, I couldnt plug the phone into front port B. But I could plug the phone into the ports in the back of my computer, as long as nothing else was plugged in. Or unplug the printer from the front port and then the phone worked just fine. I chalk it up to my computer being about 6 yrs old though. Dont think the ports can power everything anymore.
  11. Aoc5014

    Aoc5014 New Member

    I have a very similar situation, my phone would connect to the computer via USB the first time. After being able to access the SD card from the computer one time, I would try plugging it in again and no success...

    I've found that when i ran into this probelm, rebooting the phone would allow me to connect to the computer once again.Then after same deal, i would not be able connect to the computer again until i reboot the phone again.

    Hope this helps anyone.
    thrawn_aj likes this.
  12. thrawn_aj

    thrawn_aj Member


    Rebooting the phone works for me! (Win XP SP3). Can't believe I didn't try that myself :eek:. Thanks very much!

Share This Page