transformer blue screen no graphics. help please?Support


  1. DEAD_B50_UK

    DEAD_B50_UK New Member

    Hi guys, I hope someone here can help me. i've got a 15 month old asus transformer TF101 and keyboard. Its died i think. the screen is faulty. It turns on but all i get is the rear illumination of the screen lighting up and nothing else. the caps lock light works on the keyboard and the touchscreen is active as i can turn it off by holding the side power button for a few seconds then touching the appropriate place on the screen where the power off option is, (despite the screen being blank). i've tried all reboot, hard reset, etc on the forums advice sections. I've spoken to asus who don't want to know as its just out of warranty. They will look at it for a fee. I've taken it apart and made sure the screen plug is in tight and its fine. i spent ages going over the pcb to see if there are any damaged connections but all seems fine. Really gutted as it was great before it died! if anyone can help or advise i'd be really gratefull. Thanks.

    Advertisement
    :
  2. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Hi there!

    I'm not sure tbh, it sounds really odd. Do you have a mini HDMI cable you can use to plug it in to an external display? Does that work?

    How much did Asus say they'd charge for a fix btw?
  3. DEAD_B50_UK

    DEAD_B50_UK New Member

    Hi, It works via a Mini HDMI on another tv.

    ASUS wanted
Loading...

Share This Page