Tried to root, phone won't boot

Last Updated:

  1. landovr

    landovr Well-Known Member

    I tried to root with the tools in the root section. I got the bootloader unlocked and then I clicked the flash kernel button and now the phone is stuck on the htc logo when I turn it on. It's my first time trying to root so please go easy on me.

  2. xXchrizhurtyXx

    xXchrizhurtyXx Well-Known Member

    After you unlock the bootloader you have to flash a recovery. (Hansoon's tool is the easiest way to go.)

    [TOOL] HTC Amaze 4G All-In-One Toolkit V3.0 [3-22-2012] [PERM ROOT] [Noob-Proof] - xda-developers
    ^^^ Link to Hansoons Amaze 4G Noob Proof Tool

    Then you have to flash through recovery the superuser package. Downloads - Downloading
    ^^Link for the superuser package.

    If your flashing a Kernel, make sure you flash it twice.
    (Flashing A Kernal isn't necessary, the stock kernel is the most stable)
  3. landovr

    landovr Well-Known Member

    I used hansoons tool and that's how I screwed it up. How do I fix this?
  4. xXchrizhurtyXx

    xXchrizhurtyXx Well-Known Member

    Are you able to get to the fastboot screen?
    power button + Volume down?
  5. landovr

    landovr Well-Known Member

  6. landovr

    landovr Well-Known Member

    Can someone please help me.
  7. xXchrizhurtyXx

    xXchrizhurtyXx Well-Known Member

    Of Course we can, thats what the forum is here for...

    To fix this problem, you will have to flash an RUU, which will completely return your phone back to factory settings in everyway. It deletes everything.

    Dev-Host - - The Ultimate Free File Hosting / File Sharing Service
    ^^^Download the RUU from the link^^^^

    Rename the downloaded file to PH85IMG and put it on your external sd card.

    Get into the bootloader, and the update should apply.

    When the phone boots up again, go ahead and go to HTC Software Updates and update to the latest firmware...

    Now to Root the latest firmware we will have to use Hansoons tool...

    Unlock Bootloader again using Hasoon2000's toolkit
    Once the phone reboots, setup your phone.

    Download Rom Manager so that you can flash ClockWorkMod Recovery.

    Then as stated in post#2,
    download the superuser package and flash it in CWM Recovery.
    (Make sure to put the package onto your ext sd card.

    And your done.
    landovr likes this.
  8. landovr

    landovr Well-Known Member

    Thank you so much for your help. I did what you said and put the file on the sd card but the update failed. It said "CID incorrect!" Update Fail!, press power to reboot. Is the file link you gave me for the Telus version of the phone>?
  9. xXchrizhurtyXx

    xXchrizhurtyXx Well-Known Member

    Is your phone telus, wind or tmobile?
    landovr likes this.
  10. landovr

    landovr Well-Known Member

    It is telus
  11. xXchrizhurtyXx

    xXchrizhurtyXx Well-Known Member

    landovr likes this.
  12. landovr

    landovr Well-Known Member

    So I download this and rename it and put it on sd card?
  13. xXchrizhurtyXx

    xXchrizhurtyXx Well-Known Member

    Exactly, since you are running telus.
    My fault for the first link. I thought you were Tmobile US
    landovr likes this.
  14. landovr

    landovr Well-Known Member

    Ok, I did that but the phone now automatically boots to the bootloader screen.
  15. xXchrizhurtyXx

    xXchrizhurtyXx Well-Known Member

    Did the phone install the RUU?

    If it did, just unlock your bootloader again and it should stop doing that.
  16. landovr

    landovr Well-Known Member

    How do i know if it installed it?

    It says loading ph85img and then checking ph85img.

    Anyways I unlocked the bootloader and it still hangs on the htc logo screen.
  17. xXchrizhurtyXx

    xXchrizhurtyXx Well-Known Member

    I think that you might have to go back to stock gingerbread using this RUU.
    Dev-Host - RUU_Ruby_TELUS_WWE_1.41.661.3_Radio_1.08.550L.19DC_30.66.550L.08D_release_222694_signed.exe - The Ultimate Free File Hosting / File Sharing Service

    After your back on GB
    place the ICS RUU file onto your ext sd card.
    Go into your bootloader and flash into recovery.
    It will probably show a red triangle and explanation mark.
    if it does hold the volume up button and press the power button.
    It will take you to a recovery screen.
    Click on install from external
    select the ICS RUU
    Then it will ask you to select reboot.
    Then it will reboot a few times.
    landovr likes this.
  18. landovr

    landovr Well-Known Member

    I've tried the stock gb ruu and I et an error message saying I have an incorrect bootloader version.
  19. AntimonyER

    AntimonyER AF Addict VIP Member

    Hey, I moved this to the All Things Root section. Thanks for understanding. :)
    landovr likes this.
  20. xXchrizhurtyXx

    xXchrizhurtyXx Well-Known Member

    Lets try skipping the going back to gingerbread.
    Do the steps again but skip going back to gingebread
  21. landovr

    landovr Well-Known Member

    I've tried those steps too but when I click on install from sd card its says invalid operation.
  22. xXchrizhurtyXx

    xXchrizhurtyXx Well-Known Member

    OK the last thing i can think of:

    1) Put the STOCK TELUS RUU named PH85IMG into your download folders in your phones sd card (not the ext sdcard) and also put a copy on the phones sd card.

    2)Relock the bootloader.

    3)Hope that it works :p

    Attached Files:

  23. landovr

    landovr Well-Known Member

    So I put it on the phones internal storage?

    If so how do I access the internal storage?
  24. xXchrizhurtyXx

    xXchrizhurtyXx Well-Known Member

    Oh yeah you cant boot the actual device.
    So you cant access the phones internal storage when you connect it with a usb.

    Dev-Host - RUU_Ruby_TELUS_WWE_1.41.661.3_Radio_1.08.550L.19DC_30.66.550L.08D_release_222694_signed.exe - The Ultimate Free File Hosting / File Sharing Service
    Try downloading and running this .exe
    This should take you back to stock.
    Dont put this onto your phone or sd card.
    Just connect your phone and run this exe.

    (the download is quick)
  25. landovr

    landovr Well-Known Member

    I run this with the bootloader locked right.

Share This Page