Trouble connecting my epic 4g to my computerSupport


Last Updated:

  1. pattonthegen

    pattonthegen Well-Known Member

    Hello folks

    I'm sure this is a tired subject, but I have been trying to syn my Epic 4G up to my pc over the past few weeks and have had no luck so far.

    I have downloaded the Samsung drivers from the samsung page, and even tried a diffrent set of drivers, but still no luck.

    With debugging on i get (as options from the notifications bar)

    USB debugging is connected select to siable usb debugging

    or

    USB connected select to copy files to/from your computer (when i tap on this option I get a screen that comes up, and says USB connected / connect usb storage) It thinks for a bit then says its connected but nothing happens.

    Without USB debugging on I get 3 options:

    One that says

    Charge, or teather, and one other options which i don't remember right now, but none of them do anything.

    I run windows 7 64bit and could use some help to figure out how to connect my phone and pc so i can copy over music files and pic's.

    Thanks for any help.

    p.s. if anyone has a direct link to drivers that might work that would be nice as well.

    Advertisement
  2. Gavisann

    Gavisann Well-Known Member

    This is how I do it.

    I plug in the phone with debugging disabled. I then open up device manager and look at the drivers that are not recognized. I right click the driver and click update driver. I then click browse my computer and navigate to this folder. Continue those steps until all the drivers pertaining to the phone are installed.

    Next, unplug the phone, enable debugging, and plug the phone back in. update any other drivers that appear.

    This has always worked for me.

    List of the drivers that I needed to install:
    • SAMSUNG Android Composite ADB Interface
    • SAMSUNG Android USB Modem
    • SAMSUNG Android USB Composite Device
    • USB Mass Storage Device (automatically installed by my computer)
    • and for some reason, under Portable Devices I have H:\, but my computer automatically installed that one.
  3. pattonthegen

    pattonthegen Well-Known Member


    Thanks will give this a try tomorrow, and let you know how it turns out.
  4. alanamaslama

    alanamaslama Well-Known Member

    I have the same issue, but I have a Macbook Pro. Exact same things happen when I plug it in as OP's issue. My Epic doesn't even show up as a device connected to my computer. :mad:
  5. pattonthegen

    pattonthegen Well-Known Member

    Well I tried the above recommendation but still couldn't get it to work.

    However once i connected the usb cable to a plus in the back of my pc it worked fine, and i was able to copy over music and pictures to & from my pc!!!!

    I did install the samsung usb drivers 1st then connected the usb cable to my phone, then to the back of my pc and BAM it worked.


    thanks all

Share This Page