1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Trouble going from 4.1.1 to 4.1.2 on 32gb N7Support


  1. nerdstaz

    nerdstaz Well-Known Member

    I had a 16gb N7 and grabbed a 32gb the day they first were on sale. I just realized recently that the homescreen wasn't rotating. I went into the proper menu item and checked for updates and 4.1.2 downloads fine -- but it hangs on install at about 20%. I noticed it has a different version of the OS: JRO03S than my old one which started on JRO03D.

    My question is, what can I do to get this to install? I tried clearing the framework cache and downloading it several times. It downloads fine and only hangs on about 20% of the install. I get the green android with the red triangle. After, it boots back into 4.1.1 fine.

    I decided to check the recovery screen when it got stuck to see if there was an error, and there was:

    Finding update package....
    Opening update package....
    Verifying update package....
    Installing update....
    Verifying current system....
    assert failed: appply_patch_check("EMMC:/dev/block/platform/sdhci-tegra.3/by-name/LNX:5007360:089ca6232419a5766da5b95b17362cffcbf1c610:5013504:c48f8e86c73fb2c2ba179494f5ec98e27c9e206ed5")
    Installation aborted.



    ---

    I tried to factory reset as well, twice. Same results. I am not rooted, completely stock. Haven't ever rooted or unlocked the bootloader on this device. Any ideas?

    Thanks!

    Advertisement
    :
  2. nerdstaz

    nerdstaz Well-Known Member

    Tried to sideload the update - no dice.
  3. lucky013

    lucky013 Well-Known Member

    They have been on sale for over a month. Why are you just updating now? We are up to 4.2 now.
  4. nerdstaz

    nerdstaz Well-Known Member

    I forgot to update this topic. I just unlocked my bootloader and flashed the stock image. All is well now. I e-mailed Google support and they basically said I needed to do that or have them send me a new tablet. The only reason that error occurs is if there is a corrupt file or a tampered .apk. I didn't do the latter, so it must have been a bad file.


    Thanks
  5. lucky013

    lucky013 Well-Known Member

    To the OP. I would unlock and root it with one of the toolkits available. You will have much more control and in most cases can go back to stock if needed. You should then have no problem getting updated if you have an app like OTA Rootkeeper . I never was trying to piss anyone off here. Just trying to help.
  6. lucky013

    lucky013 Well-Known Member

    Glad you got it sorted out.
  7. greystonefoot

    greystonefoot New Member

    nerdstaz can I ask I have bought the kids one each for Christmas and I have the exact same issue. What was the stock level you loaded 4.1.2 or 4.1.1. Sorry if this is a daft question.
Loading...

Share This Page