1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Trouble restoring MIUI backup


  1. cputrdoc

    cputrdoc Member

    Hi guys. I've got an HTC Droid Incredible phone, with which I've been using MIUI. I was at a conference this week and noticed how quickly my battery gets depleted, and thought "maybe MIUI doesn't have the latest battery optimizations Verizon/HTC has released in the stock ROM. If it's as simple as remembering the max charge of the battery, I could flash back to the official stock ROM, get it upgraded to whatever the latest is, charge it all the way up, then switch back to MIUI and recalibrate!"

    Sounds simple enough right? So I backed everything up, flashed over to the latest stock ROM, sure enough there was an upgrade available which I installed, and charged it up.

    Then I discovered it had unrooted my phone, and unrevoked wouldn't root it again. I used this thread to regain root by using the s-off tool, installed ROM Manager, and chose "Flash clockworkMod Recovery" which installed version 5.0.2.0 (supposedly).

    However, when I tell ROM Manager to restore the backup, it instead boots into ClockworkMod Recovery 2.5.0.5. Version 2.5.0.5 doesn't recognize my backup, claiming it can't find system.img, data.img, datadata.img, etc. and is skipping those, then "Restore complete!" Except that it has at that point corrupted the phone and it won't boot. I did use it to make a backup of the stock ROM so I was able to restore that, but not my true target.

    I thought maybe I needed to try flashing the alternate recovery console, but it still boots ClockworkMod Recovery 2.5.0.5. Same thing if I try to flash any older ClockworkMod Recovery 5.x, it boots ClockworkMod Recovery 2.5.

    I was thinking that maybe it can't find it because the images it's looking for are actually called system.yaffs2.img, data.ext2.img, etc. so I tried renaming two of them, but that changes the MD5, so it refuses to even attempt a restore.

    ROM Manager insists that what's installed is ClockworkMod Recovery 5.0.2.0. I'm thinking if I could just access that version, maybe I could restore my backup!

    It's S-ON now. Radio version is 2.15.10.07.07 so unrEVOked Forever won't install.

    Help?!

    Advertisement
  2. sdrawkcab25

    sdrawkcab25 Guides Guide

    Do you still have root access?
    If not you will need to follow the directions found here:
    http://androidforums.com/incredible-all-things-root/427344-how-root-2-3-4-downgrade-get-s-off.html

    And not to make you feel bad, but what you were attempting to do, would not have helped you with battery life anyway. Every ROM is a self contained entity. When you install miui it runs solely on what is coded into the rom. You would of have been better off just booting into clockwork and doing a factory reset.

    Your battery problem is going to be due to either a degraded battery, some settings tweaks, or an app gone haywire... Or you possibly just had terrible reception.
  3. cputrdoc

    cputrdoc Member

    Yes, I'm still rooted.
  4. cputrdoc

    cputrdoc Member

    Battery: Yeah, I knew I had terrible reception there (thus the reason for trying to get every mV out of it that I could!), but I did notice when I was using MIUI that even if the charge light was green, if I turned it off and plugged it in again it would go red for a while, implying that perhaps MIUI was stopping it from charging all the way. Of course, repeatedly unplugging and replugging the charge cord while the phone was off was doing the same thing, so either I was slowly approaching maximum or the phone was trying really hard to charge it more but couldn't.
  5. sdrawkcab25

    sdrawkcab25 Guides Guide


    That's known as bump charging, and what you are seeing is a hardware "feature" of the phone. You will get the same results on a completely stock phone.

    When the phone is off, whatever rom/kernel you are running has no control over the phone, or how it charges.
  6. cputrdoc

    cputrdoc Member

    Update: I tried flashing to a vanilla MIUI ROM and using its version of ClockworkMod to restore, but still having trouble with the flashed CWM not being what actually shows up in the phone. Besides that, what comes in the image is CWM 3.x, and my backup is from 5.x.

    How can I blow away CWM 2.5.0.5 before I try flashing something else?
  7. sdrawkcab25

    sdrawkcab25 Guides Guide

    You won't be able to flash another version of clockwork recovery unless you are s-off.

    The only way to do it without s-off is to use the version of unrevoked in the thread I linked (3.22) and replace the recovery before running the program.
    (as is described in the thread)
    cputrdoc likes this.
  8. cputrdoc

    cputrdoc Member

    Yup, that did it! First time I followed those instructions I only went as far as gaining root and assumed I could restore backups from there. It didn't occur to me that the rest of those directions are important too. (in retrospect I feel dumb about it...)

    Thread can be closed.

Share This Page