Trouble Rooting ASUS Transformer Infinity TF700T (4.1.1 Jellybean)


  1. SteveWHamilton

    SteveWHamilton Active Member

    When I bought this tablet about a month ago I'm pretty sure it had ICS on it. but i did some firmware updates and now my version is at 4.1.1, which i'm assuming is Jellybean.

    But anyways, i want to root it and ran into a bit of trouble. I found a guide that claims the root procedure for ASUS's Prime tablet also works for the TF700T/Infinity. So i downloaded the drivers and installed them, as well as the DebugfsRoot_Generic_v2.3 files.I also made sure to run the included batch (.bat) file as Administrator. it went thru the usual yadayada as i followed the instructions, and then i hit these errors:

    Waiting for device to be detected...
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    Found system partition at: /dev/block/mmcblk0p1
    Step 1 - Pushing files...
    failed to copy 'debugfs' to '/data/local//debugfs': Permission denied
    failed to copy 'su' to '/data/local//su': Permission denied
    failed to copy 'debugfsinput' to '/data/local//debugfsinput': Permission denied
    failed on '/data/local/tmp' - Permission denied
    link failed File exists
    Rebooting...
    Once your devices has finished restarting,
    Press any key to continue . . .

    As you can see, the files failed to copy and permissions were denied, even though i followed the instructions to the letter. i have done nothing else to this tablet except install some non-root apps from Google Play, and the firmware updates.

    After doing all this i did a bit of research and found that this doesnt work for rooting Jellybean.

    So my question is, is there something i can do to make the above method work? if not, then how about a method for obtaining root after Jellybean is installed? or perhaps a guide to rolling back to ICS so i can then root using the above guide, and then update to JB while still retaining root? i'm not open to unlocking the bootloader, since that voids the warranty (which i dont really care much about, but still.....) and, more importantly, prevents me from applying OTA firmware/system updates. I dont plan on installing any custom ROMs, dualbooting alongside Windows 8, etc, so i see no need to unlock the bootloader, since it's normally/rarely necessary to obtain root on a device. I have bricked some phones in the past so i'll need something that's nearly foolproof, while still being able to run the latest Adroid JB version.

    I also tried restoring my tablet to the factory defaults via the menu functions, but i'm still at 4.1.1.

    Well, if anyone can help then please reply soon. Thanks!

    EDIT: also forgot to mention that i tried to use Win 8 Pro RTM x64 to do the root procedure. i really dont think that would have caused it to fail, but it's entirely possible. when i initially plugged my tablet into the laptop it appeared in Windows Explorer but Device Manager showed my tablet as having driver issues (exclamation mark [!] beside the driver's name). So i manually installed the drivers as it was listed in the root guide.

    Advertisement
    psilocybe38 and esparks004 like this.
  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    ok i have not checked lately but i think JB has not been rootable yet. when you are thinking about rooting any device stick to this rule and you should never have any issues: NEVER DO ACCEPT ANY OTA'S(OVER THE AIR UPDATES). this applies to any device whether it be a tablet or phone. with each new ota, it will most likely close any exploits used to gain root. so now you will have to wait and see what the devs come up with to get the tablet rooted. also with each new update it will get harder and harder to root your device.

    as far as factory reset goes, this only wipes data. it does not wipe any previous updates. once you accept an ota there is not turning back.
  3. SteveWHamilton

    SteveWHamilton Active Member

    Thanks for the reply, but i've been working on this for the past couple of hrs and my issue is solved. i'm currently back at 4.1.1 Jellybean again and Root Checker has verified that root is in place. the su binary is also present and all apps that need root work properly (Busybox, Titanium Backup, etc). i've also rebooted and rechecked several times to be sure, it say rooted every time now, whereas it didnt before. I managed to do all of this without unlocking the bootloader as well, even though what i've read elsewhere says it is necessary to do so.

    I would have agreed with you before on your point that OTA updates are irreversible, and they usually are, but my experience today shows otherwise. however, you are right that each OTA will probably make it harder to reroot or stay rooted. you're also right that factory reset only wipes data but not firmware, which i just recently figured out today before you posted. i used the "about tablet" section in settings both before and after my steps below to verify that i had indeed downgraded/upgraded firmware/Android versions from JB to ICS and vice versa.

    here are the steps i took, in sequential order, so that maybe anyone else with my issue can benefit. i cant gaurantee it will work for everyone:

    1. downgraded from 4.1.1 JB firmware to "Eee Pad Transformer Pad Infinity TF700T Firmware: V9.4.5.30 Only for US SKU (Android 4.0.3)". This will roll you back from Jellybean to Ice Cream Sandwich. go to support.asus.com, enter TF700T as the model number, and scroll down until you find this, then download it and unzip the zip file to the root of your sdcard (there is a zip file within the downloaded zip, place that at the root, not the downloaded file itself). if you are using a TF700T that is not US-based then download the appropriate file for your region, just make sure that it has .30 in the file name. I read on a forum somewhere that this is the only firmware update for this device that enables downgrading from higher version to 4.0.3, although it's possible that others may work. then power off your device and do a cold boot (hold down left volume and then followed by power button, do this for about 10 seconds. when you get to the desktop/start screen you will see "Safe Mode" in lower left corner, then your device will notify that an update is available. tell it to apply and let it reboot. when it powers back on you should be back at 4.0.3

    2. Do a factory reset, this can be done either before or after the step above, but i did it after. i'm not sure if this is necessary , but just to be on the safe side. back-up all important info, apps, etc beforehand

    3. I used the method at Simple Guide to Root TF700T Asus Transformer Pad Infinity : Tips For Tab . this guide can also be found at other websites, but the steps are the same and the files/utilities needed are the same as well. just follow the steps. this will not work if you are still at 4.1.1, you will get the error i detailed in my last post.

    4. Download Root Checker (to verify root access) and make sure you have the latest Superuser installed from Play (SuperSU may also work but i'm not sure, i'm using the paid version of Superuser Elite). and also get Voodoo OTA RootKeeper (free), this has a function that will allow you to restore root access after upgrading to 4.1.1. Superuser Elite also has a "ota survival" function that does essentially the same, both worked for me (this software isnt free). and get Busybox and a terminal emulator like Better Terminal Emulator or Android Terminal Emulator. i'm not even sure if these last 2/3 are absolutely necessary, but they install essential must-have functions that all root users should have.

    5. then use RootKeeper and make a backup of the su binary, or place a checkmark beside the "ota survival" function in Superuser Elite. either will backup the su info so that it can be restored.

    6. Next, do a direct OTA upgrade to 4.1.1 JB , either by using the built-in firmware update function, or by manually downloading from the website and updating using the method listed above. Do NOT do a restore to factory backup state after this point (especially after), it will most likely wipe out the backups of su made by RootKeeper/Superuser Elite.

    7. after the upgrade is finished you will be back at start screen at at 4.1.1, use Root Checker and it will say you're not rooted. Then use either of the 2 programs ive outlined to restore the su binary from the backup. in SU(E) just uncheck and recheck the OTA Survival box, or in RootKeeper just restore from backup. Then go back to Root Checker after doing either of these, it should say rooted. reboot and recheck to make sure.

    8. That's it! just wash, rinse and repeat when the next firmware update is available, hopefully these same steps should work

    Also make sure to keep a backup of the su binaries/app from here onwards, otherwise at some point in the future you may lose the ability to simply restore from backup after each OTA Firmware update. you will have to start over from the beginning.

    I'm sure someone figured this out already, but i figured i would post anyways.
  4. SteveWHamilton

    SteveWHamilton Active Member

    ocnbrze, i just now noticed your thanks, glad to see someone other than me benefitted.
  5. novox77

    novox77 Leeeroy Jennnkinnns! VIP Member

    My understanding is that ASUS is root-friendly; that means that they give us an open and free method to unlock their bootloader. Once you unlock it, they won't intentionally lock it back up via an OTA.

    Historically, people (with various ROOTED Android devices) run into issues with OTAs that upgrade the bootloader, and the manufacturer, having NOT blessed tampering with bootloader security, automatically sets the lock back in place as part of the OTA. At best, it means you lose root; at worst, your phone/tablet is left in a weird state that is not recoverable (brick). Because that worst case possibility exists, those of us that have helped lots of people with such issues generally issue a blanket statement that you should never accept an OTA while rooted, or if you plan to root. It's simply not necessary to take OTAs if you have root or plan to root, so why risk a potentially big headache?

    Fortunately for us Infinity users, once you unlock the bootloader, you always have a way to get root, or get root back. The current known root exploits are for pre-JellyBean. It's good to know that you can simply downgrade to get root.
    psilocybe38 likes this.
  6. SteveWHamilton

    SteveWHamilton Active Member

    novoxx77: did you even bother to read my (2nd) post? and you're right, ASUS is root/unlock-friendly, in that they do give us a method for unlocking the bootloader. however, that method is permanent, and so far as i can tell, ther eis no way, official, ununofficial, or otherwise, to revert back to a locked state. also, please note that one does *NOT* need to unlock the bootloader to obtain root. if you had read my post you would see my statement that my bootloader is still locked. rooting and unlocking are independent of each other. and while it's probably wise not to accept an OTA while rooted, those of us that choose to do so usually face, at worst, loss of root, which can be easily reobtained in most cases. in the case of a brick, that's a different scenario, and a device can be bricked regardless of being rooted/not rooted or locked/unlocked. i choose to accept OTA updates because i believe that doing so may provide additional functionality, features, enhancements, etc. although one day i will try a custom ROM, in that case then accepting OTAs will be completely unnecessary.

    Quote: "The current known root exploits are for pre-JellyBean. It's good to know that you can simply downgrade to get root."

    There actually is a known exploit for gaining root after upgrading to JB, however, it involves unlocking the bootloader. i found a method to do so without unlocking, it simply involves downgrading, rerooting, upgrading, and then rerooting again.
    ocnbrze likes this.
  7. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    yes your post definitely deserves a "thanx" and a "like". i will be using your suggestion this weekend to root my tablet.
  8. novox77

    novox77 Leeeroy Jennnkinnns! VIP Member

    I did read your post, and my response was more for the community than you specifically. My intent was to justify why ocnbrze stated never to accept OTAs if you're thinking of rooting or already rooted. Clearly never say never applies here, as it does with select Android devices, but as a general rule of thumb, it's good advice.

    I'll point out as well that even though unlocking the bootloader is not necessary for root (I myself obtained root before deciding to unlock the bootloader), having an unlocked bootloader makes preserving or restoring root access super simple, simply because you have access to the custom recovery. Simply flash any ROM with the su binary already packaged. Contrast that with your downgrade procedure... But I understand the warranty implications of unlocking the bootloader, which is why you went to the lengths that you did.

    One just needs to weigh the benefits of an unlocked bootloader with the drawbacks. Personally, I've never ever needed warranty support for any soft/firmware issues. The only time I'd need warranty has been hardware issues, and for those, an unlocked bootloader is inconsequential (verified with ASUS). I take full responsibility for the damage of my device on a firmware level now that I've unlocked the bootloader.
    psilocybe38 and ocnbrze like this.
  9. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    I somehow missed all these posts, but I went through the same ordeal and did it basically the same way. Downgraded. Rooted. OTA Rootkeeper (and Elite, just to be sure). Upgraded. Restored root from backup. Worked like a champ.

    When the 10.4.4.18 hit, I panicked for a half second - them remembered that I still had my backup. Sure enough, I just restored the backup and was rooted again.

    I now see 10.4.4.20 out three - I'm taking the plunge, and hopefully all should go well.

    Note: If you want to be safe, when you make your backup, then later restore it, do not delete the backup/I] - this will allow you to restore it again in case another update breaks root.

    Note: When you go to make a backup of root, first be sure to update the su binary via the Superuser app. That way you won' get random notifications that your su binary is out of date later on.

    HTH
  10. paschi

    paschi New Member

    I tried to find the TF700T Firmeware V9.4.5.30 only for WW. This Version is not on support.asus.com. All the download links i found in google doesn't work. Wher can I download this, od does anybody has a this version to share?
  11. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    They deleted them.

    My guess is that since it is a full install, they deleted all the old ones. I only have hte US versions.

    Let me pull up the XDA thread with all of them in there....
  12. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

  13. terrypearson

    terrypearson New Member

    When you downgraded, did your recovery screen go to an android lying down with a red exclamation point? Every time I attempt to flash, it does this. Then the device eventually reboots and I am not given the option to "upgrade" to the older version.

    (I was able to do this successfully before, but I lost root because I had not backed up OTA Rootkeeper properly so I was redoing it. So now I cannot get it to work.)

    Any ideas?

    --- Edited
    I want to retract my question. But I can see how it would be confusing so I will just add this for the next guy... When you reboot, your tablet goes into safe mode automatically after ten seconds. No need to press any buttons!
  14. trancend

    trancend New Member

    You can definitly roll back an OTA update. I rolled back my TF700t when the 4.1 update broke root back when it first was pushed. I'm back on 4.0.3 to this day.

    Anyone know if Root Keeper will preserve root on a TF700t going from 4.0.3 to 4.2 ? I really need the bug fixes of 4.2.

    Thanks.
  15. jhawkkw

    jhawkkw Chinchillin' Moderator

    I've used rootkeeper successfully through all the otas so far.
  16. SticksUWP

    SticksUWP New Member


    Terry, I am having the same problem you initially had when trying to downgrade to ICS. I get the android symbol with him lying on his back with the exclamation point. So basically what your saying with your "edit" to your comment is to just sit at that screen for a little while without pressing anything and it should proceed with the option to downgrade? Can you elaborate more on how you got past the screen with the "dead-looking" android? It'd be greatly appreciated! I gave up the other night when I got to this screen lol.
  17. knesbey

    knesbey New Member

    I'm have the same exact problem as explained by SticksUWP. I've been trying to root my tf700t with JB for some time now and I'm getting extremely frustrated.
  18. knesbey

    knesbey New Member

    I'd also like to ask if anyone out there have or knows where I can get my hands on the 4.0.3 firmware image, it is no longer available on the asus site. As per all the preceding conversation... I kinda need this file but cannot find it anywhere...HELP PLEASE!
  19. esparks004

    esparks004 Well-Known Member

    Im not trying to bash you, but you must always read, search, read and read some more. The answer to your question was in post 12 of this thread.

    Here you go: http://forum.xda-developers.com/showpost.php?p=33037501&postcount=1

    Scroll towards the bottom under the section that says Old Firmwares.
  20. terrypearson

    terrypearson New Member

    Sorry about taking so long to reply, we had the random screen crack issue that plagues the Transformer series (Sidenote: Be careful with your keyboard dock, if your screen is not installed perfect, the keyboard can put stress on the glass and crack it when it heats up) and our device went in for a warranty repair...

    If you got to the "dead" Android, you went to far. Try letting go of the keys sooner. If you are holding them when it gets to the first screen, let go right away, or it will redirect you to the "dead android" screen.
    colchiro likes this.
  21. gilbery007

    gilbery007 Member

    Has anyone managed to figure out how to get to JB yet? I downgraded back to ICS a while back and rooted but whenever I try to upgrade to JB manually I always seem to lose root access? I was quite happy on ICS but have noticed my tab getting quite sluggish and constantly freezing on most apps, so would like to upgrade to JB. Also when I try and update via the tab it says no update available when clearly there is JB to update too. Any help in getting to JB rooted would be much appreciated.
  22. jhawkkw

    jhawkkw Chinchillin' Moderator

    Is your bootloader unlocked? If so that's why you can't get the OTA. Also, installing the factory image will always unroot you. So if you want rooted jellybean then you have to take it as an ota.
  23. gilbery007

    gilbery007 Member

    No it's not unlocked due to voiding the warranty, haven't had it that long so don't want to void it.

    I am trying to upgrade manually to JB from the http://forum.xda-developers.com/showthread.php?t=1734005 thread and the JB manual upgrade download. When installing this manual update though I lose root everytime. I have tried the same method 4 times now and gave up when I didn't have any luck.

    I have been resetting to factory which puts me on ICS, I then root which I am able to do just soon as I try and update to JB manually I lose all root access even when trying restore the root.
  24. jhawkkw

    jhawkkw Chinchillin' Moderator

    Yeah, updating in general will destroy root on any device. However, apps like voodoo ota rootkeeper can protect root but only if the update is applied in recovery. Using fastboot to apply the update manually will not allow the app to protect root. What needs to be done is use the downgrade method to root and then get the OTA to your device. You said the option to update says there is no update?
  25. gilbery007

    gilbery007 Member

    Exactly what I have done, Voodoo OTA rootkeeper shows all boxes as checked which is what I want but if i go into Settings, About Tablet and hit System firmware update, then hit Check Update it says "There is no update for your device currently"? And yes i'm connected to my Wifi. Everytime I try this whole process which after the second time gets quite tedious I always end up here stuck on ICS.

Share This Page