Trouble rooting S2 I9100 - keeps crashing PC


  1. Chris159

    Chris159 Member

    New here, so apologies for any noob mistakes...

    I'm trying to root my new S2 I9100 - I followed the guide on this site, even watched the video and read it in full before starting. I've located the correct kernals (KI4, have tried all 3 varieties), and everything works until i start to run Odin 3.
    it connects, I click start, and about 5 seconds in I suddenly get a blue screen with white text saying

    "A problem has been detected and Windows has shut down to protect your computer.

    BUGCODE_USB_DRIVER"



    And a bunch more text below, including

    "Technical Information:

    *** STOP 0x000000FE (0x00000001, 0x00000000, 0x00000000, 0x00000000)"



    Then Shortly

    "Beginning Dump of Physical Memory"

    After Which it restarts my PC. I have tried reinstalling the drivers (just reinstalled Kies), ran windows update, then ran out of ideas. Thankfully it hasn't bricked my phone - I have to remove the battery to restart it (stuck in "ODIN MODE", with the android robot and "Downloading... Do Not Turn Off Target!!" in the centre), but it seems to work by using recovery mode once I put it back in.

    Oh, and I did enable USB debugging mode, but only after the first crash (didn't see it in the video).

    Any help which could be provided would be great, I'd love to root it but can't seem to get anywhere with it (and, like I said: noob, so apologies if I take a bit to catch on).
    Cheers!

    Advertisement
  2. Chris159

    Chris159 Member

    Update: Kies wants to update my software - I've allowed ti, and I think it's updating the kernel from KI4 to a different one - will try Rooting with the new kernel to see if that fixes it.

    Also, It just occurred to me that when using Odin3, the ID:COM box turns yellow when my phone is connected, rather than blue. In case that's of any significance...
  3. Slug

    Slug Check six! Moderator

    What OS is on the PC, Windows XP? Vista? Windows 7? The 0x000000FE error can occur on all of them but the solutions (hotfixes) available vary.

    Btw, the ID:COM box should correctly be coloured yellow when correctly connected.
    Chris159 likes this.
  4. Chris159

    Chris159 Member

    I use Win XP Home.

    I tried upgrading the firmware via Kies, but I get the same 0x000000FE error as when I tried to root with Odin3 once it's nearly installed, and again have to use recovery mode to start the S2 again.

    Off to bed soon so might not be back on until tomorrow now. Thanks for replying!
  5. naith_kk

    naith_kk Well-Known Member

    See this link to see why you're encountering that problem. You need to upgrade your Windows XP to Service Pack 2.

    or...

    Use another computer with XP SP2 and above to do your rooting.
    Chris159 and Slug like this.
  6. Chris159

    Chris159 Member


    Strange, I was sure that PC has SP2...

    But have used my work PC, worked fine and now sucessfully rooted. Thanks for the advice though, I'll check my home PC this afternoon for SP2!

Share This Page