1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Trouble rooting - stuck at "Starting Fastboot USB download protocol"


  1. akamad

    akamad Well-Known Member

    Hi all,
    I have the ASUS Transformer TF300T. I decided to root the device.

    I was following the steps as listed on a couple of websites, including here. I successfully unlocked the bootloader (I know this because I get the message in the top left corner when booting the device). I am now up to the step of running fastboot.

    The problem is, when I restart the device and get into fastboot mode (using the power+volume down button), I get a message stating "Starting Fastboot USB download protocol". It unfortunately doesn't move on from that message. I checked "fastboot devices" on my computer, but it doesn't pick up anything.

    I tried in both Windows and Linux. Both have the same results. If I have the tablet turned on normally, I can run "adb devices" and it shows up (so I'm assuming the drivers are all ok).

    Any thoughts or things to try out? I have tried enabling USB debugging and as I mentioned I tried on Linux and Windows.

    Thanks!

    Advertisement
  2. akamad

    akamad Well-Known Member

    Problem solved!

    Turns out the device doesn't turn up when running "fastboot devices". I proceeded to flash the recovery image and it worked fine.
  3. V SuperUser V

    V SuperUser V Well-Known Member

    Yes, i was going to say that at least windows wont show if the device is plugged or not, not even after running the command "fastboot devices", trying to flash something is how you know if its actually connected or not. (found this out doing the NVFlash)
  4. naykam0810

    naykam0810 Member

    For me is not working, I enter the fastboot command a it tells that file cannot be found or something like that

Share This Page