Trying to connect your Nexus to Windows XP? Samsung says: "No working MTP drivers yet"Support


Last Updated:

  1. dzuckman

    dzuckman Active Member

    I just got off the phone with Samsung "level 2" tech support. I have been trying to get my Nexus to connect to my Windows XP host (it's actually in a VirtualBox VM running under Linux, but anyway...) so that I can transfer files to it.

    I downloaded the drivers from Samsung's support site, and the drivers install fine.

    But, when I go to connect the phone to it via USB, I get the plug-and-play error: "The required section was not found in the INF."

    Samsung tech support said that the drivers they supply do not work with Windows XP, and that there are simply no MTP drivers for the device available yet for Windows XP. The support guy actually made it sound like they were waiting for Google to make the drivers available.

    Anybody find anything different? As it seems to stand right now, you can't connect your Galaxy Nexus to your Windows XP computer via MTP.


    EDITED TO SAY: SOLVED, Upgrading Windows Media Player from version 9 to version 11 solved the problem! Thanks Kevmueller. Samsung tech support was simply wrong.

    Advertisement
    jruther2 and GrandMasterB like this.
  2. Steven42

    Steven42 New Member

    I downloaded the drivers from the samsung site last night and installed them. I went into explorer and the nexus was listed. My phone had to be unlocked for it to work.
  3. syntrix

    syntrix Well-Known Member

    I downloaded the MTP microsoft drivers for XP. Required a reboot.

    Then installed the samsung drivers.


    Shows up in XP just fine. I can't copy single files over, but I was able to drag directories over to the SGN.

    If you want to only pull files off, like pics from the SGN, PTP mode worked the first time and I was able to pull files to the laptop, but not the other way around.

    edit: google around these are the filenames:

    SAMSUNG_USB_Driver_for_Mobile_Phones.exe (I found this on a mediafire server).

    mtppk12.exe (googled, and took me right to the microsoft.com page).

    Don't know if the MTP was required, but that's what I did.
  4. BringTheRain403

    BringTheRain403 Well-Known Member

    I downloaded straight from the Samsung support website yesterday at work and installed them with no problem.
  5. dzuckman

    dzuckman Active Member

    Hmm... for those that are getting this working, can you please confirm that you're on Windows XP?
  6. syntrix

    syntrix Well-Known Member

    yes, 6 year old corp provided laptop, IT only supports XP.
  7. syntrix

    syntrix Well-Known Member

    I'll also add that it won't show up as a drive letter in `my computer`.

    It shows at the bottom under `other` and as a device called Galaxy Nexus.
  8. BringTheRain403

    BringTheRain403 Well-Known Member


    ^^^what he said. I"ll also up the ante here...I work for a bank and the computer I installed them on is friggin locked down like Fort Knox and I had absolutely zero issues getting it to work...
  9. Kevmueller

    Kevmueller Well-Known Member

    Here is what I did to fix this on my work computer. I upgraded to Windows Media Player 11 and then with the Samsung drivers everything works 100% correctly now.
    GrandMasterB, dzuckman and drbugsmn like this.
  10. drbugsmn

    drbugsmn Well-Known Member

    This. Works great, though I didn't explicitly install the samsung drivers, just wm11.
  11. jokeefe10

    jokeefe10 Well-Known Member

    yeah, make sure you have the latest windows media player and uncheck debugging mode on the nexus. mine has been working fine on XP.
  12. NOVAdroid2151

    NOVAdroid2151 Well-Known Member

    Also, make sure you are using the USB cable that came with the nexus.. when I tried using another cable, it wouldn't recognize it, but using the one that came in the box, it worked. Weird, I know.. .
  13. MMcCraryNJ

    MMcCraryNJ Well-Known Member

    Not to knock anyone here still using it, but I'm actually kind of glad that current devices have issues interfacing/connecting to XP boxes.

    XP needs to die already. Really. It's from 2002. All of the current excuses that people or businesses throw out there for still using it have been debunked. It's not as stable as 7. It's definitely not as secure as 7. Sure you need greater hardware to run 7, but unless you are still using PCs from 2004, it shouldn't pose any sort of issue.

    I get that IT departments and such are underfunded and don't want to deal with migration hassles. But come on. It's a decade old system.
  14. Dubbin1

    Dubbin1 Well-Known Member

    I don't even bother plugging my phone into the computer, WiFi Explorer or Air Droid is where its at.
    dzuckman likes this.
  15. syntrix

    syntrix Well-Known Member

    Lot's of Enterprises save the Capital Expense of buying the new software. Why buy it when XP works just fine? :D:D
  16. dzuckman

    dzuckman Active Member

    Upgrading Windows Media Player from version 9 to version 11 solved the problem! Thanks Kevmueller. Samsung tech support was simply wrong.
    GrandMasterB and Crashumbc like this.
  17. dzuckman

    dzuckman Active Member

    Further notes-- Using a micro-USB cord other than the one that came with the phone did not make a difference, and leaving USB Debugging on did not make a difference.
  18. Crashumbc

    Crashumbc Well-Known Member


    Note: this worked for me also, no special drivers used (just let XP SP2 download generic) then upgraded to WM11
  19. GrandMasterB

    GrandMasterB Go Go Gadget Flow! VIP Member

    3 weeks I have been trying to figure this out..... You my friend, have a very special place in my heart. ;)

    THANK YOU!
  20. Tim K

    Tim K Well-Known Member Contributor

    Also, if you are still having problems, download and install pdanet. The drivers for that work perfectly. Most unlocking/rooting threads suggest it since the samsung drivers are hit or miss....mostly miss. You can uninstall the software and the drivers stay.

    PdaNet -- USB Tether/Bluetooth DUN for Android
  21. GrandMasterB

    GrandMasterB Go Go Gadget Flow! VIP Member

    Thanks, I'll keep that in mind. The funny thing is I have been using wugs toolbox for the past several weeks and the drivers works fine in adb and boot loader mode, I have locked and unlocked, rooted etc, several times. I was just unable to transfer any personal items to the device until I upgraded WMP.....weird.
  22. dhworph

    dhworph Well-Known Member

    What I did is connect phone to computer and then launch windows update... microsoft then saw that I needed a hardware driver. This fixed all my issues perfectly... got usb tether and mtp working perfectly (well, as perfectly as is possible probably).

    I tried WMP11, pdanet, google drivers, samsung drivers... none of that worked for me... just had to do windows update for the right driver...

    I find Samba Filesharing to be much more reliable than MTP (It works when I'm on wifi hotspot --- haven't tried it with wifi tether app though). And use ADB for pushing to root folders.
  23. jamor

    jamor Well-Known Member

    hmmm didnt work

    I was able to install the samsung driver, abd driver and root my device.. but not the MTP driver.

    So it does not recognize my device without the MTP driver (tried the exe and WM7)

    It's just this work PC though. It's piece of crap XP (so awful) so I'm always looking for work arounds.. doubt they will ever upgrade PCs.

    I have a state of the art desktop at home with windows 7 and everything installed fine..

    I guess I'll have to stay productive ;)
  24. jamor

    jamor Well-Known Member

    Got it working!

    Take that CrapXP!

    I uninstalled and reinstalled all of the drivers and downloaded the MTP driver directly from microsoft and it worked.

    Not sure if upgrading to Windows 11 did anything or not
  25. deaconrayne

    deaconrayne New Member

    I am running Windows XP. When I upgraded to Windows Media player 11, it solved the problem and my phone mounted

Share This Page