Trying to get Comcast.net email to linkSupport


Last Updated:

  1. Barth39

    Barth39 Member This Topic's Starter

    Joined:
    Feb 15, 2010
    Messages:
    15
    Likes Received:
    0
    hey guys, ive been trying to get my comcast.net email to link up to my Evo, so far every time Ive tried I just get error messages. I had it up and running in one try back when I had my palm pre. Anyone else have a comcast.net email working on their Evo. Please help! Thanks!
     

    Advertisement
  2. vtwin-racing

    vtwin-racing Well-Known Member

    Joined:
    May 22, 2010
    Messages:
    61
    Likes Received:
    15
    Mine works (receives at least), i don't understand how you can have an issue besides mail server names. mail.comcast.net and smtp.comcast.net and your username/PW are all that needs to be done. Rest (security) is default. If your getting send error, it could be Comcast not allowing 3rd party relay (when your not on comcast internet to send) But i haven't tried to send.
    By default it checks every hr Mon-Fri, so i made it manual so it wouldn't use battery.
     
  3. vtwin-racing

    vtwin-racing Well-Known Member

    Joined:
    May 22, 2010
    Messages:
    61
    Likes Received:
    15
    Ok just did a send test, works fine.
    So i have send and receive working just fine with settings above.
     
  4. mapan83

    mapan83 Active Member

    Joined:
    Jun 5, 2010
    Messages:
    29
    Likes Received:
    2
    My comcast.net works for both sending and receiving. What errors do you seem to be getting? Maybe we can narrow down the issue that way?
     
  5. sikclown

    sikclown Well-Known Member

    Joined:
    Nov 21, 2009
    Messages:
    1,910
    Likes Received:
    965
    Are you trying the automatic email setup because that won't work. When you go to set it up and you put in your email address and password you need to select manual setup and use the settings from the posts above.
     
  6. thebrain

    thebrain Active Member

    Joined:
    Dec 2, 2009
    Messages:
    44
    Likes Received:
    6
    incoming settings
    protocol: pop
    pop server : mail.comcast.net
    security type: none
    server port 110

    out going settings
    login required
    smtp server: smtp.comcast.net
    security: none
    port 25

    I am guessing your port settings are wrong
     
  7. thezlog

    thezlog Well-Known Member

    Joined:
    May 5, 2010
    Messages:
    69
    Likes Received:
    6
    I used to work for comcast. You have the incomming mail settings correct, however i would definitely suggest using port 587 for your outgoing. In a lot of areas, comcast has disable port 25 to fight against virus spammers.

    In some areas, you can use SSL with outgoing 465 and incomming 995. You may need to use these ports with SSL to check your e-mail on non-comcast internet (i.e. through 3G/4G, etc).
     
  8. lpd411

    lpd411 New Member

    Joined:
    Jul 7, 2010
    Messages:
    1
    Likes Received:
    0
    ""I used to work for comcast. You have the incomming mail settings correct, however i would definitely suggest using port 587 for your outgoing. In a lot of areas, comcast has disable port 25 to fight against virus spammers.""


    -Thanks the 587 outgoing port worked for me finally! Yeah, Comcast is a pain to setup.
     
  9. daleale

    daleale New Member

    Joined:
    Oct 12, 2010
    Messages:
    1
    Likes Received:
    0
    Hi all, I just got an EVO 4G and have set up my comcast mail. I've used port 995 for incoming and 465 for outgoing (I actually used 587 but it defaulted to 465). mail.comcast.net for incoming. SMTP.comast.net for outgoing, my security is set at none. I am receiving emails just fine but can't send them. They show up in my sent file so they are not sitting in my Outbox, so they appear to me that they are sent but are not. Any ideas?

    Thanks in advance.
    Dale
     
  10. sikclown

    sikclown Well-Known Member

    Joined:
    Nov 21, 2009
    Messages:
    1,910
    Likes Received:
    965
    Everything I can find says POP port is 110, SMTP is 587, and outgoing server requires authentication. Use the same login as incoming server.
     
  11. thebrain

    thebrain Active Member

    Joined:
    Dec 2, 2009
    Messages:
    44
    Likes Received:
    6
    Mine is set up with 110 for incoming and 25 for smtp, no security on either. I got the settings from comcast's site.
     

Share This Page

Loading...