Turn off google calendar sync??Support


Last Updated:

  1. imasmartmonkey

    imasmartmonkey New Member

    I recently got the droid x and relinquished my blackberry curve. I love this phone but I have one major problem. I am a psychologist, and use my X to schedule all of my appointments, and keep track of my clients. Because of legal issues and client privacy laws, I need to keep my phone from syncing my Google calendar to the internet. I can't have that information out there. I use Gmail for all of my email and contacts and such, but every time I turn off Google sync on my phone it syncs again the next day. I don't want to just kill all syncing, or I won't get my email anymore. Any ideas? I am also up for finding an "offline" calendar that has the same principals of Google calendar, but has no syncing ability. HELP?!

    Advertisement
  2. Podivin

    Podivin VIP Member VIP Member

    I have a different phone than you, so the menus might be a bit different, but give this a try.
    Menu > settings > accounts & sync > click your google account.
    Under there do you have three choices
    Sync Contacts
    Sync Gmail
    Sync Calendar

    If so, uncheck Sync Calendar
  3. mxsjw

    mxsjw Well-Known Member

    Another way...
    app drawer > calender > press hard menu key > more > calenders > and you can turn on and off your sync and visible options for calenders only in there.
    npothier likes this.
  4. BookLover

    BookLover Well-Known Member

    You're going to have to do a little work...

    1) PRIVATE, HIPAA Appts, you need to add to your PHONE calendar. This will prevent them from sync'ing to Gmail. Good news is that when you add an event on your phone, it automatically defaults to your Phone's un'syncable calendar. -- So I would recommend you do this FIRST. Manually add all those HIPAA appts from your Google Calendar to your phone calendar.

    2) After you do 1 above, DELETE all the HIPAA appts from your Gmail calendar OR if the majority of your appts were HIPAA appts, then simply DELETE the ENTIRE Gmail calendar. You do this online in the Calendar settings.

    3) Add back into your GMAIL calendar any appts you share with family, friends, etc. Those will automatically sync down/up to your phone. If you add them on your phone, make sure you select your Google calendar when you add the event.

    The phone will distinguish between your Phone appts and Gmail appts with different color bars in front of the appt.

    Same thing with your contacts...HIPAA contacts, add manually to your PHONE'S contact list, sync'able contacts, add to your Gmail contacts list (easiest to do this part on a computer).

    I'm going to assume your HIPAA contacts sometimes email you, so you probably have their email in your Gmail contacts, which is ok. Let that sync to your phone. But once on your phone, you can "link" that email to your Phone's HIPAA contacts, so that you connect their phone numbers with their email addies. Just do one and test the linked contact to make sure that by linking the phone contact to the Gmail contact, doesn't put all the HIPAA contact's into Gmail (as I'm not sure of the outcome of this linking).

    HTH
  5. duckydotcom

    duckydotcom Member

    I am having the same problem - for a very similar reason, in fact! However, the suggestions by mhotovec and mxsjw do not work. The phone resyncs anyway, despite being told (numerous times) not to. Plus, when I uncheck the calendar associated with my email, it tells me I have to have at least one calendar synced to google. I contacted Motorola Support and they were useless. I'm trying to figure out Booklover's solution. I do not seem to have a "private calendar" or "unsyncable" calendar on my phone? The only calendars I am able to find are the one linked to my email, which presumably is the one uploading to Google all the time, and the US Holidays one. Is there another calendar somewhere I'm not aware of? Or did I somehow delete it by accident? Any help would be so greatly appreciated. I'm using a downloaded offline calendar app, which is getting me by, but not really doing everything that the Droid Calendar could do. I would really like to be able to use to valuable feature of the phone, without publishing private information all over Google. Thanks in advance!!!
  6. Statikk

    Statikk New Member

    I was so frustrated by finding this out once I came over to a Dell Streak myself.. Been using HTC HD2 with Outlook and Win Mobile.. was a bliss but the 5" android Dell got me :)
    I joined up here just to be able to contribute and offer my help on this Google crap.

    Anyway I have a solution for you but it involves Rooting the phone and using Titanium Backup Root.. I did this on my Dell Streak Froyo 2.2

    Root the Phone and get Titanium Backup Root on your device and Open it. Then do the following.
    1) Go to Backup Restore Option and find the following entries
    Calendar 2.2
    [CALENDAR] Calendar Storage 2.2
    Calendar Sync Adapter 2.2.1
    2) Tap on the last entry "Calendar Sync Adapter 2.2.1" and when the options come up simply select "Backup" (just in case) and then select the "Freeze!" option.
    DONE! No more sync of calendar to Google Cloud..

    What does Google think.. Nobody cares about privacy anymore.. This is why Blackberry is still around!!
    This method also can be applied to stop and prevent further syncing of contacts to the cloud too :)

    Hope this was helpful!!
  7. Statikk

    Statikk New Member


    Yes, the calendar kept syncing on its own accord even though all syncing was disabled. If you happen to Open the calendar and go to the mxjw's solution you would find that there is a button with two images on it..an eye and a sync.. Tapping this once first turns off the eye and then second tap turns of the sync but then tapping again to try to get the eye (Visibility of the calendar) back also brings up the sync option and upon exit from here the calendar would sync to the cloud regardless but with my method I have yet to see it try!! :)
  8. gac

    gac New Member

    This worked really well for me on my Zte v9 tablet running overclocked cyanogenmod 7 (gingerbread) and ClockworkMod Recovery

    Many thanks
    insaf_mohd likes this.

Share This Page