Turn your laptop into a hotspot

Discussion in 'Computers & IT' started by whs37, Feb 10, 2013.

  1. whs37

    whs37 Well-Known Member
    103

    Jan 29, 2011
    597
    113
    103
    Male
    retired
    Florida/Germany

    Advertisement
    Rxpert83 likes this.
  2. Unforgiven

    Unforgiven -.. --- - / -.. .- ... ....
    Moderator
    9,128

    Jun 23, 2010
    32,354
    30,465
    9,128
    Male
    Douglas, MA
    I moved this to computers and IT so it would hit a better audience.:)
     
    mikedt and Rxpert83 like this.
  3. whs37

    whs37 Well-Known Member
    103

    Jan 29, 2011
    597
    113
    103
    Male
    retired
    Florida/Germany
    OK, no problem.
     
    Rxpert83 likes this.
  4. nickdalzell

    nickdalzell Well-Known Member
    Contributor
    223

    Jun 17, 2011
    4,849
    871
    223
    Owensboro, KY
    easier in Ubuntu. go to gears icon on top right corner, open system settings, network, then click 'wireless' and select 'create hotspot'
     
  5. whs37

    whs37 Well-Known Member
    103

    Jan 29, 2011
    597
    113
    103
    Male
    retired
    Florida/Germany
    Yeah, sometimes Linux is easier - but only sometimes. I just won a 3 day battle trying to install the VMware tools for Linux on my virtual Zorin system - but I won. For my virtual Windows 8 system that was a 2 click affair.

    I am not a Linux guru but I know the basics. But their Terminal (command line) is intimidating.
     
  6. mikedt

    mikedt 你好
    Guide
    7,028

    Sep 22, 2010
    20,138
    10,393
    7,028
    Teachaaa
    Jinan, China
    I've never heard of Zorin, except that he was the villain in one of the James Bond 007 movies. :D

    But I've found that different distros can be either really easy. Two clicks and enter password with Ubuntu and Linux Mint for VMware Tools and VirtualBox Additions. Or on the other hand Red Flag Linux* can be a wrestling match and really frustrating to make it properly supported in a virtual machine environment....I gave up in the end. It seemed to be mostly dependency problems....(dependency hell).

    Presumably VMware and Oracle only really develope and test their virtual PC environments with most popular mainstream distros, like Ubuntu, Fedora, etc. And not things like Zorin or Red Flag.

    * http://www.redflag-linux.com/en/ ...it's Chinese and I don't really recommend it.
     
  7. Speed Daemon

    Speed Daemon Well-Known Member
    213

    Jul 12, 2012
    2,033
    557
    213
    That was probably a clue. :D People need to realize that having the Linux kernel in it isn't a guarantee that it all works.

    That's another one where the name alone is sufficient warning. In auto racing: "The solid red flag is displayed when conditions are too dangerous to continue the session." Usually the red flag comes out because of a crash. :rofl:
     
    mikedt likes this.
  8. Unforgiven

    Unforgiven -.. --- - / -.. .- ... ....
    Moderator
    9,128

    Jun 23, 2010
    32,354
    30,465
    9,128
    Male
    Douglas, MA
    Speed Daemon and mikedt like this.
  9. whs37

    whs37 Well-Known Member
    103

    Jan 29, 2011
    597
    113
    103
    Male
    retired
    Florida/Germany
    Mike, You should try Zorin once - it's fun. I made a little video: Having fun with Zorin - Windows 7 Support Forums

    And if you want to install the VMware tools, those are the commands that work:

    sudo apt-get update && apt-get upgrade
    sudo mount /dev/cdrom /media/cdrom
    cp /media/cdrom/VMware*.tar.gz /tmp
    sudo umount /media/cdrom
    cd /tmp
    tar xzvf VMware*.gz
    cd vmware-tools-distrib/
    sudo ./vmware-install.pl
     
    mikedt likes this.
  10. mikedt

    mikedt 你好
    Guide
    7,028

    Sep 22, 2010
    20,138
    10,393
    7,028
    Teachaaa
    Jinan, China
    I could try it out, but it'll have to wait till next week now. I'm using pre-paid 3G EV-DO wireless due to location, so no distro downloads for the moment. I've read about Zorin OS this morning. Seems that it is Ubuntu based, and is aimed at Windows users.

    When I ran Ubuntu and Mint in a virtual environment, with VMware and VirtualBox, everything worked straight away. No need for the CLI at all.

    I've got Mint on two laptops, which is what I've settled on for my OS of choice.
     
  11. SUroot

    SUroot Well-Known Member
    1,113

    May 25, 2010
    23,925
    5,304
    1,113
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    Yep, good example...

    Turn Win 7/8 into VPN server:

    • Network Connections
    • ALT > File > New Incoming Connection.
    • Select a local user or create a new user
    • Select "Through the internet"
    • Select Protocol "IPv4" for example
    • Allow access

    Turn Ubuntu into a VPN server:

    • sudo apt-get install pptpd
    • sudo gedit /etc/pptpd.conf
    • Add:
      [HIGH]localip x.x.x.x
      remoteip x.x.x.x-x[/HIGH]
    • sudo gedit /etc/ppp/chap-secrets
    • Add:
      [HIGH]# client server secret IP addresses
      dan pptpd danspassword *
      [/HIGH]
    • sudo /etc/init.d/pptpd restart
    • sudo apt-get install libwrap0-dev debhelper
    • sudo apt-get source pptpd
    • cd pptpd-1.3.0/plugins
    • sudo gedit patchlevel.h
    • Change:
      [HIGH]#define VERSION "2.4.3"[/HIGH]
      To:
      [HIGH]#define VERSION "2.4.4"[/HIGH]
    • sudo apt-get -b source pptpd
    • sudo dpkg -i pptpd_1.3.0-1ubuntu1_i386.deb
    • sudo dpkg -i bcrelay_1.3.0-1ubuntu1_i386.deb
    • sudo /etc/init.d/pptpd restart

    Of course clearly, Ubuntu is much more configurable. Also, Windows didn't like my VPN server yesterday as the Remote access service fails due to an attached device "not working", which I haven't identified yet.

    If you want the less secure IPSEC VPN on ubuntu, its much more complicated. This insecure PPTP one is simple
     
  12. whs37

    whs37 Well-Known Member
    103

    Jan 29, 2011
    597
    113
    103
    Male
    retired
    Florida/Germany
    Yes, that is correct. It has a start menu a la Windows and is relatively easy to get around - until you need Terminal.

    I have to try Mint again. Last time I had some problems with it, but I forgot the details.
     
  13. whs37

    whs37 Well-Known Member
    103

    Jan 29, 2011
    597
    113
    103
    Male
    retired
    Florida/Germany
    mikedt, Davdi and palmtree5 like this.

Share This Page

Loading...