Turning off T9?Support


Last Updated:

  1. OT_Mark

    OT_Mark Member

    Is there a way to turn off the T9 on the Galaxy?

    I've tried telling it not to autocomplete words but it's still got the T9 activated by default in text messages, so I have to press the T9 button before starting every message i write.

    I should point out that this is with the qwerty keyboard disabled...

    Advertisement
  2. Andronix

    Andronix Well-Known Member

    settings, locale, keyboard, show suggestios
  3. informale

    informale Well-Known Member

    or install some other keyboard form the Market.
  4. OT_Mark

    OT_Mark Member

    I don't have 'show suggestions' as one of the options in my menu... :confused:

    Didn't even think of that!

    Any one you'd recommend in particular?
  5. informale

    informale Well-Known Member

    Well, the best one is the keyboard from HTC, but it isn't on market, you'll have to google for it 'htc_ime.apk'. You may encounter a version for Android 1.6, so look watch out what you're downloading. Once downloaded, copy it to your SD card (unless you've downloaded it directly from your Galaxy's browser). Go to phone Settings -> Applications and tick 'Unknown sources'. You'll now need Appmanager (available from Market) or any other ap that can install apk packages from SD card. Suppose you open Appmanager. Press menu, hit Install. If your apk is not in appmanager folder on your SD hit menu again and choose Whole SD. It'll find your apk, now you can install it.

    After installation go to phone settings again. Locale and text. Tick Touch Input and confirm in the window that pops up with a warning. Now to use the new kbd go to any app with a text input filed. Long press and choose input method. Choose Touch input.

    Now this way you'll probably only have English kbd. I managed to get Russian-English by setting my phone locale to Russian (even though my firmware doesn't actually have that lang, can be done with an app called MoreLocale from Market). You can try your language as well, but I'm not sure which kbd layouts are actually present in HTC's kbd. Anyway, whatever you do, don't ever touch the Keyboard Language setting under Settings -> Locale & Text -> Touch Input. It only contains English and if you select it you'll lose you dual keayboard. You'll probably be able to restore it by resetting the phone's locale, though.

    If you have root access on your Galaxy, you can follow these instructions to enable the language you want (and you can also check out the lust of supported languages):
    http://ostebaronen.dk/?p=190

    As for the others, I used AnySoftKeyboard for a while, but now I'm totally on HTC's kbd. AnySoftKeyboard is actually very good, it has a nice feature - swipe touch gesture to change layouts. But the design is not very ergonomic, esp. when compared to HTC's kbd.

    Just search for different keyboards and see what's best for you (HTC, HTC, HTC! %) ).
  6. lazarus101

    lazarus101 Well-Known Member

    I had TouchPal and I liked it a lot although it was a bit slow. The great thing about it was that after you pressed a letter key if you moved your finger up it would capitalized it, if you moved it down it would select the symbol. Now after wiping my phone I couldn't find TouchPal on the market anymore :( (if anyone has it installed or the apk and the english language pack send me a PM pls :D )
  7. kam187

    kam187 Well-Known Member

  8. midi24

    midi24 New Member

    To turn off T9, with my phone in my hand
    settings/Locale and text/
    Under Text settings select Swype or Samsung Keypad settings,
    switch off predictive, keypad sweeping, Auto-capitalization.
    Ive just done it as I typed this.

Share This Page