Turning off wifi is freezing my phoneSupport


Last Updated:

  1. mersault

    mersault Member This Topic's Starter

    Joined:
    Jun 30, 2010
    Messages:
    11
    Likes Received:
    0
    Hi guys,

    Am pretty happy with my Spica, but over the past day or two am having a major problem with my phone freezing completely when I try to turn its wifi on or off.

    Basically, the phone's occasionally losing its wifi connection (I sometimes pick it up, unlock it and find that the connection's down). The only way to reconnect is to turn the wifi off, and then back on - but often when I try to do this, the phone freezes completely, and I'm forced to pop the battery out and turn the phone back on.

    I'm running 2.1 btw. Anyone have any suggestions? It's driving me crazy!
     

    Advertisement
  2. Beerkan

    Beerkan Well-Known Member

    Joined:
    Apr 14, 2010
    Messages:
    720
    Likes Received:
    166
    Have you ever heard of Tommy Cooper?

    Famous British Comedian...

    One of his jokes..

    "I went to the doctor the other day, I said "it hurts when I do this"
    He said "Well don't do it then."
     
  3. mersault

    mersault Member This Topic's Starter

    Joined:
    Jun 30, 2010
    Messages:
    11
    Likes Received:
    0
    Presumably you were too eager to tell your joke to bother to read my original message. Whenever my Spica is idle, it drops its wifi connection, and the only way to get it to reconnect is to turn it off and back on again

    When I do this, 2/3 times out of 5 the entire phone will freeze up, and I'm forced to pop the battery out and back in.

    So, dated jokes aside, your suggestion is to simply get used to not having wifi on my phone?
     
  4. merlin002

    merlin002 New Member

    Joined:
    Jul 24, 2010
    Messages:
    2
    Likes Received:
    0
    I'm experiencing the same thing. I'm also trying to upgrade but it won't let me. At first I thought it was my wifi widgets that was causing it, but once it happened in the built in wifi utility after i tried turning wifi off.

    When the phone wakes up, the status is stuck at "scanning..." and when you try to turn it off, it hangs the entire phone. I'm gonna try to reset to factory defaults.

    btw when i try to flash, the phone shows up as Gadget serial control and Samsung USB composite device (but that is probably a different issue)
     
  5. pseud0

    pseud0 Member

    Joined:
    Jun 1, 2010
    Messages:
    5
    Likes Received:
    1
    How are you switching WiFi off/on? Are you using the Switchers app or Settings. Does it help to enter and then exit Airplane mode? I've had to do that on occasion to reestablish 3G or WiFi connections.

    Since this is a change in behaviour it is a question of eliminating what has changed recently on the phone/network. Have you noticed any specific network apps running when this happens? Have you added any new apps recently that might have changed the behaviour or made any changes to the wireless network. I guess the WiFi will power-save at some point, it may be worth experimenting with screen lockout settings to see if this has any effect on the frequency of the issue.
     
  6. merlin002

    merlin002 New Member

    Joined:
    Jul 24, 2010
    Messages:
    2
    Likes Received:
    0
    It has happened using several widgets and in the built-in wifi app.

    I posted my way of dealing with this problem here: Turning on WiFi causes phone to freeze

    "disabling wifi sleep solved the problem for me. this makes sense to me because sometimes i download big files and i wouldn't want to get disconnected when the screen goes to sleep. we just have to be a little more responsible in managing battery life.

    ... but yeah, it would be greAt if that feature worked. A setting for WiFi sleep on inactivity would be great too."

    But then I did a little more searching and found this:
    Issue 8067 - android - Wi-Fi drops when left idle in "Never Sleep" policy for Wi-fi Connections - Project Hosting on Google Code

    It seems the nexus one also has this problem
     
  7. vickyfin

    vickyfin New Member

    Joined:
    Aug 6, 2010
    Messages:
    1
    Likes Received:
    0
    Hey yes it been solved. just turn off the wifi sleep policy to "Never" and instead of waiting for 30minutes. just turn off and turn on the phone. it will be looking for Wi-Fi connection and scans it automatically. My cell phone is Samsung Galaxy S. Hope it works for you
     
  8. dialallama

    dialallama New Member

    Joined:
    Jul 10, 2011
    Messages:
    2
    Likes Received:
    0
    I'm afraid I can't add anything new, but wanted to confirm that I am having exactly the same problem.

    It's been a while since the last post - has anyone found any new fixes? I don't really want to drain my battery with wifi constantly on.
     

Share This Page

Loading...