[Tut] How to install Darktremor's a2sd on Froyo!!


Last Updated: 2012-08-10 22:25:10
  1. praky

    praky Well-Known Member

    This method will COMPLETELY move your apps from phone memory to sd card.
    This method has been tested on a rooted Galaxy Ace running Froyo. This won't work with gingerbread.

    Requirements:
    You need your phone to be rooted.
    a2sd_enabler.sh.zip (The Script file)
    dtapps2sd-2.zip (Darktremor 2.7.5.3 Beta 04)
    Either ADB to run commands on PC (android sdk) or Terminal app on phone

    Please note that this script sleeps for 8 seconds at boot time to make sure that the SD card is loaded before mounting.

    Instructions:
    1. Backup all data, both on your phone and your SD card. Your sdcard will be wiped clean.

    2. Partition your SD card as following: 1st partition FAT32, 2nd partition ext2. (you can start with 1-2 GB. Make sure that you use ext2 only, as ext3 and ext4 are not supported by the stock kernel)
    -->Reboot into CWM recovery
    -->In android system recovery, select partition sdcard
    -->In the partition sdcard menu, select partition sd
    -->Follow the instructions on the phone to partition your sd card. You can optionally set a swap file while you are partitioning your sd card.
    For a complete guide to partition your sd card, go here.

    3. Insert your SD card and make sure that your phone recognizes it correctly.
    Connect your phone in Mass Storage mode, then extract the contents of "a2sd_enabler.sh.zip" to your SD card root directory. Also copy dtapps2sd-2.zip to the root of the sd card & rename it as "update.zip"

    4. Disconnect mass storage. Open command prompt, navigate to your android sdk->platform-tools folder and execute:

    Code:
    adb shell
    su

    OR
    hit up terminal app & type:
    su

    5- Type in the following commands (try copy-paste each line then hit enter):
    Code:
    cp /sdcard/a2sd_enabler.sh /data/local/tmp/
    chmod 755 /data/local/tmp/a2sd_enabler.sh
    /data/local/tmp/a2sd_enabler.sh


    6. To double check everything, reboot your phone and login again as root through adb,(or hit the terminal app) then run the following command, and find a line similar to the highlighted line in the output below:
    Code:
    su
    df

    Output
    Code:

    /dev: 142220K total, 12K used, 142208K available (block size 4096)
    /mnt/asec: 142220K total, 0K used, 142220K available (block size 4096)
    /cache: 25656K total, 12K used, 25644K available (block size 4096)
    /data: 185240K total, 36768K used, 148472K available (block size 4096)
    /system: 213376K total, 211520K used, 1856K available (block size 4096)
    /system/sd: 1032088K total, 38512K used, 993576K available (block size 4096)
    /mnt/sdcard: 6783016K total, 190356K used, 6592660K available (block size 4096)
    /mnt/secure/asec: 6783016K total, 190356K used, 6592660K available (block size 4096)

    7. Now you're good to go. Reboot into recovery and select "apply update" & then select file "update.zip". Reboot.
    And you're done.

    See the origin thread @Xda-developers here

    If you have problems, please post them here.

    Advertisement
  2. praky

    praky Well-Known Member

    So nobody tried it yet?

    Knew that the article seems too complex. :p
  3. shaaan

    shaaan Well-Known Member

    Or no one uses Froyo anymore..
    :D;)
  4. praky

    praky Well-Known Member

    hehe!! correct.
    The method on gb is so f**ked up that if I post it here, people will faint. :p
  5. alfienoakes

    alfienoakes New Member

    Ok, so I just tried to do this.

    HTC Desire with Froyo.

    Phone rooted.

    copied files/ renamed as instructed to root od sdcard

    open adb shell

    when tried to do cp command got a - not found error

    tried to explore /data in the shell and access was denied

    used root explorer on the phone to manually move the file to /data/local/tmp

    executed the next 2 commands and got

    Remounting system partition as read/write..
    [: not found
    ERROR: System partition couldn't be remounted, are you on root-aid? (error code 0)


    bit stuck as to what's happening and where to go next, please advise:confused:
  6. yagya

    yagya Well-Known Member


    Please run su command first and make sure you provide root access to adb or terminal in your phone. Then try typing the commands. :)
  7. praky

    praky Well-Known Member

    also make sure usb debugging is on.
  8. alfienoakes

    alfienoakes New Member

    Thanks guys but debugging was enabled and definitely typed 'su', tried to do this both from terminal emulator and from an ADB shell on the PC. Superuser permissions are registered correctly.

    My phone is on Orange and boots to an orange splash screen as well as having a few crappy apps advertising products - so its not quite a pure vanilla froyo that I have. I can't seem to get rid of these system apps using apps for rooted phones so I don't know if something weird is going on there regarding permissions from the os?

    Phone rooted with clockwork mod and recovery mode/nandroid backup/root explorer/installing other ROMs all seem to work just fine.
  9. praky

    praky Well-Known Member

    what is the output you get after executing adb shell?
    Also adb devices before adb shell & post the output here.
  10. alfienoakes

    alfienoakes New Member

    OK, here's the output as requested -


    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    E:\Documents and Settings\Main>adb devices
    List of devices attached
    SH11DPL04644 device


    E:\Documents and Settings\Main>adb shell
    $ su
    su
    # chmod 755 /data/local/tmp/a2sd_enabler.sh
    chmod 755 /data/local/tmp/a2sd_enabler.sh
    # /data/local/tmp/a2sd_enabler.sh
    /data/local/tmp/a2sd_enabler.sh
    Remounting system partition as read/write..
    [: not found
    ERROR: System partition couldn't be remounted, are you on root-aid? (error code
    0)
    #



    Any ideas??
  11. praky

    praky Well-Known Member

    are you rooted?

    Edit: Ok. You are.
  12. praky

    praky Well-Known Member

    Ohh dear, you are trying a tutorial which is for samsung galaxy ace on a HTC phone. Never do that.
  13. Fletchguy

    Fletchguy Member

    Praky you confuse me..your thread says this method is to be used for froyo never any brand of phone. Then someone tries it and you give a "Ohh dear, you are trying a tutorial which is for samsung galaxy ace on a HTC phone. Never do that." .....Why would you call the thread for fryo if in fact it is only for your Samsung galaxy ace? kinda dumb to do that and very misleading to others who can't read your mind. You should correct the thread title to Only For Samsung Ace froyo not all froyo.
  14. ayush29k

    ayush29k Well-Known Member

    Dude, he has posted this thread inside the Samsung Galaxy Ace's section, that's obvious that this is for SGA only, if you want to use it for another phone, you should ask the dev if its compatible with your phone or not.
    We cannot put a SAMSUNG GALAXY ACE ONLY tag on each and every thread posted for ACE, posting them inside the ACE section is enough to classify it.

    The only mistake in this thread is that Praky missed that alfienoakes mentioned in his 1st post that he is using it for HTC Desire, and somehow the discussion went on to resolving the problem for ACE. :p
  15. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    One thing you'll learn about very quickly is that things are very device specific.

    Never use something that isn't made for your device.

    If it's not posted in your section don't assume it'll work.
  16. Fletchguy

    Fletchguy Member

    As I am still not an everyday user not knowing this was in a specific section as I just searched the site using the search box for the term Darktremor on froyo I never saw the section specifics as it is very small way above the actual thread area. The search never said Samsung ace just took me to this thread and I apologize for not seeing the small thread tree way at the top.My easy mistake. I now know to look at the entire web page when using the search tI do not go by just the topic description.
    ayush29k and Rxpert83 like this.
  17. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Not a problem. I would suggest going to your devices all things root page and starting a thread there with your questions in it
  18. damewolf13

    damewolf13 live~laugh~love VIP Member

    I moved this thread into the 'all things root' section of this forum for further discussion.
    Rxpert83 likes this.

Share This Page