1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[Tutorial] How to root the Samsung Rugby Smart


  1. wathou6

    wathou6 Member

    WARNING! IT WILL WIPE YOUR ENTIRE PHONE WHEN EVERYTHING IS DONE INCLUDING YOUR USB STORAGE.
    I don't know why this happens but it does so backup everything beforehand.

    1. Download the update.zip file below.

    2. Copy the zip file into the USB Storage on the Rugby Smart.

    3. Boot the Rugby Smart into Recovery
    4. Choose the apply update from sdcard and select the update.zip file with the home button.

    5. Now choose reboot system now and confirm with reboot.

    Your Samsung Rugby Smart should have root now.

    I used a similar tutorial from forum.xda-developers.com/showthread.php?t=1317394

    Attached Files:


    Advertisement
    :
  2. WcR365

    WcR365 New Member

    Great job on discovering root for the Rugby Smart. Worked great! Thanks a lot!
  3. agonz8

    agonz8 New Member

    Thanks a ton. Awesome.
  4. tralewolf

    tralewolf Member

    Before I go and flash my phone, can anyone tell me if this ROM has the wifi/usb tethering enabled?
  5. BigPeteHoog

    BigPeteHoog New Member

    Worked like a charm Thanks brah
  6. jetflyrtb

    jetflyrtb New Member

    Having issues. It wipes the drive as advertised but no hotspot available. Not sure if I am setting it up wrong. Any tips?

    Update: Still not working. The error I receive when I attempt to activate the hotspot initially "hotspot/tethering active" appears at the top. However the phone tries to verify and I receive the message "Tethering/mobile AP is unavailable (is not set up on this device)"
  7. amites

    amites New Member

  8. smorto

    smorto New Member

    So I'm not THAT tech savvy, but I'm pretty good at problem solving and one of those girls who refuses to ask for help until I'm up shits creek.. which is where I find myself now.

    I used the update, but it only half worked. Apps like avast mobile security work but morphninja, rom manager, and others are telling me superuser isn't installed, specifically that system/bin/su can't be found. So I downloaded the paid version of su that didn't work, so I triedthe beta version, no luck. I reupdated, rebooted, tried rebooting through ROM manager clockworkmod recovery mode, it'll let me use that feature for some reason, can anyone help me please?
  9. bennyboyg

    bennyboyg New Member

    hello, i rooted my rugby following all the steps and now it keeps crashing and the n restarting it's self. It keeps doing this. Any ideas? Anyone know how to undo it on the rugby or another forum that already has it? thanks

    after some messing around, i put it back into recovery then it turned back on and now it works fine.
  10. r4dpere

    r4dpere New Member

    I am not able to do the Recovery Mode, i did follow the following steps...
    1. With the phone turned off, press the Power key and Volume Up keys at the same time.
    The Samsung logo will appear for a few seconds and then disappear. Continue to press the Power key and Volume Up keys.
    2. When the Samsung logo reappears, release the Power key and Volume Up keys then press and hold the MENU key.
    3. Continue to press the MENU key for 15-20 seconds, until Recovery mode is launched and the Android System Recovery icon is displayed.

    The phone either reboot or reboot with SAFE mode, but not to Recovery mode.

    If i push the Volume Up near the middle i am getting a RADUMP MODE instead.

    Am i doing something wrong? Thanks.

    [5/14] I was able to figure it out, i keep on doing a press and hold on the MENU which is causing it to either go to SAFE mode or just reboot. Just release and press on 1st and 2nd display of Samsung icon until the recovery mode icon comes out. Then PRESS MENU again (do not hold). The only issue i saw was the update.zip file i loaded on the external SD, the device can't read it from the external SD i have to move it to internal storage to make it work.
  11. spypher

    spypher Member


    This isn't an actual ROM...

    When this update.zip is applied, it simply adds:

    sbin/busybox
    sbin/sh
    sbin/sqlite3
    sbin/su
    app/Superuser.apk

    plus changes the permissions so that these can additions can boss around the rest of the phone


    To answer your question directly:
    It shouldn't affect whatever tethering you had or didn't have before applying, but it will let you add separate tethering options that require root
    tralewolf likes this.
  12. spypher

    spypher Member

    Specifically for rom manager: Our Samsung Rugby isnt (currently 05-16-2012) supported by Clockworkmod Rom Manager... check out
    ClockworkMod ROM Manager - Recoveries
    or google "rom manager supported phones"
    or even
    http://androidforums.com/samsung-galaxy-prevail/428011-warning-do-not-use-rom-manager.html

    To see if the update.zip actually worked and you have root, simply look in your applications for Superuser (it looks like the top of an android head with a patch on one eye)

    You shouldn't have to buy the paid version (unless you wanna support the dev or need some of the advanced features)
  13. spypher

    spypher Member

    Went through the instructions as posted

    Coupla things of note:
    1) Phone had previously been activated, no problem coming back up and getting on the network

    2) Tried to have update.zip on external sd card, did not recognize it there
    moved update.zip to internal/usb, rebooted into recovery and it found it fine

    3) After update installed, phone came up as if it were the first time turning it on... took a few seconds longer and had to re-attach it to google account

    4) Titanium backup complained about su binary permissions and fixed them, but otherwise didn't have any problems running stuff as Superuser.
  14. sebo86

    sebo86 New Member

    Hi guys, I've rooted my sgh-i847, everything works fine and I have a superuser permission, but when I'm trying to dump the rom with an adb, I got "permission denied". Does anyone know how to fix it?
  15. starman1029

    starman1029 New Member

    My samsung rugby smart wont root even after I followed the instructions 7 times! if you :(know whats going on reply.:(
  16. wathou6

    wathou6 Member

    Are you using the Samsung Rugby Smart I847? Or the Samsung Galaxy Rugby?
  17. starman1029

    starman1029 New Member

    I am using samsung rugby smart I847.
  18. starman1029

    starman1029 New Member

    I want my phone rooted for full access and certain apps
  19. nicedream

    nicedream New Member

    @wathou6: Which version of recovery is on your phone? I was thinking of getting this phone, but I went to two AT&T stores and the demo models there had recovery version 3e.

    As far as I know, 3e recovery will not install unsigned update.zip files. So I am wondering if the update.zip you posted is signed, or if you got a phone with an earlier version of recovery (2e?)
  20. wathou6

    wathou6 Member

    I don't remember which recovery version it is, but I will assume that it is 3e recovery and that this unsigned update.zip should work with it. I don't believe AT&T would go out of their way to push a firmware update just for the recovery since there aren't any updates for this phone at all as of my current knowledge.
  21. nicedream

    nicedream New Member

    Thanks wathou6. I have the Samsung Exhilarate now, but I want to trade it in for something else before the 30 day return period is up. The Exhilarate has 3e recovery, and it will not install unsigned zips (I get the "signature verification failed" error message). That's why I was wondering about this phone when I saw it had 3e recovery in the store.

    I saw in the other thread that you were using an alpha version of CWM on this phone. How is that working so far? Are you about to do nandroid backups? Do you know of any custom ROMs being developed for this phone?
  22. Motorhead1991

    Motorhead1991 Well-Known Member

    I'm currently trying to figure out a workaround for this... Cross your fingers! :D
  23. Motorhead1991

    Motorhead1991 Well-Known Member

    Disregard my statement, I haven't figured this out yet
  24. John017

    John017 New Member

    Hi,

    I 'm completely new to rooting. I had this Galaxy Rugby GT-5690 sitting for a couple of months while I was using my Lg Optimus LTE. I wanted to root a basic phone i.e.galaxy Rugby, so even if I am safe even if I mess it up. But when I turned it back on it asked me for the password which i have forgotten now. I followed the instructions and tried to start it in the recovery mode. It shows up the android recovery icon and then it asks me to confirm password. It does not show the list to choose clear data option now(or any other option or list for that matter).
    I would really appreciate anything helpful.

    Thanks
  25. jeffdennison19

    jeffdennison19 New Member

    We have established root for the device now we need flash counter resets and unroot
Loading...

Share This Page