[Tutorial] How to root the ZTE Warp Sequent. USE AT YOUR OWN RISK


Thread Status:
Not open for further replies.

Last Updated:

  1. yaggermr

    yaggermr Active Member This Topic's Starter

    Joined:
    Sep 23, 2012
    Messages:
    32
    Likes Received:
    26
    Warning It's your phone if you break it blame yourself. I can't help you if this script bricks your phone. I have used and it worked great.
    After a successful root it is recommended to Flash a Recovery and make a nandroid backup. BE CAREFUL. REALLY.

    You will need the proper adb drivers for this to work .

    http://androidforums.com/warp-sequent-all-things-root/671861-guide-checking-your-drivers-adb-connection.html#post5395351
    by Junkie2100 Read has some helpful tips and troubleshooters

    How to root
    1. Put your device in usb debug mode from developer options setting menu.
    (try different usb modes at least once, generally "charge only" mode is what is recommended but each person gets different resuslts)recommended by Junkie2100
    2. Download DoomLord Script and extract it to a folder. DooMLoRD_v1_Xperia-2011-ICS-ROOT-emu-busybox-su.zip
    3. Connect your phone via usb and make sure you have adb drivers already installed.
    4. Open the extracted folder run the runme.bat
    5.Click any key to start the script the device will reboot be patient can take a couple minutes.
    6. After script completes hit any key script should close you now have root.
    (Helpful links for Clockwork mod and Rom)

    http://androidforums.com/warp-sequent-all-things-root/669226-cwm-6-v-2b.html

    http://androidforums.com/warp-sequent-all-things-root/666902-rooted-stock-rom-cwm.html

    http://androidforums.com/warp-sequent-all-things-root/670691-shinjitsu-rom-4-0-4-update-out.html

    Thanks to the Guys helping develop for the Warp Sequent
    Junkie 2100 chrisjv3393 shinru2004 playfulgod superr if I missed you sorry
    peasarecool found this method so many thanks and DoomLord is just awesome. I have used his work before thanks.
     

    Advertisement
  2. mauricio1717

    mauricio1717 Member

    Joined:
    Feb 29, 2012
    Messages:
    20
    Likes Received:
    0
    i tried and did not do anything. what i did wrong?
     
  3. mauricio1717

    mauricio1717 Member

    Joined:
    Feb 29, 2012
    Messages:
    20
    Likes Received:
    0
    did not work.
     
  4. mauricio1717

    mauricio1717 Member

    Joined:
    Feb 29, 2012
    Messages:
    20
    Likes Received:
    0
    a little help here please.
     
  5. unclejimmyb

    unclejimmyb Member

    Joined:
    Aug 20, 2012
    Messages:
    12
    Likes Received:
    2
    Didn't work for me either. Can you post a detailed how-to along with a link to the correct adb drivers? It would be greatly appreciated.
     
  6. codyjohnson198

    codyjohnson198 Member

    Joined:
    Aug 30, 2012
    Messages:
    9
    Likes Received:
    1
    Worked great! According to busybox installer, Im rooted!!! Woot Woot! Thanks guys!
     
  7. codyjohnson198

    codyjohnson198 Member

    Joined:
    Aug 30, 2012
    Messages:
    9
    Likes Received:
    1
    can also get msl with alogcat. nice
     
  8. yaggermr

    yaggermr Active Member This Topic's Starter

    Joined:
    Sep 23, 2012
    Messages:
    32
    Likes Received:
    26
    Without any details about what happened when you ran the script it is difficult to help. High percent chance that adb drivers are not installed or not installed correctly Youtube or xda developers have tutorials on installing adb drivers. I installed adb drivers about two years ao and don't remember the process. Also might help to put display timeout to thirty minutes and make sure allow install from unknown sources in security settings. Added adb drivers help link in the tutorial at the top of this page.
     
  9. codyjohnson198

    codyjohnson198 Member

    Joined:
    Aug 30, 2012
    Messages:
    9
    Likes Received:
    1
    Is there something like Clockworkmod as a ROM manager and installer I can use? The stock ROM manager won't let me browse my entire directory. :-( If so, how do i go about installing it?
     
  10. yaggermr

    yaggermr Active Member This Topic's Starter

    Joined:
    Sep 23, 2012
    Messages:
    32
    Likes Received:
    26

    No currently there is no working cwm or a way to flash a rom or make a nandroid backup. I have tried a little to get cwm working but no results. There are currently no roms to flash.
     
  11. mauricio1717

    mauricio1717 Member

    Joined:
    Feb 29, 2012
    Messages:
    20
    Likes Received:
    0
    the link to download the driver do not work.
     
  12. mauricio1717

    mauricio1717 Member

    Joined:
    Feb 29, 2012
    Messages:
    20
    Likes Received:
    0
    the link to download the drivers do not work
     
  13. yaggermr

    yaggermr Active Member This Topic's Starter

    Joined:
    Sep 23, 2012
    Messages:
    32
    Likes Received:
    26
  14. primetech

    primetech Well-Known Member

    Joined:
    Feb 5, 2011
    Messages:
    254
    Likes Received:
    36
    Random FAQ:

    I installed the driver and am still getting errors when I plug my phone in, "device unknown" etc
    ...Try turning the phone on. (Derp, self.)​

    I ran this and it got stuck waiting for the phone to be on!
    The bloody phone needs to have its screen on the whole darned time.
    What if I have a second copy of ADB installed and on my DOS or Windows path?
    I had to make a modification to the DoomLord script to get it to work with my PC, which already had ADB installed and part of the Windows path:


    1. renamed files\adb.exe to adb.exe.bak (optional)
    2. right click -> edit runme.bat
    3. find > replace
    4. files\adb
    5. to
    6. adb
    7. re-ran script (which immediately used global ADB command).
    This shouldn't be necessary for everybody, but it helped me.

     
    yaggermr likes this.
  15. rlphbgby

    rlphbgby Well-Known Member

    Joined:
    Mar 6, 2012
    Messages:
    181
    Likes Received:
    28
    still having trouble with getting pc to recognize this phone
     
  16. peasarecool

    peasarecool Well-Known Member

    Joined:
    Feb 15, 2012
    Messages:
    102
    Likes Received:
    14
    try another pc and see what happens
     
  17. rocketman228

    rocketman228 New Member

    Joined:
    Oct 22, 2012
    Messages:
    2
    Likes Received:
    0
    ok I rooted my phone and was messing around with other recoveries and lost my stock recovery. Now when I press power and down button all i get is a black screen with an android guy on it. I lost the 3e recovery that the phone came with. Any suggestions or instructions to get this back ///

    Thanks Shawn
     
  18. groncki32

    groncki32 New Member

    Joined:
    Jun 27, 2012
    Messages:
    1
    Likes Received:
    0
    i rooted my zte warp sequent with the root guide and my device now reboots after hitting the volume button while device is on and has trouble connecting to the boost mobile network and the phone app won le me display dial pad.
     
  19. sean82007

    sean82007 Well-Known Member

    Joined:
    Feb 16, 2011
    Messages:
    112
    Likes Received:
    47
    do it again then, im being serious sometimes it takes a few times to get it rooted
     
  20. animusfl

    animusfl Well-Known Member

    Joined:
    Oct 15, 2012
    Messages:
    54
    Likes Received:
    13
    If all else fails check the cwm sub threads, there's a zte factory reset tool
     
  21. chrisjv3393

    chrisjv3393 Well-Known Member

    Joined:
    Apr 12, 2012
    Messages:
    342
    Likes Received:
    33
    So just to make sure, b4 i brick my phn.....does this root fully work? Nd has anyone bricked their phn by doing this?
     
  22. chrisjv3393

    chrisjv3393 Well-Known Member

    Joined:
    Apr 12, 2012
    Messages:
    342
    Likes Received:
    33
    nvm it perfectly fine for me... thanks bro.. now to install CWM
     
  23. Dementei

    Dementei Member

    Joined:
    Oct 21, 2012
    Messages:
    12
    Likes Received:
    1
    Worked for me, first time rooting. Waiting on stable CWM release, with working microphone.
     
  24. downthemachine

    downthemachine Developer Incognito VIP Member

    Joined:
    Dec 30, 2011
    Messages:
    2,940
    Likes Received:
    1,725
    Mic doesn't matter for cwm, mic now works on my kernel
     
  25. benjiu3

    benjiu3 Well-Known Member

    Joined:
    Oct 5, 2012
    Messages:
    83
    Likes Received:
    1
    so lets say when trying this i bricked my phone
    what can i do to get it back to factory settings?
     
Thread Status:
Not open for further replies.

Share This Page

Loading...