[TUTORIAL][ROOT] How to re-root HTC Wildfire S after 2.26.401.3 update


  1. SentinelBL

    SentinelBL Member

    HOW TO (RE-)ROOT HTC WILDFIRE S (MARVEL)
    AFTER APPLYING 2.26.401.3 UPDATE AND
    CONSEQUENTLY LOSING ROOT


    I've managed to re-root my HTC Wildfire S (MARVEL) by following instructions from many different posts.
    I would like to THANK A MILLION to CafeKampuchia from AndroidForums and Heritz from xda-developers. :)

    You DON'T need to wait the v2.26 HTCdev bootloader update.
    You can re-root via Installing root.zip (a script) via Clockwork Recovery v5.0.2.8.


    PREPARE FOR (RE-)ROOT:
    01) Download the Android.zip from attachments in this post and extract files to C:\android
    (I've used those files for re-rooting my WFS)
    02) Download Clockwork Recovery v5.0.2.8 image and put it in the C:\android folder
    (LINK: download.clockworkmod.com/recoveries/recovery-clockwork-5.0.2.8-marvel.img)
    03) Download root.zip from attachments in this post.
    04) MAKE SURE YOU HAVE ALL NEEDED DRIVERS INSTALLED (Just install HTCSync)

    FOLLOW THESE INSTRUCTIONS:
    01) DISABLE "Fast boot" (go to Settings>Power>uncheck "Fast boot") and ENABLE "USB debugging"
    (go to Settings>Applications>Development>check "USB debugging")
    02) Turn off your phone and let it shutdown completely. Do not connect it to the computer yet.
    03) Hold POWER BUTTON and VOLUME DOWN for a few seconds until you see HBOOT screen,
    and then wait again few seconds for the normal system scan.
    04) Navigate to FASTBOOT and now connect your phone to the computer.
    (You should see the change of "FASTBOOT" to "FASTBOOT USB" on your screen. If not install the drivers = HTCSync)
    05) Enter the CMD on your computer and navigate to you android folder (type cd C:\android),
    then type fastboot flash recovery recovery-clockwork-5.0.2.8-marvel.img
    06) When flashing is done, turn off your phone and let it shutdown completely.
    07) Turn on your phone and let Android boot. Connect it to PC (Choose connection type: DISK DRIVE)
    and copy root.zip to the root of the SD card.
    08) Turn off your phone and let it shut down completely.
    09) Hold POWER BUTTON and VOLUME DOWN for a few seconds until you see HBOOT screen,
    and then wait again few seconds for the normal system scan.
    10) Navigate to RECOVERY, and in the recovery menu select the "install zip from sd card".
    11) In the next menu select "choose zip from sd card" and find the "root.zip" file in the list (select it).
    12) Wait until the script do its work. When it is finished you will see "Install from sd card completed".
    13) Select "Go back" and then select "Power off" to turn off your phone (let it shutdown completely).
    14) Turn on your phone and let Android boot.
    15) Go to Google Play (Market) and download Superuser.apk and install it.
    16) You are (RE-)ROOTED.

    Attached Files:


    Advertisement
    :
    loucypher, badboy 57, nikohat and 4 others like this.
  2. anabellita

    anabellita Member

    thanks for this, looks like it could be the solution to my inability to root my WFS using CafeKAmpuchia's guide - frigid's tool is not doing anything (windows pops up and then closes), probably because I'm on version 2.26.401.3?

    but if I use this method and simply apply a new img file, shouldn't I first do a backup of my current system?
  3. SentinelBL

    SentinelBL Member

    Well you can go to: [ROM]Shipped Marvel ROM Collection - xda-developers
    and download shipped ROM, or try to find and extract .img from shipped ROM so you can revert changes whenever you want.

    With this method you won't lose ANY data on your phone. :)

    P.S. My phone is running perfectly 2nd day after doing this. :)
    anabellita likes this.
  4. anabellita

    anabellita Member

    was too impatient last night, fooled around a bit more and finally your instructions clicked with me! :cool:

    got meself a rooted phone! :D

    haven't done anything with it except, well, calle, receive calls, send SMS, receive SMS (who would've thunk these gadgets can do those things?). seems to be working fine!


    will go check out the roms :)
  5. SentinelBL

    SentinelBL Member

    Well those are the things I do to... and of course I am a wild (internet) surfer. (There's neither an ocean now sea here) :)

    The biggest reason for rooting my phone was the memory issue. After rooting and installing link2sd I have an addition of 1,5GB of internal memory located on a partition of SDcard :))) If you do not use link2sd application.... start :)) Now I have tons of applications that I use from time to time. :)) and I ton more that I don't use at all.
  6. CafeKampuchia

    CafeKampuchia Well-Known Member

    Actually, I've been pushing this method of rooting the Wildfire S for phones that don't won't accept the Super Tool in my thread for several months now. I finally put it in my guide because there are so many now that the Super Tool won't root. :(
    SentinelBL likes this.
  7. Caro332

    Caro332 Well-Known Member

    I wonder why:confused::confused:

    By the way, your coffee looks soooo tasty Cafekampuchia!!! :D
  8. CafeKampuchia

    CafeKampuchia Well-Known Member

    Thanks! It was very tasty. Despite the color, it's exceedingly strong and has a slightly sweet and milky taste. The best part is that it only costs $0.37 :D[/OFFTOPIC]

    The Super Tool and other similar tools use Zergrush while the root.zip developed by xda.cn pushes a rooting script and busy box. That's the difference, but I don't know why some phones won't root with Zergrush. :dontknow:
    slimchance and SentinelBL like this.
  9. joshled

    joshled New Member

    When trying this it says waiting for device help?
  10. Caro332

    Caro332 Well-Known Member

    that's usually a HTC driver issue. Try to re-install the driver. If you have a spare pc/laptop, use a different one. That's what I did when I had the problem.
  11. slimchance

    slimchance Well-Known Member

    This was the method that worked for me, having failed with the supertool. It is good to have some insight into what is actually happening when one attempts to root the device. I tried Googling zergRush but didn't find out anything very enlightening.

    As for root.zip pushing Busybox, I never found Busybox in my app tray and downloaded it from the market and I have found out since rooting that I have a file in data/local/tmp named zergRush.
  12. Caro332

    Caro332 Well-Known Member

    Hi and welcome to AF!

    Make sure you have the latest drivers installed properly. It's usually a pc problem and not a phone problem
  13. tieskejansen

    tieskejansen Member

    Isn't it the same thing like this? (HD) How to Root the HTC Wildfire S (GSM) - Cursed4Eva - YouTube

    So the 3 steps are: 1. Unlock bootloader (except if you are S-OFF), 2. Flash CWM Recovery, 3. put root.zip on your SD-Card, go into Recovery and flash it?

    And what files should I take? The files you can download in the discription of the video or the files that are gived here, or doesn't it matter? Please help me, because I really want to root my Wildfire S.
  14. slimchance

    slimchance Well-Known Member

    That's the method I used. I think I downloaded the files from here. Good luck with it :)
  15. SentinelBL

    SentinelBL Member

  16. badboytoast

    badboytoast Well-Known Member

    Will this work if i am rooting for the first time?
  17. SentinelBL

    SentinelBL Member

    It will work if you unlock you bootloader first.

    Go to HTCdev.com and just follow instructions.
    Don't worry you will not messup anything.
    Happy rooting :)
    badboytoast likes this.
  18. badboytoast

    badboytoast Well-Known Member

    Thanks!!:D
  19. juanadolf

    juanadolf New Member

    please how can i unlock my bootloader with htcdev if it dosnt had my rom version 2.26.401.3 .....please help me
  20. slimchance

    slimchance Well-Known Member

    Try skipping the updating bit - that's what I did when I couldn't find my software version in the list and it worked for me. Good luck!
  21. muckz

    muckz New Member

    Log into HTCDEV.com and follow the instructions. That is all!

    note, if you already have the latest ROM skip step 1 (downloading and running the RUU), and just proceed to step 2.
  22. CafeKampuchia

    CafeKampuchia Well-Known Member

    Welcome to Android Forums :hello:

    Phones with updated ROMs already have an unlockable bootloader, so updating the bootloader is completely unnecessary. Before beginning, check to see if you have an updated bootloader already as follows:

  23. So It wasys waiting for device for me too, but how do I know if all my drivers are up to date? (probably something easy, but this is not my area of expertice.)

    EDIT: Duh.... I get it.... I didnt even have HTC-Sync on my W7....... xD

    EDIT:Heres what cmd told me...

    sending 'recovery'
    OKAY
    writing 'recovery'
    (bootloader) signature checking
    FAILED (remote: signature verify fail:
    finished
    _________________________________________________
    any help on this problem?
  24. aliranan8

    aliranan8 New Member

    i havent rooted before, n i m directly doing this procedure. However, when i get to step 05 it says FAILED remote signature verify fail. M stuck here, cant proceed further, n wats the point in putting the three files in c:\android? what to do with them? plz help, i recently shifted to android n help me stay on it.
  25. Caro332

    Caro332 Well-Known Member

    If you haven't rooted before then this is the wrong thread. Like the title says, this is to RE-root.
    Go this thread instead:
    http://androidforums.com/wildfire-s-all-things-root/480954-guide-how-root-wildfire-s-s-finally.html
    CafeKampuchia likes this.
Loading...

Share This Page