1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

[TUTORIAL] Unlock Sim Network on Samsung Galaxy Mini S5570,Ace S5830,Gio S5660,Pop i559,Fit S5670


Did you unlock your phone with this method successfully?

  1. Yes

    40 vote(s)
    87.0%
  2. No

    6 vote(s)
    13.0%
  1. Profiler92

    Profiler92 New Member

    Great thanks...... Good worked
    Unlock first time..............
  2. sherazahmed92

    sherazahmed92 New Member

    Hi
    I have followed these steps
    but there are some issues
    1. /efs already exist in my case. as this folder is empty
    2. when I run mount command , it say invalid parameters.
    I have tried in many times but its not working.

    Can you suggest me whats problem?
  3. munshi8181

    munshi8181 Member

    sorry have u any solution for EFs file.....ill try to unlock but after this all things my IMEI change with all 000....and i googled there is EFS file something missing .....have any tutorial for EFS file.....pls.
  4. foufou

    foufou New Member

    Stoneboytony, I wish to thank you for the method, it was great simple and working 100/100
    for me. thanks again for sharing and good luck. Merci voil
  5. Soekie

    Soekie Member

    Hello!

    I don't get where you guys get all of this information?

    I bought a Samsung Galaxy mini S 5570 on travel in Spain due a lost mobile phone. Though can't use it in my own country because of the lock.


    The provider I currently have is Yoigo Spain.

    The rest of this codes, numbers and other information, i don't know where you get them?
  6. Soekie

    Soekie Member

    Can someone please help me?

    If i want to root my phone with superoneclick, the problem gots stuck when making step 6... then I have to close it forced because nothing happens anymore for a while.
    Or do i just have to wait for maybe hours? (I'll do without a problem if that can help :))


    Also, the next step, rootexplorer.apk, I downloaded it but don't understand. The step says: install on your mobile phone... but how?

    Thank you very much for your help!
  7. Soekie

    Soekie Member

    The phone is a
    Samsung Galaxy mini GT S-5570
    Android version 2.3.4
    Baseband version S5570XWKQ5
    Kernel version 2.6.35.7-perf-CL561937 root@DELL145#1
    Build number GINGERBREAD.XWKQG
    IMEI CODE: 356716049552590
  8. Soekie

    Soekie Member

    SuperOneClick v2.1.1.0
    Checking drivers...
    Killing ADB Server...
    * server not running *

    OK 0,15s

    Starting ADB Server...
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *

    OK 4,21s

    Waiting for device...

    OK 8,13s

    2.3.4
    Getting manufacturer...
    samsung
    OK 0,03s

    Getting model...
    GT-S5570
    OK 0,02s

    Getting version...
    XWKQG
    OK 0,03s

    Checking if rooted...
    False
    OK 0,14s

    Installing BusyBox (temporary)... - Step #1
    931 KB/s (1062992 bytes in 1.115s)

    OK 1,42s

    Installing BusyBox (temporary)... - Step #2

    OK 0,09s

    Rooting device... - Step #1

    OK 0,25s

    Rooting device... - Step #2

    OK 0,18s

    Rooting device... - Step #3
    225 KB/s (16830 bytes in 0.073s)

    OK 0,21s

    Rooting device... - Step #4

    OK 0,03s

    Rooting device... - Step #5

    OK 0,02s

    Rooting device... - Step #6




    [**] Gingerbreak/Honeybomb -- android 2.[2,3], 3.0 softbreak

    [**] (C) 2010-2011 The Android Exploid Crew. All rights reserved.

    [**] Kudos to jenzi, the #brownpants-party, the Open Source folks,

    [**] Zynamics for ARM skills and Onkel Budi



    [**] donate to 7-4-3-C@web.de if you like

    [**] Exploit may take a while!



    [+] Plain Gingerbread mode!

    [+] Found system: 0xafd17fe9 strcmp: 0xafd37365

    [+] Found PT_DYNAMIC of size 232 (29 entries)

    [+] Found GOT: 0x000163b4

    [+] Using device /devices/platform/msm_sdcc.1/mmc_host

    [*] vold: 0087 GOT start: 0x000163b4 GOT end: 0x000163f4


    OK 18,98s

    Rooting device... - Step #7

    OK 52,17s

    Remounting /system with read-write access...
    mount: Operation not permitted
    FAILED



    I get this error when I try to root my mobile phone ...
  9. StoneBoyTony

    StoneBoyTony Well-Known Member

    Did you read the diference between Froyo and Gingerbread and what should you do?

    - For FROYO SuperOneClick v2.1.1
    - For GINGERBREAD universal_gb_root_v12.zip


    Be more careful what you are doing and consequences of that actions. Everything is explained is up to you how you see the world from your perspective.
  10. Soekie

    Soekie Member

    Thanks for your reply.

    Well it was a co
  11. Big Buddy

    Big Buddy New Member

    StoneBoyTony,
    Excellent! Worked perfectly.
    Country: UK
    Network: Vodafone (unlocked phone from O2)
    Phone: Samsung GT-S5570
    Android 2.2.1
    Baseband version: S5570XXKB2
    Kernel version: 2.6.32.9-perf dpi@androidbuilder14 #1
    Build number: FROYO.XWKE3
    Had to install Java jdk-7u2-windows-x64 to run Android SDK Manager and SuperOneClick but it all worked fine. Phone is now rooted and free! Thank you!
  12. Yasumy

    Yasumy New Member

    I am running Vista 64 bit and already from the start my cmd is different, which of course doesn't affect the process, but seemed odd to me anyways.

    C:\Users\USERNAME>cd..

    C:\Users>cd..


    C:\>cd adb
    The system cannot find the path specified.
    C:\>cd adb
    The system cannot find the path specified.

    C:\>

    Every time I try to use the command 'cd adb' it comes up with this. Any solutions.. ? I am able to access all my files on my phone, which must mean that the driver is correct as well.
  13. StoneBoyTony

    StoneBoyTony Well-Known Member

    Atention on step 3. Can't find the path becouse you didn't extract superoneclick in c:\ that's why it can't find the folder becouse it isn't there. ;)
  14. Yasumy

    Yasumy New Member

    Sorry mate, will try again another time, but didn't realise that I didn't SuperOneClick as well, I'd heard it was only used to root a phone. My apologies and thanks for your help. Will let you know if this works.
  15. takwando

    takwando New Member

    Thank You VERY VERY VERY VERY much. I unlocked my Friends S5570 just right now.

    I'm so happy because my Friend will be more happy then me )

    THANK YOU SO MUCH!
  16. Glutamat

    Glutamat New Member

    I just registered to say: Thank you so much StoneBoyTony!

    I succesfully unlocked my Samsung GT-S5570, by following every step closely. It took me some time, to become familiar with the new mobile [ my first smartphone ;-) ] but after two days of trying out I found the right way to unlock it. I was very nervous, in fear of bricking the device. It all turned out working in the end. :D

    Android version: 2.3.5
    Baseband: S5570XWKS2
    Kernel version: 2.6.35.7-perf-CL666847 root@DELL140 #1
    Build number: GINGERBREAD.BUKS2

    It really works!
  17. Soekie

    Soekie Member

    Can someone help me please with this question?

    Like the next step then: put this file on your SD card.


    Where exactly do you have to put it in your SD card, on which map?

    Thank you! Can't wait to use it finally!!
  18. meet2kedarcm

    meet2kedarcm New Member

    Dear Sir,
    with this method i tried to unlock my Samsung galaxy i559 cdma phone.
    But after 29th step ( cat /efc/mits/perso.txt )
    Message on phone screen is " No such file or directory "

    My Network: Reliance
    Country: India

    In this Phone All CDMA sims working. I want to transfer in to GSM network

    About phone:

    Baseband Version:
    i559DDED05

    Kernel Version:
    2.6.32.9-perf
    se.infra@sep-56 #I

    Build Number:
    FROYO.DDED05

    Is there any solution?
  19. redDragon0528

    redDragon0528 New Member

    I'm having the same problem like yasumy. I tried to DL superoneclick but when I finish dl it my antivir detects malware and automatically delete it. what should I do? is superoneclick harmful to my laptop and phone? rrply asap thanks :)

    I try also turning off my firewall but still when I try to extract the zip file it says no archives found or cannot open the file. :( please help me.. I want to unlock my phone..
  20. gilandrew

    gilandrew New Member

    how about for galaxy y? please help.. thanks! :)
  21. diagonelson

    diagonelson New Member

    My Network: Locked to 3
    Country: UK

    About phone:
    Samsung Galaxy Mini GT-S5570


    Android version : 2.3.4

    Baseband Version:
    S5570NEKQ3

    Kernel Version:
    2.6.35.7-perf-CL561937
    root@DELL145#1

    Build Number:
    GINGERBREAD.XWKQG


    Thanks Stoneboytony!!! Your detailed explanation really worked! Thanks . I saved 15 quid. This was my first attempt at unlocking… and was successful as well.
    There are 3 logical steps:
    1. Rooting your phone to have superuser access.
    2. Installation of some file manager (Root explorer or Astro)
    3. Running ADB Shell and mount other commands.
    4. Safe exit and entering the unlock code.

    Being a newbie, I was stuck at pt. 2 as I didn’t know how to install root explorer apk. But then I downloaded Astro file manager and installed root explorer apk to continue with the process.

    Now it can work with any network !! Freedom! Now will try some other mods.
    anilkumar1988 likes this.
  22. Soekie

    Soekie Member

    Even here it succeeded too!!! Perfect!! Thank you very much!! :D:D
    PDA S5570XWKQG

    Phone: S5570XWKQ5

    CSC: S5570YOGKQ3

    Android version 2.3.4

    Baseband version S5570XWKQ5

    Kernel version: 2.6.35.7-perf-CL561937
    root@DELL145#1

    Build number: GINGERBREAD.XWKQG

    (Phone company: Spanish YOIGO prepaid formula -
    reason: phone lost during travel, necesarry to buy new one in Spain but seemed to be locked while I live in North of Europe, so couldn't use it. Yoigo couldn't provide the code.)


    Only one question left: all the apps I installed onto my phone during the process (root explorer, astro etc.) How do I open them on my phone again in case I ever want to use them?

    Many thanks!
  23. Savage001

    Savage001 New Member

    Great work, i followed this down to the tee and it worked 110% on my galaxy mini S5570 locked to optus in australia no more. Now to just get an official clean rom for my region.
  24. amail2you

    amail2you New Member

    Worked like charm on GT-S5670 locked to Vodafone Australia.

    Details in my next post.
  25. amail2you

    amail2you New Member

    StoneBoyTony - YOU ARE A LEGEND! This thing worked like a charm on SAMSUNG GALAXY FIT (GT-S5670) in Australia, locked to vodafone. I first tried the code-unlocking website and paid them $6, but got a reply that my phone can not be unloacked.

    I bought a pre-paid phone from the local retailer and flashed it to remove the Vodafone custom Rom.

    You can FLASH it using the firmware from the below link.
    [REF][S5670] List Of All Official Firmwares --2.3.6 the latest--Updated on 28/12/11- - xda-developers

    I flashed it using the European version
    FW name->S5670XWKQ2
    Version-> 2.3.4

    The only difference in the steps was at step18 my phone did not ask for permission.

    My phone details below.

    PDA: S5670XWKQ2
    PHONE: S5670XWKQ2
    CSC: S5670OXXKQ2


    Model number
    GT-S5670

    Network
    VODAFONE AU

    Android Version
    2.3.4

    Baseband Version:
    S5670XWKQ2

    Kernel Version:
    2.6.35.7-perf-CL332409
    root@DELL126#1

    Build Number:
    GINGERBREAD.XWKQ2.

    Again, THANKS A LOT for your post. YOU SAVED $100.
    boxi likes this.

Share This Page