twlauncher problem!!Support


Last Updated: 2014-07-29 20:09:44
  1. Soldaat

    Soldaat New Member

    Hello,

    I've got the Samsung Galaxy Ace (GT-S5830). I installed some apps from the market, and received this error:

    SORRY
    The application TwLauncher (process com.sec.android.app.twlauncher) has stopped unexpectedly.

    Wheb i boot my phone, he keeps sending this same errormessage on my screen. I cannot type or move around the menu or settings - Nothing!

    I saw that more people had this error on another forums, but never saw a working solution for me. I already tried to reset my phone, didn't work!

    What should i do? :confused:

    Advertisement
  2. eos

    eos New Member

    just got my Samsung galaxy ace a week ago and bam! god knows what happens and my phone is screwed in the same situation as yours. i recommend that you bring it down to your local samsung service center and have them reboot your phone or exchange for a new model. seriously, i think they have a bug going in the software that explains why we are in this shit.:mad:
  3. Bayint Naung

    Bayint Naung Active Member

    I also encountered this error after plugging out from usb cable while kies is using it. I hard reset it and all OK after that. =|
    It happened after a week I've bought it too. :D
  4. PhoneDumb

    PhoneDumb New Member

    hey guys i have a samsung galaxy s I9000 i rooted my phone then got titanium backup and that

    i downloaded some apps from the market and now my phone vibrates by itself i get a force close message about my TWLauncher ive tryed rebooting it it never changed anything is there anything i can do or is the phone stuffed ??? please reply i have only just got the phone
  5. the_bogus_man

    the_bogus_man New Member

    Hi I had the same problem here. I had installed file expert from android market and I used it to create a shortcut icon on my desktop for enabling ftp server. Unfortunately I had only one desktop available and it was already filled with icons without any free space. It caused touchwiz to crash and it was no longer able to start properly even after rebooting the phone.

    I managed to fix it by connecting the phone to the pc via usb cable and manually removing the new shortcut from phone's desktop by editing touchwiz config file.

    Exact procedure (use it on your own risk):
    - connect phone to the pc
    - start SuperOneClick and select Shell Root (not sure if it is necessary)
    - run adb-file-explorer - ADB File Explorer for Android Devices - Google Project Hosting (I copied it into SuperOneClick/adb folder, not sure if necessary) and connect it to to the phone file system
    - copy file /data/data/com.sec.android.app.twlauncher/databases/launcher.db from phone to your pc
    - open it with SQLite Database Browser | Download SQLite Database Browser software for free at SourceForge.net
    - go to browse data and select favorites table. delete the last row of the table (in my case it had title "sdcard")
    - save the file and copy it back to the phone, replacing the old file
    - restart the phone

    good luck
    Warao likes this.
  6. spray76

    spray76 New Member

    I have the Samsung Galaxy S phone from US Cellular (Mesmerize) and I have the same error. However, I didn't get the error message until I upgraded to 2.2.1 so I think it is something in the OS upgrade.
  7. mn331

    mn331 New Member

    No need to reset. Only one condition is to have your phone connected and signed in to Google account.
    Clean up your Home app data is all you need. You will loose your icons on your Home screen, nothing more.
    Step by step:
    Use your Google account and login to Android Market web.
    Find and install your second Home app by pushing it into your phone from the web. I personally preffer GO Launcher EX.
    If installation succeed, lock and unlock or restart your phone. Then you should see the dialog of switcher of default Home app.
    Do not set any app as default, you will make it later! Choose your second Home app, and woala, your phone is working again.
    Go into the Settings menu and follow: Applications - Manage applications - All and find your primary Home app, wich is Samsung Home in my case.
    Tap on this app to get info about it and force it to stop. Finaly clean up the cache and the data.
    Now you can use the Home Switcher or the Home Manager app to manage your default Home app.
    jymsym, daliciouss, Guru82 and 11 others like this.
  8. manindra

    manindra New Member

    Thanks mn331, its really worked out for me
  9. mshaffer

    mshaffer New Member

    I saw an answer to this problem on another thread and it worked for me. Removing the "Accuweather Clock" widget from any screen on your phone will stop the error.
    Hollycolliep and dms1218 like this.
  10. kathyberry04

    kathyberry04 New Member

    tHANK YOU VERY MUCH !!!

    OMG, I was getting crazy. For 3 hours, I was looking for a solution. Thanks a lot !!!! Gracias!:)
  11. kathyberry04

    kathyberry04 New Member

    Thnaks mn331, you are my hero !!!!!!
  12. hotbreakkid45

    hotbreakkid45 New Member

    after 3 hours.... you are my hero mn331
  13. imcari78

    imcari78 New Member

    Thank you SO much mn331!!! This was such an easy fix after freaking out for about 5 hours!
  14. tykeinire

    tykeinire New Member

    thanks mn31 worked a treat and explained really well, thanks, I thought I was buggered!
  15. GrahamF

    GrahamF Well-Known Member


    Hi, I see that this has worked for several people, but sadly not for me. I have logged into my Googlemail account & Android Market via my pc etc & downloaded an alternative launcher. However, how do I get this download onto my Ace?? It shows on my list of apps, but I can't figure out how to load it onto my Ace from my pc. What am I missing? Thank u. GrahamF. London :confused:
  16. DiXiE223

    DiXiE223 New Member

    It's easy, you must go to Android Market in your computer's web browser, sign in to your google account and click on installation of alternative launcher to your mobile. When you connect your phone to internet then, launcher will start installing and you will be able to run it after it.
    Another option is to download launcher.apk to your computer and send it via. BT to your phone (but this requires activated 3rd party applications install and you can't reach that option in setup now)... But if you are lucky, you can run the installation right after the file is sent to your mobile and hope it will work.

    My launcher broke-up yesterday, today I tried to upgrade firmware, but when it didn't work, i found this and tried. It worked, you just must delete your application data from the launcher app in setup

    Good-luck, I hope this one will help...
  17. az75

    az75 New Member

    @mn331, you made my day buddy...i was so worried by this problem, didnt have the option of returning the set, but to wait for months to get the repair in warranty, your suggested solution worked....you rocked man/mam:)

    ooops!! the problem started again:( I am sick of this damn msg "force close" please help!!!
  18. whitty0814

    whitty0814 New Member

    sorry.. here's a question wanna ask..
    I used to install go launcher ex.. n i uninstalled it..
    now i having the same problems again n i click installed..
    n get connected to wifi... but it din start to download..
    is it becos i haven on background data?
  19. rolly123

    rolly123 New Member

    The way I fixed mine was to uninstall all the 3rd party apps that I installed after I rooted my Samsung Galaxy S 4G, except the Titanium Backup and superuser. Then I logon to Google Market and downloaded to my device GO Launcher EX, restarted my device and selected GO Launcher EX. That works! This happened last night and so far I don't have any problems with my device.
  20. LegoAndroid

    LegoAndroid New Member

    Thanks man this post really helped with the error message
    stuff of legends
  21. texes24

    texes24 New Member

    It worked to get me to be able to get to my already apps. fortunately i knew exactly the settings i messed up but had no way of getting to the app that sets them. your second home screen work like a charm!! Thanks!

    I set my LCD density wrong and after reboot to have the settings take effect TWlauncher stopped working.
  22. pmaha

    pmaha New Member

    Login to Android Market from your laptop and install a new launcher. Turn on your phone and you will see it downloading. Install it and click on it and you will be asked to choose a launcher. You can choose the one you were using previously (I had GO and dlded ADW for the sake of dlding one) or the new one and you're set!
  23. pmaha

    pmaha New Member

    Go here:
    Free Android Fix: Process com.sec.android.app.twlauncher error Without Factory Reset | menardconnect.com

    I had the same problem and did a lot of digging in order to find a solution. I did this and it was fixed with no hard reset or total reboot.
  24. xfunny

    xfunny New Member

    Hi mn331, it really, really worked on me. BIG thanks to you!!
    At first I don't know how to install the launcher ex app to my device, coz I can't tap anything beside 'Force Close'. Then I go to market.android.com through 'Search' menu on my device, installed the app, follow your instruction, and voila! Thanks mate!!:D
    GrahamF likes this.
  25. 007fahad

    007fahad New Member

Share This Page