1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

TWRP - Spectrum


  1. Neph81

    Neph81 Well-Known Member

    I got bored and did more reading. Thanks to TDM and D2A, I'm actually able to compile stuff on my own. Here is the fruit of that info.

    *Link removed. Use .zip updater as it contains the corrected graphics version.*

    The graphics colors are off and I'm still working on fixing that part, but everything else appears to work. Once I have a functional copy with the correct colors, I will post an update.zip file for people to use.

    If any brave souls want to test it out and give me feed back, please feel free to do so.

    EDIT:

    The file is now in a .zip format that you can flash from CWM. As stated elsewhere in the thread, once you get into TWRP, go to Settings -> and put a check on "Use rm -rf instead of formating". This is just a safety precaution until I can do more testing on formatting.

    As it stands, ADB fully works, but "mount USB" does not. Changing the init settings did not fix this problem, so I am going to assume what D2A is true about the lun and this will not be a problem I can fix.

    If anyone runs into issues, please let me know, and I will see what I can come up with.

    Http://androidfiles.massivefilehost.com/twrp/Spectrum_TWRP.zip

    Advertisement
    reeseboy, admn81, Lykarsis and 4 others like this.
  2. azoller1

    azoller1 Well-Known Member

    Thanks so much for this! I tried building this on my own and it was confusing and I usually figure these thing out but guess not, great job! Will test later tonight
  3. blsmitty

    blsmitty Well-Known Member

    Including USB mass storage? Not a huge deal but it's really convenient. :D
  4. Neph81

    Neph81 Well-Known Member

    USB Mass storage does not seem to work at this point. This is most likely just an init script issue. Once I tackle the color issue, I will look into the mass storage issue. TWRP does allow for charging while in it, which is a major plus for anyone doing work with backups/recovering.
    IMUcarmen and blsmitty like this.
  5. IMUcarmen

    IMUcarmen Well-Known Member

    awesome neph! nice to have another choice besides cwm. Now if we could just get a neph81 rom we'd be good :]
  6. death2all110

    death2all110 VIP Member VIP Member

    does USB mass storage even work in CWM?
  7. megaghostgamer

    megaghostgamer Well-Known Member

    It didn't for me but I haven't tried with PGs new one in cwm app
  8. blsmitty

    blsmitty Well-Known Member

    +1

    That's why it'd be a great change for the better, at least for me, if it was working in this recovery. :)
  9. death2all110

    death2all110 VIP Member VIP Member

    I've had this issue on other phones that I maintained recovery images for. When a device has multiple USB modes available, and are switchable, at least on LG devices, it seems the lun file which is what the recovery uses for USB Mass Storage is only present when the device is in USB Mass Storage mode, and then rebooted into recovery. I never found a fix. I'm not sure if there is one.
  10. Neph81

    Neph81 Well-Known Member

    Just a heads up. Until I can confirm or deny it, you may want to change the settings to use "RM -rf" . I have some /data corruption after a recent restore in TWRP and I'm not sure if it's from formating or something else I did. Again, this is just a heads up.
    IMUcarmen and ortrigger like this.
  11. MrB206

    MrB206 Well-Known Member

    I f***ing love twrp. Being able to name backups before you start and being able to stack flash zips is awesome.
  12. PhoenixPath

    PhoenixPath Well-Known Member

    fwiw, you could do this through ROM Manager premium as well. Been an option for ages, you just need to enable "advanced options" in settings for the app.

    ...but yeah, TWRP made it a heck of a lot easier and I suppose the "free" bit is attractive to many. I'll likely switch to it myself once the issues are ironed out. I do like that it can be themed...just wish there were more themes available.
  13. MrB206

    MrB206 Well-Known Member

    Yea but rom manager is really useless unless you buy premium. If rom manager were the recovery program, it would be a fair comparison, but it's an add on app.
  14. Neph81

    Neph81 Well-Known Member

    First post updated. Graphics fixed and now on version 2.4 alpha, but mount USB still does not work.
  15. Lykarsis

    Lykarsis Well-Known Member

    Links down
  16. blsmitty

    blsmitty Well-Known Member

    Link worked for me. Wanna give it another try, Lykarsis?
  17. Lykarsis

    Lykarsis Well-Known Member

    Still down. I'll try on my computer when I get home. Maybe my 3G I'd being wonky.
  18. Lykarsis

    Lykarsis Well-Known Member

    Finally got it to download. Refused to work over 3G for some reason. Running great:)
  19. IMUcarmen

    IMUcarmen Well-Known Member

    are you running a host file on your phone? I had the host file from rom toolbox pro and pimp my rom running on my phone and it was blocking me from being able to download certain files.
  20. Lykarsis

    Lykarsis Well-Known Member

    Yes actually. I just check and that's exactly what it was. Thanks:)
  21. IMUcarmen

    IMUcarmen Well-Known Member

    thank you for this neph. I started running it yesterday and I like it much more than CWM. I'll never go back to CWM unless I have to.
  22. reeseboy

    reeseboy Well-Known Member

    This is my first android device... CWM is all I've used. This will definitely grow on me, especially being able to name the backups. Thanks Neph!!
  23. Neph81

    Neph81 Well-Known Member

    Ok, so, I've done the impossible and gotten mass storage to work in TWRP. The problem is that you need adb and to access "setprop" on the /system partition to get it to work. I tried moving toolbox and setprop to the recovery partition, but they still come up as file not found. If any devs want to give me a hand here, it would be appreciated. I need a way to change "persist.sys.usb.config=" from adb to mass_storage,adb and I don't want to set it in build.prop as that would auto mount the device any time you went into recovery and could potentially lead to SDcard corruption. Any thoughts would be appreciated.
  24. Neph81

    Neph81 Well-Known Member

    I'm going to be gone for most of the weekend, so I'm leaving this hear in case someone wants to work on it.

    http://androidfiles.massivefilehost.com/twrp/spec_twrp_mswip.img

    Flash this to your phone, boot into twrp and do the following two adb command from your computer:

    adb shell mount system
    adb shell "/system/bin/setprop persist.sys.usb.config mass_storage,adb"

    This will mount your phone as a USB drive. There is no good way to turn it off without rebooting. Remember to eject the drive in windows BEFORE rebooting your phone or even attempting to do a backup/restore. Two things writing/reading your sdcard at the same time could lead to corruption of the card. You have been warned.
  25. death2all110

    death2all110 VIP Member VIP Member

    I'll try to take a look at the code later see if I can get something working with the gui
    brianmaedche likes this.

Share This Page