U.S. Holidays missing from Google CalendarSupport


Last Updated: 2014-07-14 13:48:52
  1. Tony Android

    Tony Android Member

    Sprint S4 Tri-Band running 4.3 MK5. Rooted.

    I've noticed that no national holidays (4th of July, Thanksgiving, etc) are marked on the google calendar app. A Google search and also searching this very fine forum produces this advice:
    "Go to the App drawer and run the Calendar app. At the top, select the 'Calendars' box. Then under your Google account, select 'US Holidays".

    No such options on my phone! I open Calendar, it opens to the current month. The word "Calendar" is at top left, to the right is "Today", and a "+".

    Touching / long press of "Calendar" does nothing. Sliding sideways does nothing. Quick tap does nothing. "Today" just highlights the current date. "+" brings up "Add event", "Add task", and "Add memo".

    The Menu button brings up plenty of options, "Calendars" and "Settings" are the most promising, in fact menu > Settings leads to my gmail account the is registered to the phone. But from there, "Display" and "Edit" just leads in circles to screens I've already seen. None of those lead to any option to add "US Holidays".

    I'm not even trying to sync, import, or share. I just want a usable PERSONAL calendar that along with my personal events shows the major holidays.

    Help!

    Advertisement
  2. shmn

    shmn Well-Known Member

    If you can, enable the holiday calendar on a computer using a web browser and select the calendar under 'other calendars'. Much easier.

    On your phone, it should be under the 'Calendar' option if you press the menu option. You can also try a different calendar app like Samsung's or any of the other ones and they all have a setting for selecting what calendars are visible.
  3. shmn

    shmn Well-Known Member

    I just tried the stock 'Calendar' app on my S4. Ran it, pressed menu button, and then selected 'Calendars' from the pop up menu and I was able to select US Holidays, among other calendars.
    MYKEL61 likes this.
  4. Tony Android

    Tony Android Member

    I appreciate you trying to help.

    If I am remembering your avatar correctly, that is the exact advice you gave to someone else, which I found while trying to fix the problem for myself. For me, the Option. Simply. Is. Not. There. :mad:

    What version are you running on your S4, and is it a Sprint device?

    I don't use Calendar with a web browser or with my gmail account. Still, taking your advice, I tried setting holidays in Chrome on my gmail account from my desktop computer.

    I had earlier today hit sync from the S4, and while on the desktop computer it did show my personal events from my S4 on my gmail calendar. Which I don't need, so I deleted that.

    Still no way from the desktop computer to set US holidays. I did find a couple of drop down lists for alternate calendars (Hebrew was one I remember) and a long list of countries. US was already selected, and no holidays showed from the desktop computer browser either.
  5. amarie82

    amarie82 Guides Guide

    In the calendar settings on the phone do you see any calendar settings for holidays or calendars to display settings?
  6. Tony Android

    Tony Android Member

    Ok, something weired is going on!

    First, I did make one misspeak. I used Firefox not Chrome to try to set holidays from the desktop. I use Chrome for 99% of my web browsing. I use Firefox only to log into Gmail, that way I can stay logged in to Gmail but still keep Google from tracking to much info about my general web browsing.

    The weird part is that when I logged into my regular gmail account, from Chrome (this time I mean it! :)) there still were no holidays and np way to set them on the calendar. So I logged out and decided to try logging in with a throwaway gmail account. Guess what, the default calendar shows holidays such as July 4 and Labor Day.

    If only I could find out why holidays are blocked on mine.
  7. Tony Android

    Tony Android Member

    No holidays is the problem.

    The physical menu button produces seven options:
    Go to
    Delete
    Delete memo
    Search
    Sync
    Calendars
    Settings

    Calendars produces My calendars (tapping does nothing), My task (tapping does nothing), myname@gmail.com (tapping does nothing), contact's birthdays (tapping does nothing). At the bottom, there is Display, and Edit. Display produces the same list (calenders, tasks, birthdays, but with green check marks. Edit produces My calendars and nothing else (tapping does nothing). At the top of that, there is an Add button, which brings up the option to add a calendar event.
  8. amarie82

    amarie82 Guides Guide

    Your missing the option we are referring too! Idk why you wouldn't have that option! When I go to my calendar settings, display I get the screen shot

    Attached Files:

  9. Tony Android

    Tony Android Member

    I don't know why either. My phone is a SPH-L720T, maybe the radios are not the only difference for the Tri-Band S4.
  10. amarie82

    amarie82 Guides Guide

    I have a tri band nexus 5 so I don't think that would be it. I had to get that option tho from the desktop I signed in and set display options there.
  11. shmn

    shmn Well-Known Member

    I think this is your problem. If you don't have Calendar set up through Google you won't have its options. Just set up Calendar using your Gmail account on the computer and I suspect everything will fall into place. It sounds like you may have done that already but it's unclear from your post.

    If the problem persists after you set up a Google calendar try to clear the cache and data for the app and try again. If still no work...download aCalendar from the Play store and try that...it's a similar (but better) calendar app: https://play.google.com/store/apps/details?id=org.withouthat.acalendar&hl=en You don't have to keep it, just try to see if you can get it to work for troubleshooting purposes.

    I am using the stock Calendar app on a Sprint S4 with 4.2.2. Nothing fancy here.
    Tony Android likes this.
  12. Tony Android

    Tony Android Member

    You're probably right about that, although I don't understand why Google would break the functionality of an calendar app when a user wants to use it as a simple stand alone app.

    I don't want my personal life events tied to my gmail and Google's endless thirst for very personal data. My cell phone is my personal device, not the property of Google, Facebook, etc. So I don't want to set that up. I don't even sync my email to my phone.

    If this couldn't be fixed, I was already thinking of trying a third party calender. I see that aCalendar even has a paid version. I don't like ads on my phone and spy ware, so I actually prefer paid apps. I will try it out.
  13. Tony Android

    Tony Android Member

    Update.

    Ok, I just installed aCalendar. It complained that Google calendar was not up to date, so I let it update. The new Google calendar was ugly, washed out white looking, and still no option for holidays.

    No option for holidays with aCalendar free version, either. So I paid $3.99 for the + version, then took about 30 seconds to find the option to show public US holidays. Problem solved.

    Thanks for the recommendation, shmn.
  14. MYKEL61

    MYKEL61 Well-Known Member

    Thank you. Worked for me! That was driving me crazy.

Share This Page