Ubuntu 12.10: Firefox 'loses' internet connection


  1. nickdalzell

    nickdalzell Well-Known Member Contributor

    odd bug here. my Mozilla Firefox 18 has just started this random issue. sometimes at random it will simply stop pulling up websites, eventually timing out with an error saying it cannot connect to site. clicking the 'retry' button does nothing in that error page. now if i simply restart the browser by closing and reopening it, it works fine again. i have determined my internet is not to blame. is this normal?

    Advertisement
    :
  2. argedion

    argedion The TechnoFrog Moderator

    try about config and disable ip6
  3. nickdalzell

    nickdalzell Well-Known Member Contributor

    i am using Linux. there is no 'IPv6'. i did try resetting the http.network.pipelining. setting in about:config and so far so good
  4. argedion

    argedion The TechnoFrog Moderator

    yes but firefox by default has ip6 turned on for whatever reason I used to have the same issue then i switched to chrome and havent looked back.
  5. nickdalzell

    nickdalzell Well-Known Member Contributor

    hmmm. well it's disabled now

    i'd use Chrome too but there is no about:config and i'm one of the types who likes that option, gives a level of control no other browser has--besides i was sick of Chrome's 'sad tab' crap-never liked it when it was a Mac OS feature
  6. Dngrsone

    Dngrsone Well-Known Member

    Ubuntu does support IPv6, theoretically. You can disable it in Network Connections.
  7. nickdalzell

    nickdalzell Well-Known Member Contributor

    that never worked. but that laptop died eventually so it's no longer an issue. the replacement runs Kubuntu and never has this issue (although any browser seems to have issues with Google-owned sites or the search engine itself, you can be sure it will give me a host not found if i pull up Google or Youtube. hate using bing! think it's a router bug as tethering to my phone does not cause it)
  8. Dngrsone

    Dngrsone Well-Known Member

    I have problems with my UVerse-supplied router, in that it uses AT&T's DNS servers, which are crappy. If you can change your router's settings to use the Google DNS servers, then that problem will likely go away.

    I wouldn't use bing either. You should be able to change that in the browser.
  9. nickdalzell

    nickdalzell Well-Known Member Contributor

    no i should have said i use Bing as Google gives an instant host not found error and a blank page. Bing is the only other search that compares with Google for relevancy. but i am trying to use little MS stuff. although i do love their nature theme.

    I've tried Netgear, Linksys, and now Belkin for routers. every single one dies or has random glitches or malfunctions after a year. i got an old laptop with wifi and wired built in, and a usb dongle for wifi. i may just turn it into a better router
  10. Speed Daemon

    Speed Daemon Disabled

    OpenDNS is another good option. Of course I'm a little biased, since I know David Ulevitch from when we were both involved in a non-profit colocation project.
  11. nickdalzell

    nickdalzell Well-Known Member Contributor

    i have tried twice to get openDNS working but it keeps doing nothing. it hangs and everything is offline. my internet company has recently started using some VPN that issues some weird kind of IP to the clients on my network, they will not be the same subnet (in other words, they don't use 192.168.x.x for their IP address) and i think it stopped me from using openDNS replacements. every time i input them into my router the internet icon turns off and the modem icon flashes.

    tether or not, it seems i tried Chromium but it refuses to even see my internet. it gets hung up at 'sending request' then times out claiming DNS lookup failure. on any site. Firefox seems to work fine in the meantime but nothing from Google works--unless i'm tethered
  12. 9to5cynic

    9to5cynic Well-Known Member

    Also, if you can't get DNS working right, have you tried duckduckgo? It's my search engine of choice. :p

    Hmm... I just re-read your last post, can you give us an ifconfig.... I'm curious as to what IP range you are getting...
  13. nickdalzell

    nickdalzell Well-Known Member Contributor

    it is different than what my router has since it has recently started going through a VPN now but here goes:

    wlan0 Link encap:Ethernet HWaddr e8:03:9a:82:bb:f4
    inet addr:192.168.2.106 Bcast:192.168.2.255 Mask:255.255.255.0
    inet6 addr: fe80::ea03:9aff:fe82:bbf4/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:586497 errors:0 dropped:0 overruns:0 frame:0
    TX packets:483708 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:472497127 (472.4 MB) TX bytes:68770034 (68.7 MB)


    it used to issue out 192.168.2.x where 'x' is a single digit. now it adds a 1xx number. whatever it is i cannot force a static ip or a manual dns change without the router just kicking me off
  14. Dngrsone

    Dngrsone Well-Known Member

    It sounds like you are loading down your wifi routers. You might invest in a business-class router.
  15. nickdalzell

    nickdalzell Well-Known Member Contributor

    loading down how? they only have like three devices connected at best. most of them wired. the only wifi devices are my Wii, Laptop, and phone. i never let four or more connect because it WILL crash it. but i think the year life is more their horrid quality than anything else. i can get better results out of building my own and using Linux router distro to make it work--got enough spare parts to do that for nothing
  16. Dngrsone

    Dngrsone Well-Known Member

    I know Netgear modems for sure overheat and flake when used on a continual basis. Despite fan mods and other such hacks, I ended up going to a more expensive gigabit router in order to keep my home network running smoothly.
  17. nickdalzell

    nickdalzell Well-Known Member Contributor

    this isn't a modem, it's router. but the modem DOES disconnect when temps drop. i scheduled a service call so hope it will be fixed soon.

    routers store bought are lucky to get past warranty
  18. mikedt

    mikedt 你好 Guide

    Routers can be cranky things sometimes. Friend of mine had a TP-Link router/WiFi AP. As soon as we'd start the Mac OS X version of Transmission bittorrent it would instantly crash, and the internet would go dead. It was only the Mac version of Transmission that would do this. not the Linux version. And no other bittorrent clients would crash it either.

    I know that bittorrent is one of those things that can often bring down routers
  19. nickdalzell

    nickdalzell Well-Known Member Contributor

    Torrent programs fall under the same glitch as Google.com and any site run by it. if my router was on now, and i was not tethered to my phone, this particular laptop will outright say 'host not found google.com' instantly. same for YouTube. Gmail. any Google site. Bing, however and any other site, works perfectly fine. i never changed any setting, it's still factory default. it just hates Google; Torrent programs, as rarely used as they are by me, will claim 'you got low-id'

    weird part is how IE and any windows computer has none of that trouble, not even windows torrent programs. IE in Wine will connect to Google fine via my router. it's some combo of Firefox, Linux networking, and my router conflicting. also, my router has pretty bad DHCP pools. ever had a device on your network, say another laptop if on, 'steal' an IP Address from another connected device, thus bringing down the entire deal? my PlayStation 3 has that problem on wifi only
  20. Dngrsone

    Dngrsone Well-Known Member

    I meant routers, but anyway...

    PS3 and Wii have a nasty habit of polling for an address every freakin' minute, which is hell on the logs. When they do this, they can steal your IP as soon as it expires, and before your other device (which could be waiting a while before asking for a new IP) polls the server again.

    This is one of the reasons why I prefer to assign IP addresses when I can rather than allow DHCP to issue from the pool (it also keeps my wifi printer in one place). Unfortunately, I have not figured out how to get them to stop doing so. Not that I've spent a lot of time trying to do that-- I never touch them, to tell the truth.
  21. mikedt

    mikedt 你好 Guide

    I'm sure the reason why bittorrent clients tend to crash routers is that they open many TCP connections at once, because that's how bittorrent works. It seems that some cheapo and consumer grade routers just can't deal with that.
    Bad routers - VuzeWiki

    What we had, it seemed like the Mac OS X version of Transmission was just enough to push the cheapo TP-Link thing over the edge, while the Linux version didn't. Probably a difference in the default settings. We just replaced the router in the end. BTW it wasn't a real Apple Mac, it was a Hackintosh that a friend in Shenzhen made up.

    Nick what you've got does sound like a DHCP problem. Have you tried using a different DNS service like Google's or OpenDNS, rather than your ISP's own one?
  22. nickdalzell

    nickdalzell Well-Known Member Contributor

    i have already tried that--it *used* to work, but recently my internet service issues out some oddball IP address setup and any attempt to use static DNS will cause the internet light on the router to go out and the 'modem' light will flash off and on. if i put it back to auto, internet lights up and modem stays solid.
  23. Speed Daemon

    Speed Daemon Disabled

    I can assure you that OpenDNS is (and has been) working fine. It doesn't require any client software on your side that could hang; all you do is plug in the IP addresses of their name servers and go.

    If what you mean to say is that your DNS client is hanging, then that's a different issue.

    What is this VPN for? How is your VPN client implemented?

    Off hand I'd say that you need to tackle the Internet access part before moving on to setting up a VPN. Or if the VPN borks your Internet connectivity, you'll need to get that sorted out.
  24. nickdalzell

    nickdalzell Well-Known Member Contributor

    no no, my internet has recently changed how their IP addresses work. on a client computer accessing the internet through my router and modem it will display 'virtual private network address' in place of IP Address in Windows Networking Center. since this change, i cannot use static IP or static DNS. if i so much as change the setting for either to static, my modem turns off and my router internet light goes out and the modem light blinks.
  25. Speed Daemon

    Speed Daemon Disabled

    Your Internet? You have an Internet of your own? :p ;)

    If you're not on a virtual private network, the first thing to do is to disable VPN in Windows. Once you've fixed the misconfiguration, things should go back to normal.
Loading...

Share This Page