Ubuntu and Linksys wireless adpater= No WiFi


Last Updated:

  1. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    I have a 2003 SONY VAIO desktop PC which know has a shade over 1GB of RAM (PC-2700 DDR).
    I have Windows XP with service pack 3 on 57GB of the hard drive, Ubuntu on 47GB.

    I also have Plop Boot Manager.

    In order to get Ubuntu on my Desktop I had to install another utility program that put the Ubuntu software onto my USB drive in such a manner as to allow me to install Ubuntu just like doing it from a CD, only from my USB drive (Ubuntu 12.04 is 711mb and my CD was only 702mb).

    I need to install the ndiswrapper-common, the ndiswrapper-utils, and the mdisgtk to allow me to use the Lynksys WPC54G v2 notebook adapter to establish a WiFi connection on my desktop (can't connect to wired internet at all).

    Here is where my problem comes in: I have no internet connection in the Ubuntu distro.
    After installing the ndiswrapper-common with no problems I got an error trying to install the ndiswrapper-utils. Tracked it down to needing the python 2.7 which is included in all Ubuntu builds.

    Question: What do I need to do to allow access to all the dependecies for the ndiswrapper-common and the mdisgtk so I can complete the process and continue on with allowing the drivers for the wireless adapter to be installed?

    Note: Somewhat new to Ubuntu: I had version 10 on a laptop for a few months 2 years ago, but it crashed my WiFi constantly (found out later it was the wrong version for my processor).

    EDIT: Moved everything from USB drive to home page. Opened up Terminal and typed in:
    sudo apt-get build-dep ndiswrapper-utils-1.9_1.57-1ubuntu1_i386
    Got an E: You must put some some "source" URI's in your.list

    Advertisement
  2. SUroot

    SUroot Well-Known Member Developer

    I don't know the answer. You can't apt-get install without an internet connection. Why no wired connection?
  3. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Partly because I have no experience establishing a wired connection with Ubuntu, plus I would need to drag the Desktop into the living room (rent room in house with other renters where modem and router are centrally located in the living room).

    I plug the desktop into a wired connection in the XP OS and all is good.
    Windows made me lazy and stupid. I need to break the cycle.

    Any info would be greatly appreciated. Need to learn linux somehow, just figured I'd be doing it after I had it all up and runing.
    I'm basically not sure how to obtain the info Ubuntu asks for to even allow a wired connection.

    The modem has a sticker on the botttom with 4 different MAC address's. One is a USB-MAC which I'm assuming is the proper MAC address for the modem when wired to it. I don't know any of the service provider info as I didn't establish the service (rent room in house that is owned by an outside investor)
  4. 9to5cynic

    9to5cynic Well-Known Member

    I have never used a wired connection with linux either, but I'd image that it's pretty simple... and if you need to do any configuration, it'd be something like supplying the IP address and subnet mask. Maybe the gateway... but I'd assume that your router/modem are handling the IP addressing with DHCP.

    You could download the required sources for the wireless drive from windows, by going to the Ubuntu packages page and searching for your version of ubuntu and getting the ndiswrapper files and dependencies. Then you'd install them with dpkg.

    Also, may I recommend you try out VirtualBox or VMWare player. They are virtualization software that'll allow you to install a virtual instance of Ubuntu and use the windows internet connection passed to the virtual instance. That might not be 100% practical depending on your system specs....

    Best of luck!
  5. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    I have an app on my phone that can get the subnetmask and gateway, but I'm not sure if this is for the router, or the modem. I guess I'm going to have to buy a wired connection for the router to PC connection.

    I do have the Linksys WPC54G wireless adapter driver, got it before I did a disk wipe just before the Ubuntu install (wanted a fairly clean hard disk to partition for the dual boot). Extracted the LSTINDS.inf already and put it into the HOME folder.
    The python 2.7 is included in every Ubuntu since...?
    In order to download the python 2.7 and use it I must download 8 other dependecies. Then some of those have dependencies, etc., etc.
    There has got to be a better way if you don't have a connection.

    Good thing I went dual boot until I get everything figured out, at least I still have a connection on the XP OS.

    I don't know why they didn't address this issue in this new version. They have known about it for a long time.
    Not very newb friendly to start.

    I also noticed that the images on some of the icons in the task bar on Ubuntu have disappered. Hope they come back once I get these dependencies installed.

    I really like Ubuntu, but so far it seems that Ubuntu doesn't like my WiFi.

    Guess I'll just have to install every dependencie one at a time.
    Some one needs to make a package that can be installed right after the ndiswrapper-common that has the rest of the dependencies to allow the ndiswrapper-utils and the mdisgtk to be installed. This is just crazy. Two days just to get a WiFi connection and still not a break in site.
    I've heard of learning things the hard way, but WOW!

    Sorry for that rant. Thanks for you suggestions.
  6. 9to5cynic

    9to5cynic Well-Known Member

    I hear ya on installing dependencies manually. I'm on dial up, and none of my linux installs have a modem to connect to (or linux support) so I'm on XP downloading my dependencies. It's a pain, but do able.

    Python should be installed. I installed ndiswrapper for a usb wifi adapter that I was messing around with (creating a small wireless network for file shares) and it went into Ubuntu 10.10 Server edition ... and it was pretty straight forward. I don't think I have the link anymore, but I want to say it was on the ubuntu website.

    If you look into the virtual instance with the above mentioned software, you'll be able to copy the files that you install (w/ apt-get) and paste them over to the physical install via a flash drive. Then you'll have to install them with dpkg.

    Also, you don't need to install each dependency one at a time....
    I'm guessing you're doing something like this?
    Code (Text):
    1.  
    2. dpkg -i package1
    3. dpkg -i package2....
    4.  
    you could do this:
    Code (Text):
    1.  
    2. cd /home/USER/package_folder
    3. dpkg -i *
    4.  

    Hope that helps!
    AndyOpie150 likes this.
  7. 350X

    350X Well-Known Member

    Why I have never gone far with linux, every time I hear how its improved or so new "easy" installer, Ive never gotten it online. From com port modems, win modems, usb modems...

    It does it job well on the back end of things, but don't look at the little penguin behind the curtain.... Just tape your Rubyred slippers 3 times and wish for free Windows on your home PC.
  8. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Managed to get all the dependencie's installed and got the four (I added the ndiswrapper-dkms) packages installed.
    Got the LSTINDS.INF installed, then ran "sudo depmod -a. Can't figure out how to install the Realtek RTL8139 Ethernet controller driver. Got the driver from Realteks site. Tried a few things but haven't found an diffinitive answer yet.

    lispci: list the drivers
    rfkill list all: does nothing
    cat /etc/network/interfaces: auto lo l iface to inet loopback
    iwlst scan: interface doesn't support scanning
    iwlst auth: no authentication information
    apt-get: command not found
    jockey-gtk: tries, but can't connect to network so it fails
    sudo depmode -a: seemed to have built the modules for driver


    Question: Where is the big l on the keyboard for the commands:
    lsmod l grep vt
    dmesg l grep vt
  9. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    UPDATE:
    Figured out where the | key was at ( I purchased a new key board and the paint was all messed up just on that key)
    Finally got Ubuntu 12.04 installed properly with the WiFi working.
    It blow's Windows out of the water. It much like having rooted and open sourced android OS on the computer, only way better and with a much better look and feel. Way more customization as well.
    If you want something about it to act or look differently, someone has already thought it out and made it possible.
    It's way better for developing as well.
  10. 350X

    350X Well-Known Member

    all the SDKs n dev programs have a linux version to run on it?
  11. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    I'm just learning what all you can do with Kubuntu, Lubuntu, Ubuntu, and Xubuntu (there all off the same fork just different front ends and other tweaks).
    From what I've seen most developers would rather use Linux Distros.
    Yes the Android SDK with ADB and Java as well as OCaml, Perl, Python, Ruby, Lisp, Haskell ,Mono/CLi and a host of IDEs can all be used (just to mention a few).

    If your used to navigating around in you android phones system files and giving shell commands from a terminal Emulator, then you will find Ubuntu is set up very similar. Just way better. Hard to explain from a new user point of view.

    I'm going to keep Windows on the other half of my Disk (although though I might shrink the size of the Windows partition down to just what I need for the use of the LG utilities for allowing me to unbrick my phone), but, I can't see needing to use it but once every blue moon. I'm thoroughly enjoying Ubuntu.

    Linux distros involve more terminal commands to get things installed or removed. Windows make's you command line lazy.

    As I didn't have a wired connection at all I had to do all this to get my wireless working (I have an old Linksys wireless adapter card that's a little smaller in diameter than the LG Optimus V). I had to download the driver package (WPC54G which is the model # of my card) from Sisco/Linksys web site. Then I downloaded all these packages from the Ubuntu site in the Windows OS:
    ndiswrapper-common
    ndiswrapper-utils
    libglade2
    python-glade2
    ndisgtk
    dkms
    ndiswrapper-dkms.
    I typed in the name of these packages in the search bar and added precise (the name of Ubuntu 12.04) to the end.
    Once everything was downloaded I placed on a USB drive and booted into my Ubuntu distro.
    There I copied everything over to the home folder (right click on the file and selected that option).
    extracted the actual driver folder and renamed to Drivers.
    Opened up a terminal and typed in:
    sudo dpkg -i (the full name of the package).
    I did this for every package in the order I put them in (these must be installed no matter what wireless card you have).
    Once finished I then installed the Driver by going into the folder and finding the name of the proper .INF file (in my case it was the LSTINDS.INF). I then typed in:
    sudo ndiswrapper -i drivers/LSTINDS.INF
    sudo modprobe ndiswrapper
    sudo su
    echo ndiswrapper >> /etc/modules
    exit
    After a reboot I just had to finish by imputing the proper key for my network.

    Note: Some drivers need to be installed a little differently and older cards may not be able to have anything other than WEP security, but all the precise packages mentioned above need to be installed.
  12. Prinny

    Prinny Resident Linux Nutcase

    Here's a question, sorry to bump a dated thread...

    But who makes your WiFi card in your computer?

    Is it Linksys, or is that your router?

    lspci -v would show that.

    If its broadcom, they are really well known for Linux support. They even have a tutorial on their website on compiling the driver from source. Which is actually really easy...I've done it about 20 times now...
  13. mikedt

    mikedt 你好 Guide

    Actually win modems have always been a bit of a problem for Linux. That's why they're called win modems, the "win" stands for Windows. :p Basically a very cheap way of making a modem, that relies on the host CPU rather than the modem itself to do the work. Com port modems shouldn't be a problem though, just use PPPconfig to get you connected. Although those are very legacy things these days.

    Mind you if you're talking about dial-up modems, probably a long time since you've used Linux, isn't it? ;)

    These days when it comes to USB 3G modems, I find Linux is easier to get online than Windows. There's nothing to install with Linux, USB 3G modems work straight away I've found. And I've never had any problems getting online Ethernet or WiFi either, found Ubuntu or Mint works straight away.

    BTW Windows is not free(as in free speech or free beer), you paid a license fee to Microsoft when you bought your PC. It's included in the price of the PC. That's what the Windows license sticker is for, to tell you that the license fee is paid and your copy of Windows is legal.
  14. 350X

    350X Well-Known Member

    No I still have and use a com port external dial up modem, that is the kind I always used, when I need a new one, I search ebay till I find the old NOS one I like but have tried other cheap modems too but never got online with linux, probably could very easily now with wifi tethering. [ I live in a no high speed zone. I tether for better speed now though]

    from 95-98se my dad gave me copies [he repaired PCs], windows ME MS gave to me for free [was a beta tester for ME, I got 999 beta's, by time I got one downloaded on dialup, another was out] now I did pay $100 for the windows 2000 dev kit, but the kit retailed for over $10,000 if you bought it all in the store.

    And yes if you ask, im on windows 2000 pro SP4 right now, using opera 6.01 to post this, ill check my email using netscape 4.76 mail client, then fire up app inventor and work on my android apps in the latest FireFox.

    internet security, through obscurity
    Security through obscurity - Wikipedia, the free encyclopedia
    mikedt likes this.

Share This Page