Ubuntu Root?


  1. normanb20

    normanb20 Member

    I'm trying to root my D-Inc on Ubuntu 10.04, and for a one click root this is confusing.
    I have been rooting my D1 since last December, through many methods, but never found myself as confused as I am now.

    1. Download the Android SDK from Google (Can't get it installed, I have changed directories in terminal to the tools folder and run "android" as a command with no options but get "command not found")
    2. Download the unrEVOked3 recovery reflash tool for windows, linux, or mac. (Cant find this, even the Beta)
    3. Download the modified drivers from unrEVOked. (Do I need them in Linux?)
    Could any fellow ubuntu'ers help out? I can't afford a copy of windows:(.
    I appreciate any help anyone has to offer. This site is what makes Android great.

    Advertisement
    :
  2. h3rmanmunst3r

    h3rmanmunst3r Member

    You just need the Linux version of Unrevoked3.21 from their IRC channel. The program needs root access on the computer to communicate with the phone correctly. This Ubuntu forum post will show you how to use Terminal to create a drag and drop launcher that you can make that will allow Reflash to run correctly.

    HOWTO: Easily open any file as root via drag & drop - Ubuntu Forums

    Worked perfectly for me!

    EDIT!

    Found an easier way to create the root launcher.

    1. Right click on the desktop and click "Create Launcher"
    2. In the name section put something like "Root Launcher" or "Root"
    - in the command line put [gksudo "gnome-open %u"] without brackets
    - you can leave comment empty
    3. Now drag and drop the Reflash package over this icon
    4. Now double click on Reflash and Unrevoked should start running

    Good Luck! Let me know if you have any problems or questions.
    normanb20 likes this.
  3. normanb20

    normanb20 Member

    How did you install the sdk, and the drivers?(not sure if install is the correct terminology)
    Dude thanks again for your help. Once I get into recovery I am good, I just don't know anything about rooting the incredible, but I can help with any questions you have related to "is there an app for this?" I am a total market junkie.
  4. h3rmanmunst3r

    h3rmanmunst3r Member

    You don't need the SDK or the modified drivers. Just the Linux Unrevoked3.21...then create the launcher that I showed you above and everything should work.

    Join IRC here: freenode Web IRC (qwebirc)

    Once signed in the download will be at the top
  5. TheCowGod

    TheCowGod Well-Known Member

    The part of the SDK you need for mucking around on your phone is just the adb binary. All you have to do is download the SDK, extract it, go into the tools folder and execute the adb binary from the terminal. As far as drivers, none are needed on linux.
  6. ReuseablePlastix

    ReuseablePlastix Active Member

    If you haven't quite gotten it yet, here are a few posts that helped me out a lot.

    Unrevoked 3.14 - for Android 2.1
    Join the IRC for Unrevoked 3.2 if you're on Froyo.

    Getting Unrevoked to run: Linux + UnrEVOked3

    And as far as running ADB (shouldn't need this immediately or for Unrevoked, but it is needed for other things):
    Open a terminal in sdk/tools and type "./adb devices" (no quotes) to see if it finds your phone.

    If you get the "No Permissions," go to ADB: "no permissions" (Linux Mint 9) [SOLVED] and check out where the OP writes /SOLVED:

    sudo su
    ./adb kill-server
    ./adb start-server



    Edit: oh, and to get out of sudo, just type "exit" (without quotes) if I recall correctly.
Loading...

Share This Page