Uh, so I check my battery use..Support


Last Updated:

  1. woop

    woop novacane (OFWGKTA) VIP Member This Topic's Starter

    Joined:
    Feb 7, 2010
    Messages:
    5,053
    Likes Received:
    1,542
    .. and I find that my Camera app is using 94%?!? WTF? Is this normal?

    Breakdown goes as follows:
    Camera - 94%
    Android System - 2%
    Cell standby - 2%
    Phone idle - 2%

    There HAS to be something wrong here. I have never taken a picture with the phone yet, and the only time I even opened the Camera app was to change the options to make it store pics onto my microSD card. Anyone else showing this? Or even heard of this?
     

    Advertisement
  2. zemerick

    zemerick Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    572
    Likes Received:
    130
    What was the amount of time since last unplugged? If when you looked at this it was 5 seconds after unplugging it, of which the only thing you did was open the camera and make the changes you mentioned...then it might be fine. However, if you have had the phone unplugged for 5 hours and used it for other stuff, but only had the camera active for 5 seconds..then yes, you might have a problem.

    First things first: Can you replicate that? If you plug in the phone and charge it up, then unplug and use the phone normally for a couple hours ( and make sure to open the camera atleast once to make sure to replicate things as closely as to before. ) then check your usage again.
     
    woop likes this.
  3. Quintessence

    Quintessence Well-Known Member

    Joined:
    Feb 24, 2010
    Messages:
    260
    Likes Received:
    41
    Do a reboot and try again, sometimes if there is an error, a reboot will do the trick. This thing essentially is a computer.

    But that might be better after doing all the Zemerick stated.
     
    woop likes this.
  4. woop

    woop novacane (OFWGKTA) VIP Member This Topic's Starter

    Joined:
    Feb 7, 2010
    Messages:
    5,053
    Likes Received:
    1,542
    The phone, when unplugged, had the camera app opened around 1 PM today. I have used several apps since that time, and at 9 PM I plugged my phone into my laptop for charging. Unfortunately, I didn't check if the camera app was still running before I plugged it in (not sure if this makes a difference). I will check as soon as I get a full charge as there are still 3 bars away from a complete cycle (I'm assuming because during that 4 hour duration, the camera was running the whole time, and because USB charges aren't as efficient as thru the AC adapter)

    I will try a reboot if the problem still shows after my charge.
     
  5. Quintessence

    Quintessence Well-Known Member

    Joined:
    Feb 24, 2010
    Messages:
    260
    Likes Received:
    41
    Definitely attempt to replicate it. If it shows up, your camera app might just hit a minor bug keeping it open in the background. That's where I would recommend a reboot.

    Also, I would mirror the results with another app, called Spare Parts, its free and in the app store, it can also tell battery usage, but more specific, such as CPU use or partial wake, etc.
     
    woop likes this.
  6. zemerick

    zemerick Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    572
    Likes Received:
    130
    When was it that you checked the power usage? Only having the ones listed leads me to think it was either immediately after unplugging, or even during. Typically, the Android System will report far more than the Phone Idle and Cell Standby: Which makes since, the operating system and the various services/programs/resources associated with it are going to use up a fair bit of power compared to the small phone idle and standby.

    The key here is that the battery usage only displays data for the time since you last unplugged the phone. As soon as you plug it in, it wipes the battery usage data. This is why you need unplug it and use it for a few hours then check. This gives you time to put some normal use into it and see what actually uses power.
     
    woop likes this.
  7. woop

    woop novacane (OFWGKTA) VIP Member This Topic's Starter

    Joined:
    Feb 7, 2010
    Messages:
    5,053
    Likes Received:
    1,542
    Yeah I'm gonna try to replicate it. I'm hoping this was just a minor bug and nothing major. I'm actually running OS Monitor and its NOT showing the camera app as a process taking up CPU, which is comforting.

    Ah gotcha. That makes sense as I checked it while its still plugged in. However, I didn't use the camera app before I plugged it in (was actually running several other apps AFTER the camera app but BEFORE plugging it in for charge) so that may be a problem there. I'm going to definitely run it for a few hours after its done charging and see if the camera app is still present in my battery data usage. I'll probably try a reboot too just to make sure I'm on a clean slate.

    Thanks for the help guys.
     
  8. Quintessence

    Quintessence Well-Known Member

    Joined:
    Feb 24, 2010
    Messages:
    260
    Likes Received:
    41
    Keep this thread updated if you still have the issue, I can assure you, if its an issue, you are probably not the only HTC Incredible user who has come across it. =P
     
  9. woop

    woop novacane (OFWGKTA) VIP Member This Topic's Starter

    Joined:
    Feb 7, 2010
    Messages:
    5,053
    Likes Received:
    1,542
    Haha yeah definitely. I'm hoping since I haven't seen this any where else that its just a small glitch in the system and its registering it wrong. And as zemerick said about the battery usage, it doesnt make sense that the other system apps are so low, in addition to OS Monitor showing no camera app taking CPU processing power.
     
  10. woop

    woop novacane (OFWGKTA) VIP Member This Topic's Starter

    Joined:
    Feb 7, 2010
    Messages:
    5,053
    Likes Received:
    1,542
    15 mins unplugged:

    Camera - 87%
    Android system 7%
    Display - 2%
    Cell standby - 2%
    Wi-fi - 2%

    Seems like the camera app is still running, and being registered onto battery usage. Gonna head to sleep and check in the morning
     
  11. woop

    woop novacane (OFWGKTA) VIP Member This Topic's Starter

    Joined:
    Feb 7, 2010
    Messages:
    5,053
    Likes Received:
    1,542
    10 hours unplugged and its still showing 97% usage for the camera. Not good.


    Edit: rebooted and it went away. Gonna see if this happens again after opening the camera app
     
  12. CatsTide

    CatsTide Well-Known Member

    Joined:
    Oct 29, 2009
    Messages:
    752
    Likes Received:
    106
    what is your battery % now?
     
  13. Quintessence

    Quintessence Well-Known Member

    Joined:
    Feb 24, 2010
    Messages:
    260
    Likes Received:
    41
    Lets hope the reboot did the trick. =D
     
  14. woop

    woop novacane (OFWGKTA) VIP Member This Topic's Starter

    Joined:
    Feb 7, 2010
    Messages:
    5,053
    Likes Received:
    1,542
    3 bars left. It's been sitting on my night stand on idle for 9 of the unplugged 10 hours.gps off, WiFi on
     
  15. woop

    woop novacane (OFWGKTA) VIP Member This Topic's Starter

    Joined:
    Feb 7, 2010
    Messages:
    5,053
    Likes Received:
    1,542
    Just opened the camera app for a few seconds then closed it. Waited 30 secs then checked battery usage and it shows as 34% for it, so I guess it was just a glitch? 34% is much more reasonable.
     
  16. zemerick

    zemerick Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    572
    Likes Received:
    130
    Hrm. It is starting to sound like you might have a problem. Make sure to run the battery down to where it shuts itself off, and report your usage and times. Getting 10 hours of power, even when idle, with the camera supposedly using up about 50 times more power than the Android System sounds weird. I kinda wonder if it is simply saying "Camera" but it is actually the Android System. ( Which 97 percent usage by the Android System when mostly idle is about right. )

    Hmm..I don't know about that. My phone has an up time of under 2 hours ( Because I recently restarted it like you did. ) and I took about 5 pics with flash, and a 5 sec vid and only had a 13 percent camera usage. However, Android System had 35 percent.
     
  17. woop

    woop novacane (OFWGKTA) VIP Member This Topic's Starter

    Joined:
    Feb 7, 2010
    Messages:
    5,053
    Likes Received:
    1,542
    Hmm this is definitely a little weird then. Maybe ill try a complete battery pull and see if that makes a difference.
     
  18. zemerick

    zemerick Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    572
    Likes Received:
    130
    Don't do that just yet. Run the battery down until it shuts off. Lets see if something is actually eating a ton of your battery, or if it is just a display error. ( At 10+ hours I'm pretty sure at this point its a display error, but lets just be sure. ) Once we know the problem, then we will try to fix it. Only Deep Thought can get an answer without knowing the question:)
     
  19. azak

    azak Well-Known Member

    Joined:
    Apr 30, 2010
    Messages:
    98
    Likes Received:
    12
    What app is everyone using to check these %s?
     
  20. CatsTide

    CatsTide Well-Known Member

    Joined:
    Oct 29, 2009
    Messages:
    752
    Likes Received:
    106
    Battery Indicator is one
     
  21. woop

    woop novacane (OFWGKTA) VIP Member This Topic's Starter

    Joined:
    Feb 7, 2010
    Messages:
    5,053
    Likes Received:
    1,542
    Gotcha. I don't know how accurate third party apps are but I'm running both OS monitor and Android System Info and neither show any CPU usage from the camera.
     
  22. woop

    woop novacane (OFWGKTA) VIP Member This Topic's Starter

    Joined:
    Feb 7, 2010
    Messages:
    5,053
    Likes Received:
    1,542
    Go into your settings, scroll to the bottom and hit About Phone. There should be a About Battery option, hit that and then go to Battery Usage.
     
  23. zemerick

    zemerick Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    572
    Likes Received:
    130
    No app. Just go Menu->Settings->About Phone->Battery->Battery Use.
     
  24. cashX3r0

    cashX3r0 Well-Known Member

    Joined:
    Apr 24, 2010
    Messages:
    137
    Likes Received:
    10
    settings>about phone>battery>battery use
     
  25. zemerick

    zemerick Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    572
    Likes Received:
    130
    Most apps just ask the android system what numbers it has. If you do just have a display bug, that would explain them not listing your camera. ( It hasn't pulled enough juice for the system to care and record it...and what you are seeing as "camera" is really the android system usage. )
     
    woop likes this.

Share This Page

Loading...