Ultimate Guide to Rooting and Overclocking your Bell Desire Z. NEWB Friendly!

Last Updated:

  1. Mockmo

    Mockmo Member

    Thanks alot that helps clear up some of my confusion. Just a few more questions.

    I havent recived my phone yet it comes in monday is there anything i should do when i first get it? like i said its brand new rooted and running Virtuous.

    What is/ does clockworkmod do?

    How do i switch Roms? (is there a guide)

    Can i uninstall Virtuous to get my original stock OS with loosing my root?

    Thanks in advance

    And is there any way to get free paid apps like i used to get on my iphone?

  2. Slug

    Slug Check six! Moderator

    Switch it on to check it works, plug it in to charge the battery, then sit down with a beverage of your choice and go through the User Guide which should be on the microSD card as a PDF. The fact that it's running Virtuous means that everything in the UG will match what you see on the handset.

    It's a recovery image, which replaces the very limited stock one and allows flashing *.zip files, backing up/restoring the complete handset (or just individual file systems), wiping caches, partitioning memory cards... you get the picture. :)

    The process is identical to installing your first, except you're already rooted/S-OFFed. Copy the *.zip to your sdcard and install using CWM.... simples. ;)

    The previous owner may have backed up the ROM with the nandroid utility in CWM, which can then be unrooted with VISIONary. The only way to revert the recovery though is to install a stock RUU update, unless there's a dump of the original .IMG available in the wild.

    I'm sure there is, but it's something that's prohibited by our forum rules.
  3. Mockmo

    Mockmo Member

    Will the ClockworkMod already be installed when i get the phone how do i check?

    Can you email me how to get the free paid apps

  4. Slug

    Slug Check six! Moderator

    Install ROM Manager from the Market. When you run it, the first option is to flash CWM. If it's already installed it will show the current version.

    That wasn't a terribly clever thing to ask a forum moderator. I suggest that you re-read the forum rules. :mad:

    Btw, it's not a good idea to post your email address in plain text in public forums.
  5. Mockmo

    Mockmo Member

    Ops Sry about that wont happen again
  6. lh881211

    lh881211 New Member

    will it be safe to update the phone when a new update is available?

    i have mine rooted + overclocked as per guide.
  7. Slug

    Slug Check six! Moderator

    My understanding, from reading the multitude of related threads on XDA, is that you can regain permroot after the 1.72 update without downgrading if you currently have S-OFF. This post appears to confirm that.
    lh881211 likes this.
  8. XTRevolution

    XTRevolution Member

    Just figured I'd post my progress here. Got the G2 a little while back, rooted it the second day I had it, and I had SetCPU bought from my previous phone. Got that downloaded again, which surprisingly had support for the G2 instantly, and I've had it overclocked to 1.3GHz. In Quadrant benchmark, I scored a 2696 with that overclock, which is actually faster than the new dual core dual-1GHz phones that are supposed to be coming out soon.
  9. cloakster

    cloakster Member

    When Rooting, will i need to back up and/or re-install any of my apps?
  10. Slug

    Slug Check six! Moderator

    No, the process doesn't require a wipe so nothing should be lost. It's always wise to have insurance against unforeseen circumstances though, so I'd still advise backing up any important data.
  11. cloakster

    cloakster Member

    At step 11 after i type ./gfree it starts to do some stuff and then i get:

    Patching and backing up partition 7...
    Error opening copy file.

    Anyone know why this is happening? Thanks in advance :)
  12. Slug

    Slug Check six! Moderator

    How much free space is on your sdcard? It could be a lack of space issue.
  13. cloakster

    cloakster Member

    7GB left on the card and 739mb of the internal storage left. No matter what setting i put the connection type to (charge only, sync) i still have access to the SD card from my computer. Would it have anything to do with that? and how do i fix it? Thanks

    Edit: I did step 11 in terminal emulator and it worked :D
  14. Slug

    Slug Check six! Moderator

    As the old song says, "It ain't what you do, it's the way that you do it". :)

    Congrats on your success.
  15. Livedog

    Livedog New Member

    I have literally been trying to figure this out for days now. I just got my first Android phone and I have no idea whats going on. Now, I do have Visionary installed, setcpu, gscript, terminal emulator, Astro, I have the Super user icon, IMve temprooted my device several times. I think my only problem is I cant get adb to install the visionaryplus file, I do have SDK downloaded.

    Anyway I'm going to go insane if I cant figure this out. I NEED to figure this out! Lol....losing mind....so any help would be so appreciated. I'm one step away from paying someone to do it for me.

  16. Absolute_

    Absolute_ New Member

    New at this ordered my desire z and its coming tomorrow.. But im just wondering if this guide works on an unbranded HTC Desire Z, since i ordered it off of eBay. Plus all i want to do is keep stock ROM and just overclock my desire z. Anyways I have been doing some research and all this technical talk is so complicated compared to windows mobile.
  17. Jin 06

    Jin 06 New Member

    I've done everything in order, and everything went as it should have, till I selected "temproot" on Visionary+.
    The black screen comes up after a few seconds, then it just stays black (I've waited almost ten minutes for it to go back to the options menu).

    (I also tried the next step, but got denied)

    Any idea of where I went wrong?

    I should note these two things:
    1. My firmware version is 1.72.4 (I've heard there are issues of rooting for this)
    2. When I go to the home screen after waiting for so long, my DZ becomes extremely laggy, hence I have to restart it and by doing so, puts the phone back to its initial state before the temproot was started.

    I really want to root my DZ and unleash its processor's potential!

    I'm new to this, but due to my exams I can't really do all of my research and learning on rooting and such, so sorry for the frustrating question.

    Thank you in advance! :)
  18. Slug

    Slug Check six! Moderator

    Hi Jin!

    Firmware versions above 1.34.xxx.xx can't (yet) be reliably rooted. You'll have to downgrade and then you'll be able to root it. There's a link to the complete process here.
    Jin 06 likes this.
  19. Aleksandroid

    Aleksandroid New Member

    Alright, I have the HTC Desire Z and have updated it to 2.2.1(which is the latest release from HTC for the Desire Z)... I am still at the stage where i'm rooting my phone. I have the visionary apk installed on my desire Z, so I open up the visionary app to temp root it then the rooting starts then goes to black screen and stays like that and does nothing. i've let it sit for more then about 3 minutes and nothing happens so i just closed the app. ive tried it around 5 - 10 times and i always get the same result... what gives?
  20. Jin 06

    Jin 06 New Member

    Hi Aleksandroid!

    If you read the post above yours you'll see that the link will take you to another method that should work.

    My guess is that your firmware is above 1.34, hence this method doesn't work for your DZ yet.
    Slug likes this.
  21. lh881211

    lh881211 New Member

    @Slug i have a quick question about the official RUU (ROM Upgrade Utility) do you know any tutorial or walk through for restoring back to original stock form?

    because i would like to unroot my phone now, will upgrading my phone to 1.82.709.1 from my current 1.34.709.5 automatically unroot my phone? thanks!
  22. Slug

    Slug Check six! Moderator

    Yes, it will wipe and replace everything.
    lh881211 likes this.
  23. funwithham

    funwithham Member

    my screen will not come back from being black when i do temproot!!!!!!!! someone please help me ahhhhhhh i am getting pissed offfff :mad::mad::mad::mad::mad::mad::mad::mad::mad:
  24. Slug

    Slug Check six! Moderator

    Pull the battery, reinsert and restart the handset. It's a temp root so restarting will return it to normal service.
  25. zuplok

    zuplok New Member

    thank you for this awsome tutorial ;)

    had to improvise a little when installing the overclocking update since my Z would'nt boot into the "new" recovery but i think it worked out. (did a backup through the ROM Manager then "Install ROM from SD Card"(dont know if that will create the proper nandroid backup?) other than that it seems to work perfectly.


Share This Page