Unable to Connect Droid Eris to PC with USBSupport


  1. Renholder5x

    Renholder5x Well-Known Member

    I used to be able to connect my Droid Eris to my PC with a USB cable and the option in the notification bar to Mount would pop up... now I'm getting a message on my PC saying the USB Device is not recognized. I've tried scouring the web for more info, but only came up with noobs who didn't know to click the mounting option in the noti. bar.

    Anyone have any ideas why my phone cannot connect to my PC all of the sudden and how to fix this issue?

    Advertisement
  2. Do all of these and something should finally click right.

    Restart phone
    Restart computer
    User another USB port on the computer
    Use another mini-USB cable (if you have one, I have tons)
    Check settings and see if some options are disabled.

    Check back here when doing those and let me know.

    Oh, and PC manufacturer and OS would help too.
  3. cgh

    cgh Well-Known Member

    All of these + perhaps update your USB drivers before plugging the phone in?
  4. BlueDC2

    BlueDC2 Well-Known Member

    The same thing happens to me sometimes. only the stock cord works, I just keep unplugging, restarting, and changing ports. Does yours also disconnect on and off if you move it even a little while it is hooked up?
  5. Renholder5x

    Renholder5x Well-Known Member

    Yes it does. It began doing that the other day like it was real touchy for a while, then it just stopped working all together.

    Smacky and CGH, thank you for your speedy replies, and I have already tried all of those options with no luck still. This is becoming very frustrating having to email myself pictures and videos. I guess I could call VZW tech support, but I hate talking to them so much! LoL
  6. Gimme an OS and PC manufacturer.
  7. deno73

    deno73 Well-Known Member

    I have this problem too. What will do is turn phone off and while its off then plug it AND THEN TURN IT ON WHILE PLUGGED INTO THE PC. works 4 me every time.
  8. Doesn't your computer then start up ultra slow as it tries to read everything on the device's card as a hard drive? Sometimes computers don't boot up with a USB drive in them, I can't imagine a phone either.
  9. EKhatch

    EKhatch Well-Known Member

    I don't think he is talking about turning off your PC, just your phone.
  10. SirEagle

    SirEagle Well-Known Member

    While the phone is plugged in go into your Windows Device Manager and see if the phone shows as a drive. If so uninstall it, unplug the phone, reboot pc, plug phone back in and see what happens.
  11. Renholder5x

    Renholder5x Well-Known Member

    It's Windows Vista and the PC is a Dell.

    BUT the damndest thing... it's working again all of the sudden. :)

    Plugged it in a few hours ago to charge it up and BOOM... works. And it's not touchy like it was before. I dunno WTF is going on here, but whatever. It's working.

    Does anyone ever go to reply to a text and the text box is grayed out? And even if you type, nothing comes up. Happens to me maybe once a week. If I fiddle with it, it goes away and I can type again. Not really that big of an issue, just wondering if anyone else has had this happen to them...
  12. Renholder5x

    Renholder5x Well-Known Member

    Deno, I can't be certain, but there's a 40% chance I think I may have unintentionally fixed this issue because I had an Windows update that needed to be installed. Maybe this had some sort of interference with my USB drivers????? I don't know. But it's worth a shot. Check your Windows Updates, reboot both PC and phone and come back and let us all know if it worked. :cool:
  13. deno73

    deno73 Well-Known Member

    Thanks for the tip, but windows is set for auto update on my pc. Just figured it was the phone. Will look into it a bit more. Thanks again.
  14. jenwarner

    jenwarner New Member

    Sorry to piggyback on your thread, but I'm losing my mind! I am in the same boat as a lot of people, but can't seem to fix my problem. I plug in using the specific USB cord, and I get the USB debugging notification, but NO option to mount SD card.
    I went into Verizon and they just clicked the Stay Awake button and said that would fix it. It didn't... any info?:confused: I need help!!!!
  15. Gato

    Gato Well-Known Member

    couldn't you just:

    Right click My Computer
    Click on Device Manager
    Scroll down till you see Universal Serial Bus
    Go to the level just below that and delete/uninstall EVERYTHING
    Reboot PC
    Plug in device and let PC discover it fresh

    ???
  16. chakra22

    chakra22 New Member

    i have had that problem sometime too
    I went to recovery mode and click on the ( USB-MS togle ) on my droid Eris
    then the box on the pc would pop up
  17. joliveri

    joliveri New Member

    use your stock usb wire that came with the eris. I figured this out after hours of frustration. It use to work with other usb cables, but then stopped. Don't ask me why. Whatever. found my original wire, and bam. working again. PIA!:D
  18. yowza

    yowza New Member

    I have wasted many hours on this and thought I would tell my tale of woe to help others. I tried connecting my HTC Eris to my Windows 7 64 bit machine with a usb mini cable. I could see it was charging the battery but nothing else happened. I did not get a notification. It did not show up as a device on my PC. I spent time changing settings, powering on and off both the phone and my PC, reinstalling the HTC sync software, moving files around, downloading software etc... I then found out that the USB cable I was using was for charging only and not syncing. So, I went over to Fry's and picked up a BYTECH mini USB retractable cable that said it was good for syncing, took it home and plugged it into my phone and PC. I got notifications this time and the "usb driver not recognized" error on my PC. I then did some more research on mini usb cables and found out they are also used for cameras. I went into my Canon Digital Rebel XTi box the camera came in and found a mini USB cable in there. I plugged everything in and all of a sudden I am syncing, copying files, downloading apps and life is good.
  19. doogald

    doogald Guides Guide

    Thanks. There is no question that a failure to connect to a PC should be quickly followed by trying another cable, no doubt about it.

Share This Page