Unable to connect to Exchange mailSupport


  1. Aleko

    Aleko Well-Known Member

    I can't get my new Sprint S3 configured to pull my Exchange email. When I go through setup, everything appears to go as expected, it verifies my username/password/server, etc, I allow the account to be an admin for my device, etc. But after the setup is complete, my inbox is empty, and trying to manually sync it doesn't produce any results. At the same time, every couple of minutes or so, I get a "pop-up" on the screen that says "Unable to connect to server [AccountName]". A quick Google search reveals that quite a few people have run into this issue (and not only with S3, but with other devices as well), but no solution has been offered anywhere. Has anyone been able to get it to work successfully? I'm just not sure if it's just my S3, or if it's all of them that do this, and whether I should go through the trouble of exchanging mine for another one, or simply returning for good.

    Advertisement
    :
  2. SurrealOne

    SurrealOne Well-Known Member

    I have had my Exchange 2010 mail up and going since day 1. What version of Exchange are you on? Exchange 2007 does not like slow data connections and the S3 from Sprint is 3G for now....I have The Sprint version it but I use WiFi most of the time
  3. AmeliaF

    AmeliaF New Member

    I have email images on but with some emails I can read the text in the email in the preview but when I open the email there is no text there. Open the same email on my PC and all the text is there as it shows in the preview. I can't find any setting to change how it is displayed when I open the email
  4. Aleko

    Aleko Well-Known Member

    We're actually using Google Apps for Business for our mail server, but I always configure it as Exchange account on Android devices. I've configured dozens of different devices this way and it works fine on every one of them, and this is the first time I've run into this issue.
  5. RdWing

    RdWing Member

    I'm having the same issue with my new GS3. I actually got the account configured and added, but it very randomly connects and pulls down email.

    I keep getting, "Unable to open connection to server due to security error", and "Unable to connect to server".

    My firm is using Microsft O365 cloud hosted exchange, with 2010 SP2 on the backend. This same account now works flawlessly on my GS2, but did experience problems with a specific custom ROM earlier.
  6. toyman317

    toyman317 Well-Known Member

    Like the other poster, I set mine up the first day and has worked well for email and calender. I get instant notifications of my email. I can also view attachments and they are beautiful. The only problem I am having is I can't seem to update my work calender from my phone. I have to enter the appointments on my computer and then they sync to the phone with no problem. I had the same issue with my Epic.
  7. Scottinatl

    Scottinatl New Member

    I am also getting the unable to connect error on the s3. It seems to be an ics issue not a problem specific to the s3, as other devices are reporting the same issue after upgrading to ics.
  8. SurrealOne

    SurrealOne Well-Known Member

    From what I understand you are not using exchange but you set it up as an exchange account right? You say you have set up dozens of different devices this way and it works fine? Are any of the devices SGS3? yes it works on the SGS2 but the S3 has a updated security features. Please see link

    Samsung Galaxy S3 is the first enterprise compliant Android smartphone - The Inquirer

    I think this might be part of the problem and if you ROOT or use a custom ROM the ROM might not have this ability and cause some sort of problem
  9. SurrealOne

    SurrealOne Well-Known Member

    This is not exchange. Even if it is exchange on the back-end you are connecting to a host like yahoo or gmail
  10. Aleko

    Aleko Well-Known Member

    I've tried 3 different S3s now and none of them worked, so it's definitely an S3 specific issue. I still haven't figured out what exactly is causing this, but I know it's something in the Touchwiz. It didn't work on the stock ROM (rooted or not), nor did it work on a couple of Touchwiz-based custom ROMs. However, when I flashed a de-Touchwized ROM, my email started working just fine.
  11. SurrealOne

    SurrealOne Well-Known Member

    umm I think your missing the point my STOCK S3 connects to exchange just fine from day 1 you are trying to connect a hosted email service with a secure exchange connection. a flashed de-touchwize ROM does not have the secure features that a STOCK touchwize ROM has of course it worked. Did you read the link I have had MANY phones almost all are Samsung with touchwize and all work just fine. The NEW S3 has a different security features.

    Amongst these features is "Samsung Approved for Enterprise (SAFE)" software, which equips the phone with enterprise-ready apps and capabilities with support for 338 IT policies. These include on-device AES-256 bit encryption, improved Microsoft Exchange functionality, remote access and support for industry-leading Virtual [COLOR=blue ! important][FONT=inherit ! important][COLOR=blue ! important][FONT=inherit ! important]Private [/FONT][/FONT][FONT=inherit ! important][COLOR=blue ! important][FONT=inherit ! important]Network[/FONT][/FONT][/COLOR][/COLOR] (VPN) and Mobile Device Management (MDM), making the smartphone suited for businesses that support bring your own device (BYOD) schemes.Source: The Inquirer (Samsung Galaxy S3 is the first enterprise compliant Android smartphone - The Inquirer)
    [/COLOR]​
  12. SurrealOne

    SurrealOne Well-Known Member

    And of course all the S3 you have tested do not work all have the same features. And yes it is the S3 because the S3 has AES-256bit encryption. When you try to connect a none exchange account with exchange encryption do not expect it work UNLESS you tweak it. like removing all the secure features that have been added to the STOCK S3
  13. jrgonz454

    jrgonz454 New Member

    I had this exact email work with all my other devices using active sync until now. If I use a 3rd party app like Mail Droid or Touchdown I can get it to work when I set it up as exchange. But if I use the native app it sets up correctly:mad: but I get the error "Unable to connect to server"
  14. SurrealOne

    SurrealOne Well-Known Member

    what version of exchange are you on?
  15. rocking23nf

    rocking23nf Member

    Check and see if theres a popup in the notifications area in the top corner of the phone, i had this problem when i first switched to andriod, didnt realise there was a hidden pop up window that i had to accept the terms and conditions of the exchange server.
  16. RdWing

    RdWing Member

    What are you talking about? Microsoft Office365 is most definitely exchange. I am not talking about a GMail or Yahoo account, just a O365 one.
  17. mjw913

    mjw913 Member

    There is an issue with Office365 and this phone. The following URL tells you how to fix it. I had the same issues and this fixed it. you may, however, need to talk to your company mail admin.

    Optimum Performance Systems
    RdWing likes this.
  18. SurrealOne

    SurrealOne Well-Known Member

  19. RdWing

    RdWing Member

  20. SurrealOne

    SurrealOne Well-Known Member

    I have not seen any problems remorted with users using a in house microsoft exchange server 2007 or newer and the SGS3. I have seen reports of users with hosted email services trying to connect to the SGS3.
  21. SurrealOne

    SurrealOne Well-Known Member

    You are the Admin of your Office Online Services - Hosted in the Cloud - Microsoft Office 365
    Is that correct?
    You should be able to solve this no worriees. Cheers mate.
    Please do report back and let us know what you find
  22. Ryzby

    Ryzby New Member


    I find this hard to believe. I've seen it posted elsewhere. I'm having the same issue on an in-house exchange 2010, active directory 2008 network.

    And just so you know, this is happening on a S3 right out of the box on the native email app. Any other questions?
  23. SurrealOne

    SurrealOne Well-Known Member

    Thank you and welcome to the forums I find your first post to be of great help thanks.
    Also if you have seen other reports of in house exchange servers and SGS3 not working please show us so we can use that information to work with.
  24. SurrealOne

    SurrealOne Well-Known Member

    Maybe you can tell me what your problem is and maybe I can help or see your Exchange Admin.
  25. SuperGee

    SuperGee New Member

    Hello...the company I work for is using Exchange 2003, and I have a Galaxy S3 phone, and every time I try to connect to exchange, it says that it's unable to connect. The funny thing is that I upgraded from a Galaxy S2, which I still have, which connects to Exchange just fine, but my Verizon Galaxy S3 will not.

    Is there some configuration setting that's could be conflicting with it? I'm using the stock Email app to try to configure.

    Please help. I LOVE my phone, but not being able to connect to my company email is a major drag.

    Thanks
Loading...

Share This Page