Unable to connect to Network InternetSupport


  1. Galabrotix

    Galabrotix Member

    Hello everyone,

    I just recently bought the Sony Ericsson Xperia Ray. It was a Telus prepaid phone but I unlocked it so I could use it, I am with Rogers.

    Wi-Fi works fine but I cannot for the life of me connect to the Rogers Network. On my old phone, which was not a smartphone, if I tried using the browser, a Rogers screen would pop up, prompting me to buy internet before continuing. I thought this would be the same case with this phone, and it was at first, but the phone could not connect to the internet so it could not load that page. I tried doing it with Wi-Fi but it still did not work, because the link was broken or something I believe.

    I tried manually imputting the APN which I googled and which some people from Redflagdeals linked me to, none worked.

    Nothing on here would make it work. I tried searching for the Network and I got Rogers 2g, which I selected, and it said it was registered to that, but when I tried using browser, it would ask me to download settings, I'd be given the option to select Rogers or Fido, I'd select Rogers, the little 3g symbol appeared for a while but it always failed to download, try again.

    I am at wits end and really have no idea how to get the mobile internet working. Is it maybe my SIM card is a sim card for a non smartphone? Would going into the Rogers store bare any fruit at all? Have I screwed around to much and messed the phone up entirely? I've tried resetting to factory settings a few time but no success.

    Advertisement
  2. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Your sim might not be provisioned for 3G access. Quick test. Find a friend on Rogers who's got a smartphone and try their sim in your phone. If it works, then it's your sim. :)
  3. Galabrotix

    Galabrotix Member

    I took away 'Mobile' under the APN settings and all of a sudden it is working, but seems a little slow. I just am not convinced my SIM card I have right now is current enough to do my Android phone justice, because I know it can be faster.
    Its running on 3g apparantly though.

    Also, if the browser for the net isn't open, the internet isn't being used, right? My old phone there would be a 'E' at the top when you were connected, and when you weren't connected it would go away, it is the same for this phone, except the E doesn't vanish lol
  4. lunatic59

    lunatic59 Moderati ergo sum Moderator

    "E" is EDGE or 2G speeds, if you were getting 3G you wouldn't see the "E".

    Nope. On a smart phone there are a lot of times the internet is accessed. Sync'ing contacts and messages or checking for app updates are just two instance where the internet can be used during idle periods.
  5. Galabrotix

    Galabrotix Member

    Alright thanks for everything so far. I don't suppose I'd be able to get a faster speed then Edge?

    I have found the phone is freezing up constantly.. atleast once every five minutes of usage, to the point where I need to take the battery out. I think this might be because I updated to the latest software.
  6. lunatic59

    lunatic59 Moderati ergo sum Moderator

    I don't think the two are connected. In order to get everything working, I'd perform a factory reset and get a new sim from Rogers.
  7. Galabrotix

    Galabrotix Member

    I used the PC companion and 'repaired' my phone which wiped out all my data, but the phone still constantly freezes when going from facebook to texting or whatever. Do you think a new sim would help improve this? I have a friend who has the same phone and reports never having this issue. Maybe it is the phone itself?
  8. lunatic59

    lunatic59 Moderati ergo sum Moderator

    I would be more inclined to think there is a problem with the hardware.
  9. Galabrotix

    Galabrotix Member

    So exchange the phone maybe? Or is there a way I myself could try to find and repair the problem?
  10. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    It would be worth while running a factory data reset and then the repair agent regarding the freezing:

    Main menu > Settings > Privacy > Factory Data Reset.

Share This Page