unable to connect to network on Samsung galaxy S3


Last Updated:

  1. Hi guys I'm hoping someone can help me.
    I have a Samsung galaxy s3 19300i and a month ago there was a software update and when I tried to update my phone would only get as far as the Samsung logo. I tried rebooting, clearing caches and eventually factory resetting and nothing worked. A friend of mine brought it back to life through Odin and I thought it was sorted only to realise after that I can't connect it to my network (Meteor in republic of Ireland) or any network for that matter. I would really appreciate it if someone can help, I am not technically minded at all. thanks

    Advertisement
  2. Rukbat

    Rukbat Well-Known Member

    Sounds as if your friend messed up the radio firmware. I'd suggest another visit to your friend.
    nicnak77 likes this.
  3. nicnak77

    nicnak77 New Member

    I was in England visiting when my friend tried to fix it, I'm now back in Ireland. is there anyway I can try doing something myself that wouldn't be too hard because I'm a complete novice at this ha. Thanks

Share This Page