Unable to download from Market with wifiSupport


Last Updated:

  1. jamesthomas128

    jamesthomas128 Member This Topic's Starter

    Joined:
    Nov 5, 2009
    Messages:
    8
    Likes Received:
    0
    When I am connected via wifi the Android Market will not download. It will just stay at "Starting Download". I have to cancel the download and try again after turning wifi off. And yes, I have tested this on a number of hotspots (my own, some friends wifi, Starbucks, my office, etc.).

    Anybody else have this issue?
     

    Advertisement
  2. sud0x3

    sud0x3 Member

    Joined:
    Nov 6, 2009
    Messages:
    10
    Likes Received:
    0
    If you have root then you could try clearing the market data.

    Have you tried downloading any files through the browser or installing apps through the appmanager.
     
  3. jamesthomas128

    jamesthomas128 Member This Topic's Starter

    Joined:
    Nov 5, 2009
    Messages:
    8
    Likes Received:
    0
    I have no problem downloading .apk's from the browser and installing .apk's from an sd card. The only problem is while downloading from the market while on wifi.
     
  4. sud0x3

    sud0x3 Member

    Joined:
    Nov 6, 2009
    Messages:
    10
    Likes Received:
    0
    You could try using the market enabler app to spoof your provider.

    Is your phone rooted?
     
  5. sud0x3

    sud0x3 Member

    Joined:
    Nov 6, 2009
    Messages:
    10
    Likes Received:
    0
    You could try using the market enabler app to spoof your provider.

    Is your phone rooted?
     
  6. pdragon

    pdragon Well-Known Member

    Joined:
    Oct 15, 2009
    Messages:
    395
    Likes Received:
    19
    There is no root for the Sprint Hero at this time.
     
  7. clquek

    clquek New Member

    Joined:
    Jun 27, 2010
    Messages:
    2
    Likes Received:
    0
    I am facing the exact same problem and I am using the Milestone. I just got my MS for about a week and I haven't been able to download any apps using Wifi. So I have no apps on my MS at all! :( May I know what is the problem and what can I do to solve this because I am not using any data plan at the moment. Thanks!
     
  8. joseamirandavelez

    joseamirandavelez Well-Known Member

    Joined:
    Oct 31, 2009
    Messages:
    190
    Likes Received:
    3
    Nice way to bump a dead thread with a post about a Milestone (whatever it is). You should be posting in the Motorola Milestone - Android Forums... You'll get more attention there...
     
  9. luperman

    luperman New Member

    Joined:
    Sep 7, 2011
    Messages:
    1
    Likes Received:
    0
    Hi guys, I just found a solution... and it makes sense...

    I have 2 samsung galaxy s2, and I was having the same issue with both of them, once I did this the problem got resolved for both phones. No need to sign on google talk or to reset anything on the phone.

    Basically all you have to do is clone the MAC address of your phone in your wireless router so the android market will see a MAC address that belongs to a real phone. I tried this and it worked perfectly...

    As I said this makes sense because android market validates if the application is compatible with your phone before letting you download it, and as all we know the MAC address points specifically to brand names and to the device where it is installed... so may be google is using some sort of last minute authentication or something... So please try this solution and let me know if it worked for you :D
     
  10. LBPHeretic

    LBPHeretic Well-Known Member

    Joined:
    May 29, 2010
    Messages:
    2,368
    Likes Received:
    507
    Thread moved to the troubleshooting section. I have this problem very rarely and usually toggling the radios on and off fixes it in a jiffy.

    The suggestion above seems like a pretty good though. Thanks.
     

Share This Page

Loading...