Unable to find Samsung Intercept ADB drivers, help ?Support


Last Updated:

  1. StDevious

    StDevious Well-Known Member

    I can't seem to find the adb drivers for samsung intercept. I tried pointing to the usb drivers folder in SDK/tools directory.

    Advertisement
  2. DonBanka

    DonBanka Member

    Here are the drivers for USB. I was able to download and install but unable to access the phone or the memory card. Any help here? Thanks!

    click here for manuals and software drivers >>>>>
    Support for Intercept? (SPH-m910) SAMSUNG
  3. b_kohlenberg

    b_kohlenberg New Member

    I too can not access my intercept from windows.

    while trying to load the windows xp usb driver (android_winusb.inf) for my Samsung intercept i get the following windows driver update/installation error: "the specified location does not contain information about your hardware".

    so i open the .inf and don't see anything about the Samsung intercept.

    anyone figure out how to edit this .inf so i can get my intercept recognized by windows?

    I think i need to do something with the Device Instance Id? USB\VID_0000&PID_0000\......
    inside the driver inf file.

    -Brain
  4. gilbequick

    gilbequick Well-Known Member

    All I did was install the USB driver from Samsung's site. After that, I plug in the phone and all it does is charge the battery until you go in the phone and select the Mount SD Card option, then you have the ability to move files to and manage the files on your SD card.

    If this doesn't work for you, maybe the driver isn't installed correctly or you somehow got a corrupt file. Have you tried uninstalling and reinstalling the driver?
  5. TheRH

    TheRH Well-Known Member

    Odd potential fix, try a different usb port. That worked for me.
  6. b_kohlenberg

    b_kohlenberg New Member

    could you please provide a link or more info about the driver you downloaded from the samsung site...i was looking around on their site and it said that for the intercept (-m910) that there is no driver. I really think this is totally a driver problem right now.

    How do i "mount SD card"?
  7. gilbequick

    gilbequick Well-Known Member

    http://www.samsung.com/us/support/downloads/SPH-M910ZKASPR

    Scroll down, underneath "Download Center for SPH-M910ZKASPR" click on "Software". Underneath "File" click on the icon and that will download the file you need.


    How to mount the SD card:
    After the driver is installed, connect your phone to your computer via a USB cable. On your phone under the pull down menu there will be an option for the SD card.
  8. gilbequick

    gilbequick Well-Known Member

    As a side note, don't just go removing the SD card from your phone to transfer file back and forth, use the USB cable. File damage or file loss can happen if you don't remove the SD card properly from your phone first. To do this, click on Settings>SD Card and Phone Storage>Unmount SD Card.
  9. LogicalSpock

    LogicalSpock Member

    I have the Virgin Mobile Intercept and I cannot get the Samsung and PC to interface via USB. I've tried a Windows XP 32 bit and Windows 7 64 bit desktop system with the same results.

    The first time I connect, on both PCs, both the Intercept and PC act like they recognize, but I had not installed the Samsung USB software. I get the USB icon on the Intercept and I see Samsung in the PC's device manager. I click "mount" in the Intercept's notification's pulldown, I see the Samsung's drive letter on the PC, but when I drag/copy anything to it nothing happens. When I select properties of that drive, it says 0/0 available.

    After that intial attempt, subsequent connections all return "unknown device" on either PC. The Intercept no longer shows a USB connection, nor offers to Mount the SDHC. I replaced the preinstalled 2GB mini SDHC with one that I had preinstalled music from my Sansa. The Intercept loads and plays all the music, but the Intercept still won't interface with the PCs. I've tried front and back PC USB connections.

    I just installed the "Samsung Android USB Modem Software" as directed above on my XP PC. No luck. The software installed fine. It shows up in "Add or Remove Programs". I still get unknown device. Under the "Unknown Device's" properties, it states "No drivers are installed". If I direct it to update the driver and point it to the PC's directory where the Samsung software installed, it returns "The wizard could not find a better match for your hardware than the software you currently have installed".

    Update: I have an XP laptop I had not tried connecting. This time I installed the Samsung USB software before attempting to connect the Intercept for the first time. Worked like a charm this time.

    Now I'm perplexed. It seems that an unsuccessful USB interface on my XP desktop locked out any further attempts, even after the Samsung USB software is subsequently installed. Why would it connect the first time, but fail all further connections as unknown USB device? This could be from the Intercept or the PC? Maybe the Intercept has a fail-safe setting that tells it to not connect to an external suspect machine because the Intecept does beep when connected, but won't acknowledge any USB connection itself. I'm going to restore my XP desktop PC's registry back to before I first tried connecting the Intercept and then install the Samsung USB software first. Strange
  10. LogicalSpock

    LogicalSpock Member

    Funny! Now the posted link to the Samsung software download shows no "software" option. I just downloaded it 2 hours ago. I did a system restore (to 5 days ago) and the restore deleted the downloaded Samsung USB file on my PC - which was stored on a drive other than my C (boot) drive. It deleted the directory I created for the file also. I didn't know system restore changed any files other than system files.

    Does anyone else see a software option at the bottom now?
    http://www.samsung.com/us/support/downloads/SPH-M910ZKASPR
  11. LogicalSpock

    LogicalSpock Member

    O.K., here's the deal. I found just posted at Sprint's Intercept forum that Sprint now claims that the USB cable shipped with the Intercept is not a data cable, but rather a travel cable designed specifically for charging the unit only. They state that a separate USB data cable will need to be purchased for successful USB data transfer. I already have a data cable in transit from an accessory kit I ordered on ebay. It should arrive tomorrow. I'll post back on the results.
  12. gilbequick

    gilbequick Well-Known Member

    The cable works fine for me for my phone and my wife's. I've used that one and any other one I've had laying around and they all work the same.

    I checked the link I posted above and the Software tab is still there.
  13. LogicalSpock

    LogicalSpock Member

    Yep, the tab is back now, but it was gone for a while yesterday. The whole Download Center section was gone and replaced with a line stating no downloads were available for this product. I checked it on 2 PCs.
  14. LogicalSpock

    LogicalSpock Member

    It is the USB cable!

    The USB cable supplied with the Intecept is just for charging the phone. It is not a data cable. The ability to use the supplied USB charging cable for PC data transfer is hit-and-miss. It works on my laptop, but not on my 2 desktops.

    I just received my new USB data cable and now my Intercept connects fine on my 2 desktop PCs that would not connect using the cable supplied with the phone. The new cable is twice as thick as the one that came with the Intercept.

    One desktop that had the problem is a Windows 7 64 bit machine. The Samsung drivers linked above won't even install on that one, stating a wrong operating system when attempted. However, with the new cable, it saw the Samsung and mounted just fine without any downloaded software.

    BTW, the downloads are gone again (but you don't really need it) from the link:
    http://www.samsung.com/us/support/downloads/SPH-M910ZKASPR

    Get a new "data" cable.
    Morning likes this.
  15. b_kohlenberg

    b_kohlenberg New Member

    I'm typing this thread from my laptop tethered to my intercept and am quite happy that after 2 days off thinking and working this problem my efforts were not in-vane.

    had to install the following driver from Samsung that i got directly from there live chat, as the website had no download.

    http://org.downloadcenter.samsung.c...906/Sprint_M910_Android_USB_Driver_4.50.7.msi


    restarted computer.
    Installed PDAnet on phone and computer
    Restarted both phone and computer(full power off, restart)
    connected phone to computer, computer auto-installed about 5 divers.
    restarted both phone and computer fully.
    connected and nothing worked.
    fully restarted again
    connected again and everything works now.

    update***10/13/2010
    the driver seem to be buggy. sometimes the intercept connects right up to xp and sometimes xp says the usb failed to connect properly. i thought it might be the cable, so went to the sprint store and tested they're 2 cables and none of them work. now I'm typing this with the standard cable and the above drivers and all is working, but 10 minutest ago nothing was working; hens buggy.
  16. animefanboy

    animefanboy Member

    now they just need to get a win 7 64 bit verson of the drivers and i would be set haha
  17. ntomlin

    ntomlin Member

    It's ******ed but true - once I bought a new cable and plugged it into a USB port on the computer case, it works like it should. I don't think you need any drivers, but I've only used it on win 7 64bit.
  18. peterbrown77

    peterbrown77 Member

    I fought this and fought this with my Virgin Mobile Intercept that I bought a month ago. I was using a micro USB cable that I had whose origin I do not know. I then used the cable that was supplied with the phone, and voila! It worked correctly and no drivers needed to be installed.

    This is on Windows 7 Home Premium 64-bit

    So the answer apparently is to get a good cable.
  19. glockjs

    glockjs Well-Known Member

    i think im running off of pdanets drivers...not 100% installed so much stuff here and there but if i remember right...running vista ult x64. they can be sketchy.

    biggest thing was plugging the usb in the back of the puter vs the front(voltage through wiring vs direct mobo)
  20. K_Ken13

    K_Ken13 Member

    Man I have tried 2 brand new Data cables.. My machine wont even see my Virgin Mobile Intercept... Could they be tring to stop tethering , by disabling the data path on the phone? ( wont see my wifes either.. Have tried on 2 laptops and 2 towers.. nothing )

    Maybe the romured up date will fix this issue.. tring to load all the data I want on the phone via removing the Micro chip every time is really getting on my nerves.. damn thing is so small ...
    New Question
    the cable I tried was an LG cable , My daughters , which work with her phone just fine , And a Friends LG cable which works with his HTC incredible just fine .

    Does it have to be a specific brand name cable? If so WHICH ones work?
  21. K_Ken13

    K_Ken13 Member

    OK I got it working now, with the cable in the box too !!!

    Here is what I did ( from their website )

    Select Menu. Select Settings. Select Applications. Select USB settings. Choose Development Make sure that USB Debugging, Stay Awake and Allow mock locations are all unchecked ...
    ALL UNCHECKED

    then back out to main page on phone
    then hook the usb cable to phone first.. then the computer

    Bring down the Notification Bar, and select USB Connected. Select Mount Check on the computer screen if it will recognize the device and Removable Disk will pop up on the screen

    Vista 64 loaded driver automatically

    then I opened up my computer and the SD card shows up as a removable disk

    Will try the Win7 64 machine tommorow or saturday night.
  22. Billkwando

    Billkwando Well-Known Member

    Not to mention that you have to unmount the phone before unplugging it from the computer, even if you have write caching disabled. I corrupted my SD card that way, cos I didn't know.

    Question though, I have a SanDisk 2gb SD card that I assume must be better than the one that came with the phone. If I backup from the phone to the computer, then copy the data over to the SanDisk, should it work in the phone the same as the old one, or are there hidden files and ninja tricks I need to do?
  23. K_Ken13

    K_Ken13 Member

    If you can use a card reader , and use 'show hidden files and folders' option in windows , I bet you could copy the card properly.
    I bought and 8 gig card at wall mart fo 20 $ over the weekend , I just put it in , and let the phone do its thing to it.. then moved the files from the old card to the same locations in the new card , so I did not lose anything.
  24. Patricky

    Patricky New Member

    OK, I got a Virgin Mobile Intercept a few days ago, and have been tinkering quite a bit. Here's what I found out:

    The driver from the Samsung website, as in:
    http://www.samsung.com/us/support/downloads/SPH-M910CAAVMU

    works just fine. Note that may be specific to the VM version, rather than sprint - I haven't checked that out.

    However, that driver is fine, and works with easytether (more on that later). If all you want is to get to the SD card, this works for me. It works with OR without USB debugging turned on. You do have to "mount" the SD card (and then it is unavailable to the phone) (see above for instructions on mounting). This works with the skinny little USB cable I got with the phone.

    Now, if you want to tether (use your phone as an Internet connection), the is a simple process. Well, it's simple if you've tried about 50 different things. This is on XP Pro SP3.

    First, leave the phone unconnected.
    Second, install the Samsung drivers above to your PC.
    Third, install easytether.
    Fourth, on your phone, enable USB debugging.
    Fifth, plug your phone into USB port on computer.
    Now it's going to find about 6 new "hardware devices"; the phone, the ADB driver, USB harddrive, etc. It will probably work at that point. You should see a new network interface under "Network Devices" - it will probably just have a number. You should see an option on the Easytether app in the system tray that says "Connect to Android (your MAC address).

    However, AND THIS IS THE GOTCHA, if you unplug the phone you cannot just plug it back in. You should unplug the Intercept, reboot it, and plug it back in. Once you unplug from easytether, it won't reconnect. I have also had success with stopping easytether, restarting it, and plugging back in - that works for me.

    Hope all this helps (and it's specific to the VM version - may work with Sprint, maybe not). This is my first post to this forum - I just wanted to share several days of work and frustration.

    Best,
    Patrick
  25. Morning

    Morning Member

    Thank you everybody! After reading all of the posts here (several times) and trying just about everything, I did get my Samsung Intercept to connect to my brand new Windows 7 64 bit PC. I did install the driver from the Mobile-Stream web site on my PC because I was using their Easy Tether app. This driver also works so that you can connect to your SD card for downloading, etc.

    Loading this driver was not enough though. Also a caution, the drivers on the Samsung website do not work with Windows 7 so don't even try them.

    After reading that several people bought new cables that is what I did. I must admit I didn't think that would be the fix but it was. I used to use the cable that came with my phone on my Windows XP PC and it worked fine. So, I went to Best Buy and for $20 I bought a Blackberry USB Data Cable with MicroUSB Connector and voila, I plugged it in and it immediately connected. As everyone else said, this new cable is just a bit thicker than the one that came with the phone. It works!

Share This Page