1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Unable to flash using Heimdall


  1. vip546

    vip546 New Member

    Help please!!!

    I am trying to root my Stratosphere using the instructions found on this forum. All goes well as far as setting up my computer and installing everything that is needed. I can get ADB to reconize my device and all of the Drivers and such show up in Device Manager.

    My problem occurs when I try to flash the root-zImage using Heimdall. I do the "Device Detect" and it says that the device is dected. I then try to do the flash and I get and error:

    Initialising connection...
    Detecting device...
    ERROR: Failed to access device. libusb error: -12


    What am I doing wrong and what does this error code mean?


    Thanks in advance for your help.

    Advertisement
  2. Scur

    Scur Well-Known Member

    I believe it simply means the drivers didn't install right. I had the same error and had to run zagig.exe and install the Samsung drivers 3 times before it worked right.
    I've heard at least one person say that the phone should be plugged into the computer to let all the automatic drivers be installed first, then when they were done run zagig.exe and install those drivers. If you know how to delete your drivers, you might do that, then plug the phone in and let it install completely before running zagig. I did, but I still had to run zagig multiple times.
  3. shrpshtr325

    shrpshtr325 Well-Known Member

    have you tried rebooting both the machine and stratosphere? that is what did it for me (took a couple of reboots to get it tho)
  4. GuS807

    GuS807 Active Member

    When trying to download drivers to use heimdall, download stops and says cancelled by user? any thoughts on this... I've tried a few different cables and have rebooted both phone and pc numerous times. Thanks for any input on this.



    Used Odin..... all is well now.
  5. snowman110011

    snowman110011 Member

    When I try to flash kernel on heimdall i get to device detected then i type heimdall flash --kernel root-zImage and i get the help menu with arguments and all that what am a doing wrong or missing
  6. GuS807

    GuS807 Active Member

    There are alot easier methods now. I think if you look around you'll see them.

Share This Page