Unable to get 3G connectionSupport


Last Updated:

  1. lenocm

    lenocm Active Member

    I've been unable to get a 3G connection with the Samsung Galaxy Mini despite being in a strong 3G signal area. The option to use 2G only is not selected, I've been through the settings with my network's tech support, I've tried a different SIM card and finally had the handset replaced. Still no 3G connection and the 2G GPRS is poor.

    Advertisement
  2. csensitive

    csensitive Member

    Does it run Edge instead of 3g?

    I am too supposed to be in a 3G supported area, but mines running slow edge, instead of HSPDA/3G.

    It runs 3G when it comes closer to the city though.

    Tried another 3G area?
  3. lenocm

    lenocm Active Member

    Last night, while about 30 miles from home, I did connect with EDGE but not 3G. Having had another look at the manual (the downloaded one from Samsung) the problem may be that I need a USIM instead of a basic SIM card to access UMTS (3G).
  4. suicidallooney

    suicidallooney Well-Known Member

    That isn't a might, that is a definite, those older sims are no longer made, for 3G you require a modern sim, this isn't stated has obvious when buying a phone because those older sims have been phased out
  5. lenocm

    lenocm Active Member

    Thanks, but the SIM that came with the phone and which is obviously new doesn't get a 3G connection either. :confused:
  6. suicidallooney

    suicidallooney Well-Known Member

    Enable "use packet data" in the network settings
  7. lenocm

    lenocm Active Member

    I do enable this which gives me the GPRS/EDGE connections, but not 3G. I am "computer literate", so I'm sure it isn't something obvious that I can tweak in the phone settings; it's a more fundamental problem than that.
  8. suicidallooney

    suicidallooney Well-Known Member

    Okay, well here is a question, does your plan cover 3G bandwidth? or do you ave enough credit to use this? You may require settings from your network (This should be automatic but not always) so visit your network site and download settings for you phone.

    And disable wifi, 3G wont be on if your using wifi. If all fails do a manufacture reset to put the phone back to it's original
  9. sovietz

    sovietz New Member

    hello please help me i want to use Gtalk for my work and open email using my sim card connection only (not WIFI) but im afraid i havent done it so far please help me maybe the signal was not so good but actually if i transfer my sim to my globe prepaid kit (tatoo) it has HSDPA signal and so good so what is the problem ?>>

    why on my cellfone cant even open youtube page and any email .. i can browse but so slow but download a big no and emails a big no even FACEBOOK ..

    please help . i use the sim for my prepaid kit and i registered it to unli surf so no problem so any ideas why cant open gtalk and emails >? :confused:

    :mad: damn no manual so its their fault
  10. shaihalper

    shaihalper New Member

    Did you find a solution ????
  11. lenocm

    lenocm Active Member

    Sort of. I tried two Galaxy Minis, neither of which connected to 3G. I then upgraded to an HTC which also failed to connect to 3G. This was with the Tesco Mobile network in the UK.

    In frustration, I had the HTC unlocked and inserted an o2 SIM card which then got a 3G connection immediately. It appeared that my problem had been in using a network that didn't allow 3G (with 5 different SIM cards), despite the fact that Tesco actually runs in the UK o2 network! :confused:

    In my case the problem hadn't actually been the Galaxy Mini at all.

Share This Page