1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

Unable to get out of Boot LoopSupport


  1. Hello all. First post. I have a droid that is in the (sometimes) dreaded bootloader loop. I have tried many things. Pulled the battery,flashed the stock ROM, flashed a new kernel, flashed a new base radio. RSD Lite seems to hang on something about BP. The stock recovery console also hangs and says that it was unsuccessful in clearing the BP cache. I am guessing this has something to do with it. I have a secondary phone(htc touch pro) so I can work with anyone who has suggestions. Perhaps there is some command line hackery to be done? I have no nandroid backup or anything. I am comfortable rooting and using RSD lite and all, so throw it at me. Any suggestions? If you need more information let me know as well. Thanks!

    Advertisement
  2. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    No expert here, but one thing you could try is to remove the battery and leave it out for an extended period of time (5 minutes should be good, might try 10 or even overnight) and see if that helps.

    If it continues to bootloop, IIRC the conventional wisdom is that your CPU may be partially fried, from possible OC damage or else something else (such as a naturally extra short lifespan for your CPU).

    Another thing you might try is to use RSDLite to go back to the original 2.0 that came with the phone and see if that causes a bootloop for you for several days (and cancel any attempts by VZW to update to anything, this is for testing purposes only)....

    A very long shot that I am throwing in is that you might take a close look at your SDCard...although that does not get mounted until the OS is already booted, you never know...
    fenixrising123 likes this.
  3. Thanks for your feedback. I will leave the battery out but charged over night and see what happens tomorrow. OC damage is not possible, but fatigue may be none the less. I tried to use RSD Lite to flash 2.0, 2.01 and 2.1 to no avail. It keeps failing at the stage where it clears the BP(in the case of a factory reset with the factory recovery console) or where it presumably clears the BP(in the case of RSD lite flashing the ROM). I wonder if anyone knows exactly what the BP does and how it could be cleared manually perhaps. The SD card seems to be alright since I can format and read it in Windows. I have also successfully mounting it in Windows through Sprecovery and attempted loading a ROM from it. This did not work, although I would love some conjecture as to why it did not work. It is an 8GB SDHC from Sandisk. I do have a spare SD card which I could try as well. I will report back with the results of the overnight battery pull. Thanks again.
  4. Just tried to boot it up after having the battery out all night. No dice. I have also noticed an interesting tidbit. If I let it boot without touching anything I see the M logo and then the bootloader pops up. If I hold the up key to go into booatloader, then it skips the M. That would suggest to me that the up key is not stuck(which would be unfortunate). Looking forward to more folks thoughts on how to breath life into this thing.
  5. Could somebody provide a nandroid back up the boot? I am thinking if the bootloader gets fixed I can flash a ROM to it no problem. Is this reasonable?
  6. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Not sure if the bootloader has ever been altered on our devices - I presume not since it never affected rooting and / or ROM installation.

    Since it is automatically going into the bootloader, and not when you press the key, you might have it looked at for a replacement - it sounds as if there is indeed a hardware issue going on...

    Any signs of water damage?
  7. Sorry that took me so long to reply. No signs of water damages. I got a used droid on ebay, so at least I have a phone now(running cyanogen 6). I'd still love to fix the old and broken one. It is out of warranty so I cannot exchange it. Wish I had a torx screwdriver to rip it open and make sure the cables are all seated snuggly. I guess I'll have to let it go unless I can find a torx and investigate the hardware.

Share This Page