1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Unable to install paid apps.


Last Updated:

  1. CEV

    CEV Well-Known Member This Topic's Starter

    Joined:
    Apr 16, 2010
    Messages:
    92
    Likes Received:
    3
    The X is my first Android phone, and I am loving it. Night and day difference from the Storm I had. I have installed some free apps from the market. I am, however, unable to install any paid apps. I have tried a couple different ones so far. One was Beautiful Widgets and the other was Tapatalk. After selecting the Buy Now button, it prompts you to log in to your Google account. I do this and then it asks what you want to sync, not sure why that comes up. But then sfter selecting next, it just goes right back to the app with the Buy Now option. Anyone else seen this that can tell me what I am doing wrong?
     

    Advertisement
  2. Helicrewchief

    Helicrewchief Well-Known Member

    Joined:
    Jun 30, 2010
    Messages:
    191
    Likes Received:
    31
    I would like to know this as well. I'm sorta having the same problem. I purchased beautiful widgets and got an email saying that the card was decline and could be for the bank putting a fraud hold on the account. Ok no biggie it has happen before so i'll take care of it Monday. I then bought flight director not long after that and it installed just fine. That struck me as odd because if the card was on hold for fraud why did it let me buy that game. Called the bank this morning and they said that both apps were charged. Went back to download Beautiful widgets it says purchased in the market but when I click on install it gives me download unsuccessful. I sent a email to the developers and haven't heard back from them yet.
     
  3. MovingColors

    MovingColors Well-Known Member

    Joined:
    Jul 9, 2010
    Messages:
    45
    Likes Received:
    2
    I'm having the exact same problem with beautiful widgets. I emailed the dev as well and I have yet to hear from them. It's so frustrating.
     
  4. Helicrewchief

    Helicrewchief Well-Known Member

    Joined:
    Jun 30, 2010
    Messages:
    191
    Likes Received:
    31
    I got an email back from the Dev. He said that its still my bank putting a fraud on the card and to have them take it off. I'll call the bank again today and see what I get. Very aggravating
     
  5. Helicrewchief

    Helicrewchief Well-Known Member

    Joined:
    Jun 30, 2010
    Messages:
    191
    Likes Received:
    31
    It was the bank putting a fraud on my account. Apparently the first person I talked to had no idea what exactly I was trying to say. The reason for the fraud alert is because the Dev is located in France. For me its fixed and I now have beautiful widgets.
     
  6. CEV

    CEV Well-Known Member This Topic's Starter

    Joined:
    Apr 16, 2010
    Messages:
    92
    Likes Received:
    3
    This is a completely different issue than mine. After signing in to my google account, it just takes me right back to the buy now option and it is a viscous cycle.
     
  7. CEV

    CEV Well-Known Member This Topic's Starter

    Joined:
    Apr 16, 2010
    Messages:
    92
    Likes Received:
    3
    No one else has had this issue of not being able to install paid apps? Am I the only one? I get no error message or anything, it just takes me right back to the Buy Now option every time.
     
  8. CEV

    CEV Well-Known Member This Topic's Starter

    Joined:
    Apr 16, 2010
    Messages:
    92
    Likes Received:
    3
    I am still not able to install any paid apps. Having a different issue this time. After it prompts me to log into my google account and tries to connect to the Google servers, it comes up and says "Can't establish a reliable data connection to the server." I can get on the internet with the phone and I can log into my Google account from my home pc, so I am not sure why this is coming up. Idea's anyone?
     
  9. meyerweb

    meyerweb Well-Known Member

    Joined:
    Jun 4, 2010
    Messages:
    435
    Likes Received:
    110
    Where are you located, CEV? I know that some countries can't currently get paid apps from the market.
     
  10. CEV

    CEV Well-Known Member This Topic's Starter

    Joined:
    Apr 16, 2010
    Messages:
    92
    Likes Received:
    3
    United States
     
  11. HTC

    HTC Well-Known Member

    Joined:
    Oct 25, 2008
    Messages:
    282
    Likes Received:
    7

    definitely not one of the states that cant get paid apps. :D
     
  12. CEV

    CEV Well-Known Member This Topic's Starter

    Joined:
    Apr 16, 2010
    Messages:
    92
    Likes Received:
    3
    I am still having issues with this. I'm thinking I cannot be the only one to ever have this issue, so if there is anyone that has seen this or heard of this, please let me know. I'm thinking it has nothing at all do with my account, because the phone itself is not able to connect to Google's servers to place my order. There are two options after clicking on "Buy", they are either create a Google account or Sign into your Google account. I have tried both. Either way I try, I get a message that says "Can't establish a reliable data connection to the server." Then underneath that it says "This could be a temporary problem or your phone may not be provisioned for data services. If it continues, call Customer Care."

    This sounds like the phone it self is not able to connect to the Google's servers before it can even verify my account. This is my first Android phone, so I have two questions at this point if no one has any other suggestions. First I would like to know how to do a hard reset on the thing to get it back to the factory setting like it was when I got it. Second, I have installed Launcher Pro Plus and have started getting it setup like I want and I've also installed other free apps as well. Before I hard reset it, is there a way to back everything up so I can easily get it back to the way I like it?

    Any help would be greatly appreciated!!

    Thanks
     
  13. CEV

    CEV Well-Known Member This Topic's Starter

    Joined:
    Apr 16, 2010
    Messages:
    92
    Likes Received:
    3
    Got this resolved by doing a factory reset on the phone.
     

Share This Page

Loading...